summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-11-24 12:39:18 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-11-24 12:39:18 +0000
commit5eb73679e72b21d469990aae5cedb2d8dc9be2ce (patch)
tree0328d60ef00e9e2008f923d7cdc6e87383cbd4c8 /app-misc/crunch
parentPackage should not depend on dev-lang/perl unconditionally, bug #487406. Than... (diff)
downloadgentoo-2-5eb73679e72b21d469990aae5cedb2d8dc9be2ce.tar.gz
gentoo-2-5eb73679e72b21d469990aae5cedb2d8dc9be2ce.tar.bz2
gentoo-2-5eb73679e72b21d469990aae5cedb2d8dc9be2ce.zip
Initial commit, wrt bug #458122
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'app-misc/crunch')
-rw-r--r--app-misc/crunch/ChangeLog10
-rw-r--r--app-misc/crunch/crunch-3.4.ebuild28
-rw-r--r--app-misc/crunch/files/crunch-3.4-gentoo.patch34
-rw-r--r--app-misc/crunch/metadata.xml11
4 files changed, 83 insertions, 0 deletions
diff --git a/app-misc/crunch/ChangeLog b/app-misc/crunch/ChangeLog
new file mode 100644
index 000000000000..c9e635491fe8
--- /dev/null
+++ b/app-misc/crunch/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-misc/crunch
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/crunch/ChangeLog,v 1.1 2013/11/24 12:39:18 pinkbyte Exp $
+
+*crunch-3.4 (24 Nov 2013)
+
+ 24 Nov 2013; Sergey Popov <pinkbyte@gentoo.org> +crunch-3.4.ebuild,
+ +files/crunch-3.4-gentoo.patch, +metadata.xml:
+ Initial commit, wrt bug #458122
+
diff --git a/app-misc/crunch/crunch-3.4.ebuild b/app-misc/crunch/crunch-3.4.ebuild
new file mode 100644
index 000000000000..a6de4866009c
--- /dev/null
+++ b/app-misc/crunch/crunch-3.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/crunch/crunch-3.4.ebuild,v 1.1 2013/11/24 12:39:18 pinkbyte Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A wordlist generator"
+HOMEPAGE="http://sourceforge.net/projects/crunch-wordlist/"
+SRC_URI="mirror://sourceforge/crunch-wordlist/crunch-wordlist/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~x86"
+
+src_prepare() {
+ tc-export CC
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+ epatch_user
+}
+
+src_install(){
+ dobin crunch
+ doman crunch.1
+ insinto /usr/share/crunch
+ doins charset.lst
+}
diff --git a/app-misc/crunch/files/crunch-3.4-gentoo.patch b/app-misc/crunch/files/crunch-3.4-gentoo.patch
new file mode 100644
index 000000000000..acdc757ef61d
--- /dev/null
+++ b/app-misc/crunch/files/crunch-3.4-gentoo.patch
@@ -0,0 +1,34 @@
+--- Makefile.orig 2013-11-21 11:53:21.835712927 +0400
++++ Makefile 2013-11-21 11:53:42.557713372 +0400
+@@ -16,19 +16,19 @@
+ # General variables
+ PACKAGE = crunch
+ VERSION = 3.4
+-PREFIX = /usr
++PREFIX ?= /usr
+ DISTDIR = $(PACKAGE)-$(VERSION)
+ DISTFILES = crunch.c crunch.1 charset.lst
+ BINDIR = $(PREFIX)/bin
+ BTBINDIR = /pentest/passwords/$(PACKAGE)
+ MANDIR = $(PREFIX)/share/man/man1
+ INSTALL = $(shell which install)
+-CC = $(shell which gcc)
++CC ?= $(shell which gcc)
+ LIBFLAGS = -lm
+ THREADFLAGS = -pthread
+ OPTFLAGS = -g -o0
+ LINTFLAGS = -Wall -pedantic
+-CFLAGS = $(THREADFLAGS) $(LINTFLAGS) -std=c99
++CFLAGS += $(THREADFLAGS) $(LINTFLAGS) -std=c99
+ VCFLAGS = $(THREADFLAGS) $(LINTFLAGS) -std=c99 $(OPTFLAGS)
+ LFS = $(shell getconf POSIX_V6_ILP32_OFFBIG_CFLAGS)
+ INSTALL_OPTIONS = -o root -g root
+@@ -46,7 +46,7 @@
+
+ crunch: crunch.c
+ @echo "Building binary..."
+- $(CC) $(CFLAGS) $(LFS) $? $(LIBFLAGS) -o $@
++ $(CC) $(CFLAGS) $(LDFLAGS) $(LFS) $? $(LIBFLAGS) -o $@
+ @echo ""
+
+ # Clean target
diff --git a/app-misc/crunch/metadata.xml b/app-misc/crunch/metadata.xml
new file mode 100644
index 000000000000..92eb07b23869
--- /dev/null
+++ b/app-misc/crunch/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">crunch-wordlist</remote-id>
+ </upstream>
+</pkgmetadata>