summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-07-13 06:33:11 +0000
committerHans de Graaff <graaff@gentoo.org>2010-07-13 06:33:11 +0000
commitf13bd138c853a071942e8efdb837cf45accac8e6 (patch)
tree007aa90f2181116451a000cfcbb1c44785127e92 /app-misc/booh
parentVersion bump to the latest 195.36.x. Remove older versions that will no longe... (diff)
downloadgentoo-2-f13bd138c853a071942e8efdb837cf45accac8e6.tar.gz
gentoo-2-f13bd138c853a071942e8efdb837cf45accac8e6.tar.bz2
gentoo-2-f13bd138c853a071942e8efdb837cf45accac8e6.zip
Version bump. Convert to ruby-ng. Drop rubygems patch: it should not be needed in a properly set up Gentoo system.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/booh')
-rw-r--r--app-misc/booh/ChangeLog8
-rw-r--r--app-misc/booh/booh-0.9.3.ebuild74
2 files changed, 81 insertions, 1 deletions
diff --git a/app-misc/booh/ChangeLog b/app-misc/booh/ChangeLog
index f1c9cfb98bd9..60f29e8645fa 100644
--- a/app-misc/booh/ChangeLog
+++ b/app-misc/booh/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/booh
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/booh/ChangeLog,v 1.26 2010/06/01 19:24:11 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/booh/ChangeLog,v 1.27 2010/07/13 06:33:11 graaff Exp $
+
+*booh-0.9.3 (13 Jul 2010)
+
+ 13 Jul 2010; Hans de Graaff <graaff@gentoo.org> +booh-0.9.3.ebuild:
+ Version bump. Convert to ruby-ng. Drop rubygems patch: it should not be
+ needed in a properly set up Gentoo system.
01 Jun 2010; Hans de Graaff <graaff@gentoo.org> booh-0.9.2.2.ebuild,
+files/booh-0.9.2.2-stdc.patch:
diff --git a/app-misc/booh/booh-0.9.3.ebuild b/app-misc/booh/booh-0.9.3.ebuild
new file mode 100644
index 000000000000..1bcab15537a1
--- /dev/null
+++ b/app-misc/booh/booh-0.9.3.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/booh/booh-0.9.3.ebuild,v 1.1 2010/07/13 06:33:11 graaff Exp $
+
+EAPI="2"
+USE_RUBY="ruby18"
+
+inherit eutils bash-completion ruby-ng
+
+DESCRIPTION="Static HTML photo album generator"
+HOMEPAGE="http://booh.org/index.html"
+SRC_URI="http://booh.org/packages/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gtk encode exif"
+
+CDEPEND="media-gfx/exiv2
+ gtk? ( >=x11-libs/gtk+-2.8 )"
+
+DEPEND="${DEPEND} ${CDEPEND}"
+RDEPEND="${RDEPEND} ${CDEPEND}
+ || ( media-gfx/imagemagick[jpeg,png] media-gfx/graphicsmagick[jpeg,png] )
+ exif? ( media-gfx/exif )
+ encode? ( media-video/mplayer )"
+
+ruby_add_rdepend "
+ >=dev-ruby/ruby-gettext-0.8.0
+ dev-ruby/ruby-glib2
+ gtk? ( >=dev-ruby/ruby-gtk2-0.12 )"
+
+all_ruby_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.9.2.2-stdc.patch
+
+ # Remove scripts requiring gtk if gtk is not used
+ if ! use gtk; then
+ rm bin/booh bin/booh-classifier bin/booh-fix-whitebalance \
+ bin/booh-gamma-correction
+ fi
+}
+
+each_ruby_configure() {
+ ${RUBY} setup.rb config || die "ruby setup.rb config failed"
+ ${RUBY} setup.rb setup || die "ruby setup.rb setup failed"
+ cd ext
+ ${RUBY} extconf.rb || die "ruby extconf.rb failed"
+ sed -i -e 's:-Wl,--no-undefined ::' Makefile || die "--no-undefined removal failed"
+ sed -i -e 's:-Wl,-R$(libdir)::' -e 's:-Wl,-R -Wl,$(libdir)::' Makefile || die "Fix insecure RUNPATH failed"
+}
+
+each_ruby_compile() {
+ emake -Cext || die
+}
+
+each_ruby_install() {
+ ${RUBY} setup.rb install \
+ --prefix="${D}" || die "ruby setup.rb install failed"
+ cd ext
+ emake install \
+ DESTDIR=${D} \
+ libdir=${D}/`ruby -rrbconfig -e "puts Config::CONFIG['sitelibdir']"` \
+ archdir=${D}/`ruby -rrbconfig -e "puts Config::CONFIG['sitearchdir']"` \
+ || die "emake install failed"
+ cd ..
+}
+
+all_ruby_install() {
+ domenu desktop/booh-classifier.desktop desktop/booh.desktop || die "domenu failed"
+ doicon desktop/booh-48x48.png || die "doicon failed"
+ dobashcompletion booh.bash-completion || die "dobashcompletion failed"
+ dodoc AUTHORS ChangeLog INTERNALS README VERSION THEMES \
+ || die "dodoc failed"
+}