summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2014-08-03 18:44:52 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2014-08-03 18:44:52 +0000
commitbd827338f38fc0dd4e4743ddece8459d94cc87fd (patch)
treef18517ec3ea9a10a4ff35f076debc9aad8dd15a2 /app-leechcraft/lc-aggregator
parentBump LeechCraft to 0.6.70, thanks to 0xd34df00d. (diff)
downloadgentoo-2-bd827338f38fc0dd4e4743ddece8459d94cc87fd.tar.gz
gentoo-2-bd827338f38fc0dd4e4743ddece8459d94cc87fd.tar.bz2
gentoo-2-bd827338f38fc0dd4e4743ddece8459d94cc87fd.zip
Bump LeechCraft to 0.6.70, thanks to 0xd34df00d.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key F8DBDADE)
Diffstat (limited to 'app-leechcraft/lc-aggregator')
-rw-r--r--app-leechcraft/lc-aggregator/ChangeLog8
-rw-r--r--app-leechcraft/lc-aggregator/lc-aggregator-0.6.70.ebuild39
2 files changed, 46 insertions, 1 deletions
diff --git a/app-leechcraft/lc-aggregator/ChangeLog b/app-leechcraft/lc-aggregator/ChangeLog
index 662d13734165..6a1ddf045e50 100644
--- a/app-leechcraft/lc-aggregator/ChangeLog
+++ b/app-leechcraft/lc-aggregator/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-leechcraft/lc-aggregator
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-aggregator/ChangeLog,v 1.11 2014/04/10 17:50:01 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-aggregator/ChangeLog,v 1.12 2014/08/03 18:44:52 maksbotan Exp $
+
+*lc-aggregator-0.6.70 (03 Aug 2014)
+
+ 03 Aug 2014; Maxim Koltsov <maksbotan@gentoo.org>
+ +lc-aggregator-0.6.70.ebuild:
+ Bump LeechCraft to 0.6.70, thanks to 0xd34df00d.
*lc-aggregator-0.6.65 (10 Apr 2014)
diff --git a/app-leechcraft/lc-aggregator/lc-aggregator-0.6.70.ebuild b/app-leechcraft/lc-aggregator/lc-aggregator-0.6.70.ebuild
new file mode 100644
index 000000000000..3bd36676ee6c
--- /dev/null
+++ b/app-leechcraft/lc-aggregator/lc-aggregator-0.6.70.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-aggregator/lc-aggregator-0.6.70.ebuild,v 1.1 2014/08/03 18:44:52 maksbotan Exp $
+
+EAPI="4"
+
+inherit leechcraft
+
+DESCRIPTION="Full-featured RSS/Atom feed reader for LeechCraft"
+
+SLOT="0"
+KEYWORDS=" ~amd64 ~x86"
+IUSE="debug mysql +sqlite postgres webaccess"
+
+DEPEND="~app-leechcraft/lc-core-${PV}[postgres?,sqlite?]
+ dev-qt/qtwebkit:4"
+RDEPEND="${DEPEND}
+ virtual/leechcraft-downloader-http"
+
+REQUIRED_USE="|| ( mysql sqlite postgres )"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_enale webaccess AGGREGATOR_WEBACCESS)
+ )
+ cmake-utils_src_configure
+}
+
+pkg_setup(){
+ if use mysql; then
+ ewarn "Support for MySQL databases is experimental and is more likely"
+ ewarn "to contain bugs or mishandle your data than other storage"
+ ewarn "backends. If you do not plan testing the MySQL storage backend"
+ ewarn "itself, consider using other backends."
+ ewarn "Anyway, it is perfectly safe to enable the mysql use flag as"
+ ewarn "long as at least one other storage is enabled since you will"
+ ewarn "be able to choose another storage backend at run time."
+ fi
+}