summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2013-06-11 17:12:13 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2013-06-11 17:12:13 +0000
commit59543d475bf460243706c6548bc9c3c72a32a8bb (patch)
tree0af9cd229a8d0427662c7c63e0b281e820cb5f0d /app-leechcraft/lc-aggregator
parentBump LeechCraft suite to 0.5.97, thanks to 0xd34df00d. (diff)
downloadgentoo-2-59543d475bf460243706c6548bc9c3c72a32a8bb.tar.gz
gentoo-2-59543d475bf460243706c6548bc9c3c72a32a8bb.tar.bz2
gentoo-2-59543d475bf460243706c6548bc9c3c72a32a8bb.zip
Bump LeechCraft suite to 0.5.97, thanks to 0xd34df00d.
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key F8DBDADE)
Diffstat (limited to 'app-leechcraft/lc-aggregator')
-rw-r--r--app-leechcraft/lc-aggregator/ChangeLog8
-rw-r--r--app-leechcraft/lc-aggregator/lc-aggregator-0.5.97.ebuild32
2 files changed, 39 insertions, 1 deletions
diff --git a/app-leechcraft/lc-aggregator/ChangeLog b/app-leechcraft/lc-aggregator/ChangeLog
index 63a6f48ff1e8..ee0c4fded7c8 100644
--- a/app-leechcraft/lc-aggregator/ChangeLog
+++ b/app-leechcraft/lc-aggregator/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-leechcraft/lc-aggregator
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-aggregator/ChangeLog,v 1.3 2013/05/26 19:33:14 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-aggregator/ChangeLog,v 1.4 2013/06/11 17:12:13 maksbotan Exp $
+
+*lc-aggregator-0.5.97 (11 Jun 2013)
+
+ 11 Jun 2013; Maxim Koltsov <maksbotan@gentoo.org>
+ +lc-aggregator-0.5.97.ebuild:
+ Bump LeechCraft suite to 0.5.97, thanks to 0xd34df00d.
*lc-aggregator-0.5.96 (26 May 2013)
diff --git a/app-leechcraft/lc-aggregator/lc-aggregator-0.5.97.ebuild b/app-leechcraft/lc-aggregator/lc-aggregator-0.5.97.ebuild
new file mode 100644
index 000000000000..58d936875d81
--- /dev/null
+++ b/app-leechcraft/lc-aggregator/lc-aggregator-0.5.97.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-aggregator/lc-aggregator-0.5.97.ebuild,v 1.1 2013/06/11 17:12:13 maksbotan Exp $
+
+EAPI="4"
+
+inherit leechcraft
+
+DESCRIPTION="Full-featured RSS/Atom feed reader for LeechCraft"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug mysql +sqlite postgres"
+
+DEPEND="~app-leechcraft/lc-core-${PV}[postgres?,sqlite?]
+ dev-qt/qtwebkit:4"
+RDEPEND="${DEPEND}
+ virtual/leechcraft-downloader-http"
+
+REQUIRED_USE="|| ( mysql sqlite postgres )"
+
+pkg_setup(){
+ if use mysql; then
+ ewarn "Support for MySQL databases is experimental and is more likely"
+ ewarn "to contain bugs or mishandle your data than other storage"
+ ewarn "backends. If you do not plan testing the MySQL storage backend"
+ ewarn "itself, consider using other backends."
+ ewarn "Anyway, it is perfectly safe to enable the mysql use flag as"
+ ewarn "long as at least one other storage is enabled since you will"
+ ewarn "be able to choose another storage backend at run time."
+ fi
+}