summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2005-02-19 04:38:36 +0000
committerJoseph Jezak <josejx@gentoo.org>2005-02-19 04:38:36 +0000
commitc01cfeaa7882149dc0076666a64e4abaecad7fee (patch)
treeea5bd44aaf242d17f843a80da62d1aa5cab68301 /app-laptop
parentStable ppc-macos (diff)
downloadgentoo-2-c01cfeaa7882149dc0076666a64e4abaecad7fee.tar.gz
gentoo-2-c01cfeaa7882149dc0076666a64e4abaecad7fee.tar.bz2
gentoo-2-c01cfeaa7882149dc0076666a64e4abaecad7fee.zip
Version bump for pbbuttonsd along with patch to fix ALSA segfault. See bug #79629.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/pbbuttonsd/ChangeLog9
-rw-r--r--app-laptop/pbbuttonsd/Manifest9
-rw-r--r--app-laptop/pbbuttonsd/files/alsa-segfault-0.6.7.patch21
-rw-r--r--app-laptop/pbbuttonsd/files/digest-pbbuttonsd-0.6.71
-rw-r--r--app-laptop/pbbuttonsd/pbbuttonsd-0.6.7.ebuild45
5 files changed, 81 insertions, 4 deletions
diff --git a/app-laptop/pbbuttonsd/ChangeLog b/app-laptop/pbbuttonsd/ChangeLog
index 100847aacff9..ccfd372c0cb3 100644
--- a/app-laptop/pbbuttonsd/ChangeLog
+++ b/app-laptop/pbbuttonsd/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-laptop/pbbuttonsd
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/ChangeLog,v 1.17 2005/01/21 19:52:49 pylon Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/ChangeLog,v 1.18 2005/02/19 04:38:36 josejx Exp $
+
+*pbbuttonsd-0.6.7 (19 Feb 2005)
+
+ 19 Feb 2005; Joseph Jezak <josejx@gentoo.org>
+ +files/alsa-segfault-0.6.7.patch, +pbbuttonsd-0.6.7.ebuild:
+ Added the new version of pbbuttonsd along with a patch to prevent segfaults
+ with ALSA. See bug #79692.
*pbbuttonsd-0.6.6 (21 Jan 2005)
diff --git a/app-laptop/pbbuttonsd/Manifest b/app-laptop/pbbuttonsd/Manifest
index 7a69fb317300..ea18cfa9414b 100644
--- a/app-laptop/pbbuttonsd/Manifest
+++ b/app-laptop/pbbuttonsd/Manifest
@@ -1,5 +1,8 @@
-MD5 1452ac994e8d828db9ac2b12f480ca81 ChangeLog 6711
-MD5 52f9d8e98c8931645c57a3de1c36727d metadata.xml 156
+MD5 8afcc4e28551f56eb0914210ae71e22e ChangeLog 6962
MD5 3f69a621b8f6af1b58e0def21bf85971 pbbuttonsd-0.6.6.ebuild 1144
-MD5 72caa2adac6c8260c57c0ae15cc259f3 files/digest-pbbuttonsd-0.6.6 68
+MD5 52f9d8e98c8931645c57a3de1c36727d metadata.xml 156
+MD5 42f0ecf7a1757812ed1cf106c866a5ca pbbuttonsd-0.6.7.ebuild 1200
MD5 e87049121a8371a7173cb9aa7c5b167d files/pbbuttonsd.rc6 444
+MD5 676408374debb17d40c3562e2fa021a6 files/alsa-segfault-0.6.7.patch 487
+MD5 79966ef982c2ecd2ae5fcd57c9a82e97 files/digest-pbbuttonsd-0.6.7 68
+MD5 72caa2adac6c8260c57c0ae15cc259f3 files/digest-pbbuttonsd-0.6.6 68
diff --git a/app-laptop/pbbuttonsd/files/alsa-segfault-0.6.7.patch b/app-laptop/pbbuttonsd/files/alsa-segfault-0.6.7.patch
new file mode 100644
index 000000000000..c854ec8ab5be
--- /dev/null
+++ b/app-laptop/pbbuttonsd/files/alsa-segfault-0.6.7.patch
@@ -0,0 +1,21 @@
+--- src/module_alsamixer.c 2005-01-24 19:50:37.000000000 +0100
++++ src/module_alsamixer.c 2005-01-27 16:24:18.000000000 +0100
+@@ -434,9 +434,15 @@
+ alsamixer_exit ()
+ {
+ struct moddata_alsamixer *base = &modbase_alsamixer;
+- free (base->elements);
+- base->elements = NULL;
+- snd_mixer_free (base->mixer);
++
++ if (base->elements) {
++ free (base->elements);
++ base->elements = NULL;
++ }
++
++ if (base->mixer)
++ snd_mixer_free (base->mixer);
++
+ base->init_complete = 0;
+ return 0;
+ }
diff --git a/app-laptop/pbbuttonsd/files/digest-pbbuttonsd-0.6.7 b/app-laptop/pbbuttonsd/files/digest-pbbuttonsd-0.6.7
new file mode 100644
index 000000000000..ca2f4221dbdb
--- /dev/null
+++ b/app-laptop/pbbuttonsd/files/digest-pbbuttonsd-0.6.7
@@ -0,0 +1 @@
+MD5 9dd3e2e41cae5028020947495a97d3e9 pbbuttonsd-0.6.7.tar.gz 384799
diff --git a/app-laptop/pbbuttonsd/pbbuttonsd-0.6.7.ebuild b/app-laptop/pbbuttonsd/pbbuttonsd-0.6.7.ebuild
new file mode 100644
index 000000000000..b2552eeeb874
--- /dev/null
+++ b/app-laptop/pbbuttonsd/pbbuttonsd-0.6.7.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/pbbuttonsd-0.6.7.ebuild,v 1.1 2005/02/19 04:38:36 josejx Exp $
+
+inherit eutils
+
+DESCRIPTION="program to map special Powerbook/iBook keys"
+HOMEPAGE="http://pbbuttons.sf.net"
+SRC_URI="mirror://sourceforge/pbbuttons/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc"
+IUSE=""
+
+DEPEND="virtual/libc
+ >=sys-apps/baselayout-1.8.6.12-r1"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/alsa-segfault-${PV}.patch
+}
+
+src_compile() {
+ econf || die "sorry, failed to configure pbbuttonsd"
+ make || die "sorry, failed to compile pbbuttonsd"
+}
+
+src_install() {
+ dodir /etc/power
+ make DESTDIR=${D} install || die "failed to install"
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/pbbuttonsd.rc6 pbbuttonsd
+ dodoc README
+}
+
+pkg_postinst() {
+ einfo "This version of pbbuttonsd can replace PMUD functionality."
+ einfo "If you want PMUD installed and running, you should set"
+ einfo "replace_pmud=no in /etc/pbbuttonsd.conf. Otherwise you can"
+ einfo "try setting replace_pmud=yes in /etc/pbbuttonsd.conf and"
+ einfo "disabling PMUD"
+}