summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2013-05-11 09:58:27 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2013-05-11 09:58:27 +0000
commit6217b6614d952634546736817795dce03a675454 (patch)
treecdf85f19f3006026d2c6b1ec1e83f695cc631658 /app-laptop
parentFix remaining gtk+-3.8 issue (#469062 by Evgeny Bobkin) (diff)
downloadgentoo-2-6217b6614d952634546736817795dce03a675454.tar.gz
gentoo-2-6217b6614d952634546736817795dce03a675454.tar.bz2
gentoo-2-6217b6614d952634546736817795dce03a675454.zip
Do not use killall -g, bug#463944 thanks to Murray Campbell
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, signed Manifest commit with key BF20DC51)
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/laptop-mode-tools/ChangeLog9
-rw-r--r--app-laptop/laptop-mode-tools/files/laptop-mode-tools-1.63-killall.patch38
-rw-r--r--app-laptop/laptop-mode-tools/laptop-mode-tools-1.63-r2.ebuild94
3 files changed, 140 insertions, 1 deletions
diff --git a/app-laptop/laptop-mode-tools/ChangeLog b/app-laptop/laptop-mode-tools/ChangeLog
index d402f73fcdc0..89f7baa4a101 100644
--- a/app-laptop/laptop-mode-tools/ChangeLog
+++ b/app-laptop/laptop-mode-tools/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-laptop/laptop-mode-tools
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/laptop-mode-tools/ChangeLog,v 1.74 2013/04/12 06:22:54 lxnay Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/laptop-mode-tools/ChangeLog,v 1.75 2013/05/11 09:58:27 alonbl Exp $
+
+*laptop-mode-tools-1.63-r2 (11 May 2013)
+
+ 11 May 2013; Alon Bar-Lev <alonbl@gentoo.org>
+ +files/laptop-mode-tools-1.63-killall.patch,
+ +laptop-mode-tools-1.63-r2.ebuild:
+ Do not use killall -g, bug#463944 thanks to Murray Campbell
12 Apr 2013; Fabio Erculiani <lxnay@gentoo.org>
laptop-mode-tools-1.62-r2.ebuild, laptop-mode-tools-1.63.ebuild,
diff --git a/app-laptop/laptop-mode-tools/files/laptop-mode-tools-1.63-killall.patch b/app-laptop/laptop-mode-tools/files/laptop-mode-tools-1.63-killall.patch
new file mode 100644
index 000000000000..0dfdfc981a9b
--- /dev/null
+++ b/app-laptop/laptop-mode-tools/files/laptop-mode-tools-1.63-killall.patch
@@ -0,0 +1,38 @@
+From a68a8d051b476ceae87e0490001b7c60ac5ea942 Mon Sep 17 00:00:00 2001
+From: Ritesh Raj Sarraf <rrs@debian.org>
+Date: Wed, 17 Apr 2013 12:11:01 +0530
+Subject: [PATCH] Don't call killall with the -g argument.
+
+It kills the entire group of processes
+https://bugs.gentoo.org/show_bug.cgi?id=463944
+
+Thanks: Murray Campbell
+---
+ usr/sbin/laptop_mode | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/usr/sbin/laptop_mode b/usr/sbin/laptop_mode
+index 74a129c..cfd99c1 100755
+--- a/usr/sbin/laptop_mode
++++ b/usr/sbin/laptop_mode
+@@ -1130,7 +1130,7 @@ if [ x$ENABLE_BATTERY_LEVEL_POLLING = x1 ] && [ x$BLACKLIST_IN_FLOCK = x1 ]; the
+ log "VERBOSE" "On AC, stopping the polling daemon."
+
+ # In AC mode we disable the polling daemon.
+- killall -g -q lm-polling-daemon
++ killall -q lm-polling-daemon
+ elif [ x$ON_AC = x0 ]; then
+ exec 7>$LMT_BATTPOLL_LOCK;
+ if $FLOCK -n -x -w 1 7; then
+@@ -1149,7 +1149,7 @@ if [ x$ENABLE_BATTERY_LEVEL_POLLING = x1 ] && [ x$BLACKLIST_IN_FLOCK = x1 ]; the
+ # should be killed.
+ if [ x$INITSCRIPT_STOP = x1 ]; then
+ log "VERBOSE" "On Battery, but init script stop is called. Killing lm-polling-daemon"
+- killall -g -q lm-polling-daemon
++ killall -q lm-polling-daemon
+ fi
+ else
+ log "ERR" "Unknown ON_AC state: $ON_AC";
+--
+1.8.1.6
+
diff --git a/app-laptop/laptop-mode-tools/laptop-mode-tools-1.63-r2.ebuild b/app-laptop/laptop-mode-tools/laptop-mode-tools-1.63-r2.ebuild
new file mode 100644
index 000000000000..e42eb9c0c29a
--- /dev/null
+++ b/app-laptop/laptop-mode-tools/laptop-mode-tools-1.63-r2.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/laptop-mode-tools/laptop-mode-tools-1.63-r2.ebuild,v 1.1 2013/05/11 09:58:27 alonbl Exp $
+
+EAPI=5
+inherit eutils multilib systemd udev
+
+MY_P=${PN}_${PV}
+
+DESCRIPTION="Linux kernel laptop_mode user-space utilities"
+HOMEPAGE="http://www.samwel.tk/laptop_mode/"
+SRC_URI="http://www.samwel.tk/laptop_mode/tools/downloads/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+acpi apm bluetooth scsi"
+
+RDEPEND="net-wireless/wireless-tools
+ sys-apps/ethtool
+ sys-apps/hdparm
+ acpi? ( sys-power/acpid )
+ apm? ( sys-apps/apmd )
+ bluetooth? ( net-wireless/bluez:= )
+ scsi? ( sys-apps/sdparm )"
+DEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-pcie-aspm-silencing-stderr.patch"
+ epatch "${FILESDIR}/${P}-killall.patch"
+
+ # This should avoid conflict with pm-powersave wrt #327443 and #396703
+ cat <<-EOF > "${T}"/${PN}
+ HOOK_BLACKLIST="00powersave"
+ EOF
+}
+
+src_compile() { :; }
+
+src_install() {
+ DESTDIR="${D}" \
+ INIT_D="none" \
+ MAN_D="/usr/share/man" \
+ LIB_D="/usr/$(get_libdir)" \
+ UDEV_D="$(udev_get_udevdir)" \
+ SYSTEMD_UNIT_D="$(systemd_get_unitdir)" \
+ TMPFILES_D="/usr/$(get_libdir)/tmpfiles.d" \
+ ACPI="$(use acpi && echo force || echo disabled)" \
+ PMU="$(false && echo force || echo disabled)" \
+ APM="$(use apm && echo force || echo disabled)" \
+ SYSTEMD=yes \
+ sh ./install.sh || die
+
+ dodoc Documentation/*.txt README
+ newinitd "${FILESDIR}"/laptop_mode.init-1.4 laptop_mode
+
+ # See src_prepare()
+ insinto /etc/pm/config.d
+ doins "${T}"/${PN}
+}
+
+pkg_postinst() {
+ if use acpi || use apm; then
+ if use acpi; then
+ daemon_name="acpid"
+ elif use apm; then
+ deamon_name="apmd"
+ fi
+ if [ "$(rc-config list default | grep laptop_mode)" = "" ] || [ "$(rc-config list default | grep ${daemon_name} )" = "" ]; then
+ ewarn "To enable automatic power state event handling,"
+ ewarn "e.g. enabling laptop_mode after unplugging the battery,"
+ ewarn "both laptop_mode and the ${daemon_name} daemon must be"
+ ewarn "added to default runlevel:"
+ if [ "$(rc-config list default | grep laptop_mode)" = "" ]; then
+ ewarn "# rc-update add laptop_mode default"
+ fi
+ if [ "$(rc-config list default | grep ${daemon_name} )" = "" ]; then
+ ewarn "# rc-update add ${daemon_name} default"
+ fi
+ fi
+ else
+ ewarn "Without USE=\"acpi\" or USE=\"apm\" ${PN} can not"
+ ewarn "automatically disable laptop_mode on low battery."
+ ewarn
+ ewarn "This means you can lose up to 10 minutes of work if running"
+ ewarn "out of battery while laptop_mode is enabled."
+ ewarn
+ ewarn "Please see laptop-mode.txt in /usr/share/doc/${PF} for further"
+ ewarn "information."
+ ewarn
+ fi
+}