summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-12-27 13:24:13 +0000
committerMichał Górny <mgorny@gentoo.org>2014-12-27 13:24:13 +0000
commitecd365b1b5a4a014e0e4b15714b156e714e08501 (patch)
tree99234de5e8648041d89dfaa586c15bd49522eaab /app-i18n
parentConvert to distutils-r1. (diff)
downloadgentoo-2-ecd365b1b5a4a014e0e4b15714b156e714e08501.tar.gz
gentoo-2-ecd365b1b5a4a014e0e4b15714b156e714e08501.tar.bz2
gentoo-2-ecd365b1b5a4a014e0e4b15714b156e714e08501.zip
Convert to python-single-r1.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/tomoe/ChangeLog10
-rw-r--r--app-i18n/tomoe/tomoe-0.6.0-r2.ebuild93
2 files changed, 100 insertions, 3 deletions
diff --git a/app-i18n/tomoe/ChangeLog b/app-i18n/tomoe/ChangeLog
index b7e3f849955c..d4fde169ac66 100644
--- a/app-i18n/tomoe/ChangeLog
+++ b/app-i18n/tomoe/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/tomoe
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/tomoe/ChangeLog,v 1.17 2012/06/22 02:13:29 naota Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/tomoe/ChangeLog,v 1.18 2014/12/27 13:24:13 mgorny Exp $
+
+*tomoe-0.6.0-r2 (27 Dec 2014)
+
+ 27 Dec 2014; Michał Górny <mgorny@gentoo.org> +tomoe-0.6.0-r2.ebuild:
+ Convert to python-single-r1.
22 Jun 2012; Naohiro Aota <naota@gentoo.org> +files/tomoe-0.6.0-glib232.patch,
tomoe-0.6.0-r1.ebuild:
@@ -72,4 +77,3 @@
12 Aug 2006; MATSUU Takuto <matsuu@gentoo.org> +tomoe-0.2.1.ebuild:
Initial ebuild submitted by Olof <olofshopping@hotmail.com>. bug 140117.
-
diff --git a/app-i18n/tomoe/tomoe-0.6.0-r2.ebuild b/app-i18n/tomoe/tomoe-0.6.0-r2.ebuild
new file mode 100644
index 000000000000..f4d1c434dcc3
--- /dev/null
+++ b/app-i18n/tomoe/tomoe-0.6.0-r2.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/tomoe/tomoe-0.6.0-r2.ebuild,v 1.1 2014/12/27 13:24:13 mgorny Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit autotools eutils multilib python-single-r1
+
+DESCRIPTION="Japanese handwriting recognition engine"
+HOMEPAGE="http://tomoe.sourceforge.jp/"
+SRC_URI="mirror://sourceforge/tomoe/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc hyperestraier mysql ruby python static-libs subversion"
+
+RDEPEND=">=dev-libs/glib-2.4
+ ruby? ( dev-ruby/ruby-glib2 )
+ hyperestraier? ( app-text/hyperestraier )
+ subversion? (
+ >=dev-libs/apr-1
+ dev-vcs/subversion
+ )
+ mysql? ( dev-db/mysql )
+ python? (
+ ${PYTHON_DEPS}
+ dev-python/pygobject:2[${PYTHON_USEDEP}]
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+ )"
+# test? ( app-dicts/uconv )
+
+DEPEND="${DEPEND}
+ dev-util/gtk-doc-am
+ dev-util/intltool
+ virtual/pkgconfig
+ doc? ( dev-util/gtk-doc )"
+
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RESTRICT="test"
+
+pkg_setup() {
+ if use python ; then
+ python-single-r1_pkg_setup
+ fi
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}/${P}-export-symbols.patch" \
+ "${FILESDIR}/${P}-ldflags.patch" \
+ "${FILESDIR}/${P}-glib232.patch"
+
+ if ! use hyperestraier ; then
+ sed -i -e "s/use_est=yes/use_est=no/" configure.ac || die
+ fi
+ if ! use mysql ; then
+ sed -i -e "s/use_mysql=yes/use_mysql=no/" configure.ac || die
+ fi
+ if ! use subversion ; then
+ sed -i -e "s/use_svn=yes/use_svn=no/" macros/svn.m4 || die
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+
+ # --with-python b0rked hard
+ local -x PYTHON
+ use python || myconf="${myconf} --without-python"
+
+ econf \
+ $(use_enable doc gtk-doc) \
+ $(use_with ruby) \
+ $(use_enable static-libs static) \
+ $(use_enable ruby dict-ruby) \
+ ${myconf} || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ find "${ED}/usr/$(get_libdir)/tomoe" \( -name '*.la' -o -name '*.a' \) -type f -delete || die
+ if ! use static-libs ; then
+ find "${ED}" -name '*.la' -type f -delete || die
+ fi
+
+ dodoc AUTHORS ChangeLog NEWS TODO || die
+}