summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-12-27 11:24:29 +0000
committerMichał Górny <mgorny@gentoo.org>2014-12-27 11:24:29 +0000
commit32862b2073beebf3670fd3b118591df7ff6e6033 (patch)
tree6f5d9f1e4b78e254e2d66c98c512a9e1395a8f8d /app-i18n
parentFix building against sys-libs/ncurses[tinfo] (bug #529768). (diff)
downloadgentoo-2-32862b2073beebf3670fd3b118591df7ff6e6033.tar.gz
gentoo-2-32862b2073beebf3670fd3b118591df7ff6e6033.tar.bz2
gentoo-2-32862b2073beebf3670fd3b118591df7ff6e6033.zip
Convert to python-single-r1.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-table/ChangeLog9
-rw-r--r--app-i18n/ibus-table/ibus-table-1.5.0-r1.ebuild42
2 files changed, 49 insertions, 2 deletions
diff --git a/app-i18n/ibus-table/ChangeLog b/app-i18n/ibus-table/ChangeLog
index 511a95824c23..4b0b0ecbfb9c 100644
--- a/app-i18n/ibus-table/ChangeLog
+++ b/app-i18n/ibus-table/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/ibus-table
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-table/ChangeLog,v 1.30 2013/02/05 15:22:19 yngwin Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-table/ChangeLog,v 1.31 2014/12/27 11:24:29 mgorny Exp $
+
+*ibus-table-1.5.0-r1 (27 Dec 2014)
+
+ 27 Dec 2014; Michał Górny <mgorny@gentoo.org> +ibus-table-1.5.0-r1.ebuild:
+ Convert to python-single-r1.
05 Feb 2013; Ben de Groot <yngwin@gentoo.org>
+files/ibus-table-1.5.0-pycompile.patch:
diff --git a/app-i18n/ibus-table/ibus-table-1.5.0-r1.ebuild b/app-i18n/ibus-table/ibus-table-1.5.0-r1.ebuild
new file mode 100644
index 000000000000..1b989b221577
--- /dev/null
+++ b/app-i18n/ibus-table/ibus-table-1.5.0-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-table/ibus-table-1.5.0-r1.ebuild,v 1.1 2014/12/27 11:24:29 mgorny Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+inherit eutils python-single-r1
+
+DESCRIPTION="The Table Engine for IBus Framework"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="${PYTHON_DEPS}
+ >=app-i18n/ibus-1.2[python,${PYTHON_USEDEP}]
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.16.1 )
+ virtual/pkgconfig"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+src_prepare() {
+ python_fix_shebang .
+
+ sed -i -e "s/python/${EPYTHON}/" \
+ engine/ibus-table-createdb.in engine/ibus-engine-table.in || die
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc AUTHORS ChangeLog NEWS README
+}