summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2012-03-15 01:47:50 +0000
committerNaohiro Aota <naota@gentoo.org>2012-03-15 01:47:50 +0000
commit8a0e3cee5ec64797287539753ad97cf1f2fceea6 (patch)
treec74eb3937d271f510b354882a7e0d56e1bb5ec14 /app-i18n/nkf
parentPull in libselinux for selinux/selinux.h wrt #408213 by Markus Knetschke (diff)
downloadgentoo-2-8a0e3cee5ec64797287539753ad97cf1f2fceea6.tar.gz
gentoo-2-8a0e3cee5ec64797287539753ad97cf1f2fceea6.tar.bz2
gentoo-2-8a0e3cee5ec64797287539753ad97cf1f2fceea6.zip
Change nkf-python upstream address. Update LICENSE. Bug #405235
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n/nkf')
-rw-r--r--app-i18n/nkf/ChangeLog9
-rw-r--r--app-i18n/nkf/nkf-2.1.2-r1.ebuild85
2 files changed, 92 insertions, 2 deletions
diff --git a/app-i18n/nkf/ChangeLog b/app-i18n/nkf/ChangeLog
index 159016f1412b..76ed1e4cf9fe 100644
--- a/app-i18n/nkf/ChangeLog
+++ b/app-i18n/nkf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/nkf
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/nkf/ChangeLog,v 1.51 2011/11/20 15:15:34 naota Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/nkf/ChangeLog,v 1.52 2012/03/15 01:47:50 naota Exp $
+
+*nkf-2.1.2-r1 (15 Mar 2012)
+
+ 15 Mar 2012; Naohiro Aota <naota@gentoo.org> +nkf-2.1.2-r1.ebuild:
+ Change nkf-python upstream address. Update LICENSE. Bug #405235
*nkf-2.1.2 (20 Nov 2011)
diff --git a/app-i18n/nkf/nkf-2.1.2-r1.ebuild b/app-i18n/nkf/nkf-2.1.2-r1.ebuild
new file mode 100644
index 000000000000..4fb40fa533cd
--- /dev/null
+++ b/app-i18n/nkf/nkf-2.1.2-r1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/nkf/nkf-2.1.2-r1.ebuild,v 1.1 2012/03/15 01:47:50 naota Exp $
+
+EAPI="3"
+PYTHON_DEPEND="python? 2"
+inherit eutils distutils perl-module toolchain-funcs
+
+DESCRIPTION="Network Kanji code conversion Filter with UTF-8/16 support"
+HOMEPAGE="http://sourceforge.jp/projects/nkf/"
+SRC_URI="mirror://sourceforge.jp/nkf/53171/${P}.tar.gz
+ python? ( http://dev.gentoo.org/~naota/files/NKF_python20090602.tgz )"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-macos"
+IUSE="perl python linguas_ja"
+
+pkg_setup() {
+ if use python ; then
+ python_set_active_version 2
+ fi
+}
+
+src_prepare() {
+ sed -i \
+ -e "/^CFLAGS/s:-O2:${CFLAGS}:" \
+ -e '/-o nkf/s:$(CFLAGS):$(CFLAGS) $(LDFLAGS):' \
+ Makefile || die
+
+ if use python; then
+ mv "${WORKDIR}/NKF.python" "${S}" || die
+ sed -i -e "s/-s/${CFLAGS}/" NKF.python/setup.py || die
+ fi
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" nkf || die
+ if use perl; then
+ cd "${S}/NKF.mod"
+ perl-module_src_compile
+ fi
+ if use python; then
+ cd "${S}/NKF.python"
+ distutils_src_compile
+ fi
+}
+
+src_test() {
+ emake test || die
+ if use perl; then
+ cd "${S}/NKF.mod"
+ perl-module_src_test
+ fi
+}
+
+src_install() {
+ dobin nkf || die
+ doman nkf.1
+ if use linguas_ja; then
+ ./nkf -e nkf.1j > nkf.1
+ doman -i18n=ja nkf.1
+ fi
+ dodoc nkf.doc
+ if use perl; then
+ cd "${S}/NKF.mod"
+ perl-module_src_install
+ fi
+ if use python; then
+ cd "${S}/NKF.python"
+ distutils_src_install
+ fi
+}
+
+pkg_postinst() {
+ if use python ; then
+ distutils_pkg_postinst
+ fi
+}
+
+pkg_postrm() {
+ if use python ; then
+ distutils_pkg_postrm
+ fi
+}