summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2012-01-22 11:14:23 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2012-01-22 11:14:23 +0000
commit1e7c75457aee31dc2016b3c6a10d859f299ce182 (patch)
tree3cbd4382c11e3aeb5e7bf6a0f7313f38840896f6 /app-i18n/kinput2
parentDrop old. (diff)
downloadgentoo-2-1e7c75457aee31dc2016b3c6a10d859f299ce182.tar.gz
gentoo-2-1e7c75457aee31dc2016b3c6a10d859f299ce182.tar.bz2
gentoo-2-1e7c75457aee31dc2016b3c6a10d859f299ce182.zip
Added imsettings related file. Clean up.
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n/kinput2')
-rw-r--r--app-i18n/kinput2/ChangeLog10
-rw-r--r--app-i18n/kinput2/files/xinput-kinput25
-rw-r--r--app-i18n/kinput2/kinput2-3.1-r2.ebuild75
3 files changed, 88 insertions, 2 deletions
diff --git a/app-i18n/kinput2/ChangeLog b/app-i18n/kinput2/ChangeLog
index 38aae91adb48..b701504f3052 100644
--- a/app-i18n/kinput2/ChangeLog
+++ b/app-i18n/kinput2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/kinput2
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/kinput2/ChangeLog,v 1.23 2006/10/27 18:18:22 flameeyes Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/kinput2/ChangeLog,v 1.24 2012/01/22 11:14:22 matsuu Exp $
+
+*kinput2-3.1-r2 (22 Jan 2012)
+
+ 22 Jan 2012; MATSUU Takuto <matsuu@gentoo.org> +files/xinput-kinput2,
+ +kinput2-3.1-r2.ebuild:
+ Added imsettings related file. Clean up.
27 Oct 2006; Diego Pettenò <flameeyes@gentoo.org> kinput2-3.1-r1.ebuild:
Ebuild cleanup, fix for modular X support only (thanks Patrick Lauer for
diff --git a/app-i18n/kinput2/files/xinput-kinput2 b/app-i18n/kinput2/files/xinput-kinput2
new file mode 100644
index 000000000000..16de07ca4f7e
--- /dev/null
+++ b/app-i18n/kinput2/files/xinput-kinput2
@@ -0,0 +1,5 @@
+XIM=kinput2
+XIM_PROGRAM=@EPREFIX@/usr/bin/kinput2
+XIM_ARGS="-@SERVER@ +kinput -xim"
+GTK_IM_MODULE=xim
+QT_IM_MODULE=xim
diff --git a/app-i18n/kinput2/kinput2-3.1-r2.ebuild b/app-i18n/kinput2/kinput2-3.1-r2.ebuild
new file mode 100644
index 000000000000..dc47a8902d91
--- /dev/null
+++ b/app-i18n/kinput2/kinput2-3.1-r2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/kinput2/kinput2-3.1-r2.ebuild,v 1.1 2012/01/22 11:14:22 matsuu Exp $
+
+EAPI="3"
+inherit eutils
+
+MY_P="${PN}-v${PV}"
+DESCRIPTION="A Japanese input server which supports the XIM protocol"
+HOMEPAGE="http://www.nec.co.jp/canna/"
+SRC_URI="ftp://ftp.sra.co.jp/pub/x11/${PN}/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="freewnn"
+
+RDEPEND="freewnn? ( >=app-i18n/freewnn-1.1.1_alpha19 )
+ !freewnn? ( >=app-i18n/canna-3.5_beta2-r1 )
+ x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXmu
+ x11-libs/libXp
+ x11-libs/libXt"
+
+DEPEND="${RDEPEND}
+ x11-misc/gccmakedep
+ x11-misc/imake
+ app-text/rman"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-r1-gentoo.diff"
+
+ if use freewnn; then
+ sed -i -e '/\/\* #define UseWnn/s:^:#define UseWnn\n:' Kinput2.conf || die
+ else
+ sed -i -e '/\/\* #define UseCanna/s:^:#define UseCanna\n:' Kinput2.conf || die
+ fi
+}
+
+src_configure() {
+ xmkmf -a || die
+}
+
+src_compile() {
+ emake \
+ XAPPLOADDIR="${EPREFIX}/usr/share/X11/app-defaults/" \
+ CDEBUGFLAGS="${CFLAGS}" \
+ LOCAL_LDFLAGS="${LDFLAGS}" \
+ || die
+}
+
+src_install() {
+ emake XAPPLOADDIR="/usr/share/X11/app-defaults/" DESTDIR="${D}" install || die
+ rm -rf "${ED}/usr/lib/X11" || die
+
+ local server
+ if use freewnn; then
+ server="wnn"
+ else
+ server="canna"
+ fi
+
+ insinto /etc/X11/xinit/xinput.d
+ sed \
+ -e "s:@EPREFIX@:${EPREFIX}:g" \
+ -e "s:@SERVER@:${server}:g" \
+ "${FILESDIR}/xinput-kinput2" > "${T}/kinput2.conf" || die
+ doins "${T}/kinput2.conf" || die
+
+ dodoc README NEWS doc/* || die
+ newman cmd/${PN}.man ${PN}.1 || die
+}