summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-01-22 06:32:35 +0000
committerMamoru Komachi <usata@gentoo.org>2004-01-22 06:32:35 +0000
commit0d1aa97a5a996073aa58ef8a2b5408a184ef6edd (patch)
tree2dedd71d35017b8244527e8e476500d7d2302bb9 /app-i18n/jmcce
parenthppa stable (diff)
downloadgentoo-2-0d1aa97a5a996073aa58ef8a2b5408a184ef6edd.tar.gz
gentoo-2-0d1aa97a5a996073aa58ef8a2b5408a184ef6edd.tar.bz2
gentoo-2-0d1aa97a5a996073aa58ef8a2b5408a184ef6edd.zip
Fixed a bug related to gcc 3.x. Closing bug #38117
Diffstat (limited to 'app-i18n/jmcce')
-rw-r--r--app-i18n/jmcce/ChangeLog8
-rw-r--r--app-i18n/jmcce/Manifest5
-rw-r--r--app-i18n/jmcce/files/jmcce-1.4_rc2-gcc3-gentoo.diff12
-rw-r--r--app-i18n/jmcce/jmcce-1.4_rc2.ebuild33
4 files changed, 42 insertions, 16 deletions
diff --git a/app-i18n/jmcce/ChangeLog b/app-i18n/jmcce/ChangeLog
index 6ad8e4b7ca97..c820868873da 100644
--- a/app-i18n/jmcce/ChangeLog
+++ b/app-i18n/jmcce/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-i18n/jmcce
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/jmcce/ChangeLog,v 1.1 2003/05/25 15:10:52 liquidx Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/jmcce/ChangeLog,v 1.2 2004/01/22 06:32:25 usata Exp $
+
+ 22 Jan 2004; Mamoru KOMACHI <usata@gentoo.org> jmcce-1.4_rc2.ebuild,
+ files/jmcce-1.4_rc2-gcc3-gentoo.diff:
+ Fixed a bug related to gcc 3.x. Closing bug #38117
*jmcce-1.4_rc2 (25 May 2003)
diff --git a/app-i18n/jmcce/Manifest b/app-i18n/jmcce/Manifest
index a0f562048c1e..12c45e268203 100644
--- a/app-i18n/jmcce/Manifest
+++ b/app-i18n/jmcce/Manifest
@@ -1,4 +1,5 @@
-MD5 a77fe88ee9ce9da860af7c2239c0baca ChangeLog 358
-MD5 5e376addc2d8962e2275eded79e49969 jmcce-1.4_rc2.ebuild 891
+MD5 f5e29bb104a5b68e6beebb43db2057a6 ChangeLog 521
+MD5 35f5d8d04d54ff090633ca212855a6fa jmcce-1.4_rc2.ebuild 986
MD5 e92a48548554c80cf90e18df17ff6a82 metadata.xml 156
MD5 e77919af8495197697785325e0809b82 files/digest-jmcce-1.4_rc2 65
+MD5 69726c3d942600fbd25f0e519a26dfff files/jmcce-1.4_rc2-gcc3-gentoo.diff 568
diff --git a/app-i18n/jmcce/files/jmcce-1.4_rc2-gcc3-gentoo.diff b/app-i18n/jmcce/files/jmcce-1.4_rc2-gcc3-gentoo.diff
new file mode 100644
index 000000000000..6987582a9538
--- /dev/null
+++ b/app-i18n/jmcce/files/jmcce-1.4_rc2-gcc3-gentoo.diff
@@ -0,0 +1,12 @@
+diff -urN jmcce-1.4RC2.ORIG/util/tit2tui.c jmcce-1.4RC2/util/tit2tui.c
+--- jmcce-1.4RC2.ORIG/util/tit2tui.c 2002-05-15 22:44:30.000000000 +0900
++++ jmcce-1.4RC2/util/tit2tui.c 2004-01-22 14:49:30.121746528 +0900
+@@ -19,7 +19,7 @@
+ #define _llseek lseek // for DOS compatible
+ #define _lread read // for DOS compatible
+
+-//#define ANSI //* Comment out for UNIX version
++#define ANSI //* Comment out for UNIX version
+ #ifdef ANSI //* ANSI compatible version
+ #include <stdarg.h>
+ int average( int first, ... );
diff --git a/app-i18n/jmcce/jmcce-1.4_rc2.ebuild b/app-i18n/jmcce/jmcce-1.4_rc2.ebuild
index 94efcc3aa02b..2a6698faa3c3 100644
--- a/app-i18n/jmcce/jmcce-1.4_rc2.ebuild
+++ b/app-i18n/jmcce/jmcce-1.4_rc2.ebuild
@@ -1,12 +1,15 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/jmcce/jmcce-1.4_rc2.ebuild,v 1.3 2003/09/06 22:19:22 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/jmcce/jmcce-1.4_rc2.ebuild,v 1.4 2004/01/22 06:32:25 usata Exp $
+
+inherit gcc
+
+MY_P=${P/_rc/RC}
+S=${WORKDIR}/${MY_P}
-MY_PV=${PV/_rc/RC}
-S=${WORKDIR}/${PN}-${MY_PV}
DESCRIPTION="A Chinese Console supporting BIG5, GB and Japanese input."
HOMEPAGE="http://jmcce.slat.org"
-SRC_URI="http://zope.slat.org/Project/Jmcce/DOWNLOAD/${PN}-${MY_PV}.tar.gz"
+SRC_URI="http://zope.slat.org/Project/Jmcce/DOWNLOAD/${MY_P}.tar.gz"
SLOT="0"
LICENSE="GPL-2"
@@ -18,22 +21,28 @@ DEPEND=">=media-libs/svgalib-1.4.3
MAKEOPTS="${MAKEOPTS} -j1"
-src_compile() {
+src_unpack() {
+
+ unpack ${A}
cd ${S}
+ if [ `gcc-version` = "3.3" ] ; then
+ epatch ${FILESDIR}/${P}-gcc3-gentoo.diff
+ fi
+}
- ./genconf.sh
- econf --sysconfdir=/etc/jmcce
+src_compile() {
+
+ ./genconf.sh || die
+ econf --sysconfdir=/etc/jmcce || die "econf failed"
emake || die "make failed"
}
src_install() {
+
dodir /etc/jmcce
make DESTDIR=${D} install || die "install failed"
- dodir /usr/share/doc
- mv ${D}/usr/share/doc/jmcce-1.4RC2 ${D}/usr/share/doc/${PF}
+ mv ${D}/usr/share/doc/{${MY_P},${PF}}
doman doc/jmcce.1
}
-
-