summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-03-28 22:10:24 +0000
committerMike Frysinger <vapier@gentoo.org>2012-03-28 22:10:24 +0000
commitc0e245054a98480f69815e1bd82184d7e493e110 (patch)
treeba7656fe7f5e98d70eb8594065fdde74a86be40b /app-i18n/ibus
parentBlock <udev-init-scripts-10 due to file collision with /lib/udev/rules.d/40-g... (diff)
downloadgentoo-2-c0e245054a98480f69815e1bd82184d7e493e110.tar.gz
gentoo-2-c0e245054a98480f69815e1bd82184d7e493e110.tar.bz2
gentoo-2-c0e245054a98480f69815e1bd82184d7e493e110.zip
Utilize REQUIRED_USE rather than confutils, and fix USE=-python build failure.
(Portage version: 2.2.0_alpha95/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n/ibus')
-rw-r--r--app-i18n/ibus/ChangeLog6
-rw-r--r--app-i18n/ibus/ibus-1.4.1.ebuild11
2 files changed, 11 insertions, 6 deletions
diff --git a/app-i18n/ibus/ChangeLog b/app-i18n/ibus/ChangeLog
index 1cc75d58c583..d7ed28f62a1e 100644
--- a/app-i18n/ibus/ChangeLog
+++ b/app-i18n/ibus/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-i18n/ibus
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus/ChangeLog,v 1.107 2012/03/28 21:52:09 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus/ChangeLog,v 1.108 2012/03/28 22:10:24 vapier Exp $
+
+ 28 Mar 2012; Mike Frysinger <vapier@gentoo.org> ibus-1.4.1.ebuild:
+ Utilize REQUIRED_USE rather than confutils, and fix USE=-python build
+ failure.
28 Mar 2012; Mike Frysinger <vapier@gentoo.org> ibus-1.4.1.ebuild:
Add arm love.
diff --git a/app-i18n/ibus/ibus-1.4.1.ebuild b/app-i18n/ibus/ibus-1.4.1.ebuild
index 1d87d565582c..c3fbec5a7ac0 100644
--- a/app-i18n/ibus/ibus-1.4.1.ebuild
+++ b/app-i18n/ibus/ibus-1.4.1.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus/ibus-1.4.1.ebuild,v 1.8 2012/03/28 21:52:09 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus/ibus-1.4.1.ebuild,v 1.9 2012/03/28 22:10:24 vapier Exp $
EAPI=4
PYTHON_DEPEND="python? 2:2.5"
-inherit confutils eutils gnome2-utils multilib python autotools
+inherit eutils gnome2-utils multilib python autotools
DESCRIPTION="Intelligent Input Bus for Linux / Unix OS"
HOMEPAGE="http://code.google.com/p/ibus/"
@@ -15,6 +15,7 @@ LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 arm ppc ppc64 x86 ~x86-fbsd"
IUSE="dconf doc +gconf gtk gtk3 +introspection nls +python vala X"
+REQUIRED_USE="|| ( gtk gtk3 X )" #342903
RDEPEND=">=dev-libs/glib-2.26
dconf? ( >=gnome-base/dconf-0.7.5 )
@@ -73,8 +74,6 @@ update_gtk3_immodules() {
}
pkg_setup() {
- # bug #342903
- confutils_require_any X gtk gtk3
if use python; then
python_set_active_version 2
python_pkg_setup
@@ -96,6 +95,8 @@ src_prepare() {
}
src_configure() {
+ # We cannot call $(PYTHON) if we haven't called python_pkg_setup
+ use python && PYTHON=$(PYTHON) || PYTHON=
econf \
$(use_enable dconf) \
$(use_enable doc gtk-doc) \
@@ -109,7 +110,7 @@ src_configure() {
$(use_enable python) \
$(use_enable vala) \
$(use_enable X xim) \
- PYTHON="$(PYTHON)"
+ PYTHON="${PYTHON}"
}
src_install() {