summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMu Qiao <qiaomuf@gentoo.org>2010-12-19 02:48:24 +0000
committerMu Qiao <qiaomuf@gentoo.org>2010-12-19 02:48:24 +0000
commita1b752c1907932578fcc895238092917dc8b5cbe (patch)
treefe80f1a3efa099ffc5e6e585e402ce81fecac95a /app-i18n/fcitx
parentVersion bump (diff)
downloadgentoo-2-a1b752c1907932578fcc895238092917dc8b5cbe.tar.gz
gentoo-2-a1b752c1907932578fcc895238092917dc8b5cbe.tar.bz2
gentoo-2-a1b752c1907932578fcc895238092917dc8b5cbe.zip
Make fcitx compile without pango.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n/fcitx')
-rw-r--r--app-i18n/fcitx/ChangeLog6
-rw-r--r--app-i18n/fcitx/fcitx-4.0.1.ebuild9
-rw-r--r--app-i18n/fcitx/files/fcitx-4.0.1-fix-pango.patch18
3 files changed, 31 insertions, 2 deletions
diff --git a/app-i18n/fcitx/ChangeLog b/app-i18n/fcitx/ChangeLog
index 2b81b8cc4849..f76bbb6f2ae6 100644
--- a/app-i18n/fcitx/ChangeLog
+++ b/app-i18n/fcitx/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-i18n/fcitx
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/fcitx/ChangeLog,v 1.33 2010/12/18 10:06:32 qiaomuf Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/fcitx/ChangeLog,v 1.34 2010/12/19 02:48:24 qiaomuf Exp $
+
+ 19 Dec 2010; Mu Qiao <qiaomuf@gentoo.org> fcitx-4.0.1.ebuild,
+ +files/fcitx-4.0.1-fix-pango.patch:
+ Make fcitx compile without pango.
*fcitx-4.0.1 (18 Dec 2010)
diff --git a/app-i18n/fcitx/fcitx-4.0.1.ebuild b/app-i18n/fcitx/fcitx-4.0.1.ebuild
index 627692f8a76d..25c88b1f6076 100644
--- a/app-i18n/fcitx/fcitx-4.0.1.ebuild
+++ b/app-i18n/fcitx/fcitx-4.0.1.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/fcitx/fcitx-4.0.1.ebuild,v 1.1 2010/12/18 09:10:07 qiaomuf Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/fcitx/fcitx-4.0.1.ebuild,v 1.2 2010/12/19 02:48:24 qiaomuf Exp $
EAPI="3"
+inherit eutils
+
DESCRIPTION="Free Chinese Input Toy for X. Another Chinese XIM Input Method"
HOMEPAGE="http://www.fcitx.org/"
SRC_URI="http://fcitx.googlecode.com/files/${P}_all.tar.gz"
@@ -24,6 +26,11 @@ DEPEND="${RDEPEND}
x11-proto/xproto
dev-util/pkgconfig"
+src_prepare() {
+ # fix a bug when compiling without pango
+ epatch "${FILESDIR}/${P}-fix-pango.patch"
+}
+
src_configure() {
econf \
$(use_enable dbus) \
diff --git a/app-i18n/fcitx/files/fcitx-4.0.1-fix-pango.patch b/app-i18n/fcitx/files/fcitx-4.0.1-fix-pango.patch
new file mode 100644
index 000000000000..280f8f5bc197
--- /dev/null
+++ b/app-i18n/fcitx/files/fcitx-4.0.1-fix-pango.patch
@@ -0,0 +1,18 @@
+--- fcitx-4.0.1/src/ui/ui.c 2010-12-17 12:20:02.000000000 +0800
++++ fcitx-4.0.1-patched/src/ui/ui.c 2010-12-19 10:24:26.646000021 +0800
+@@ -986,6 +986,8 @@
+ return desc;
+ }
+
++#endif
++
+ Visual * FindARGBVisual (Display *dpy, int scr)
+ {
+ XVisualInfo *xvi;
+@@ -1018,6 +1020,3 @@
+ XFree (xvi);
+ return visual;
+ }
+-
+-
+-#endif