summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2005-03-01 11:28:08 +0000
committerMamoru Komachi <usata@gentoo.org>2005-03-01 11:28:08 +0000
commitc9cdc7bc4e208e3b93af0325c40022371392628c (patch)
treed2e28d8d348cdd3473e7eca56c727e8cdb294b48 /app-i18n/fcitx/fcitx-3.0.4.ebuild
parentInitial import as per bug #73955 (diff)
downloadgentoo-2-c9cdc7bc4e208e3b93af0325c40022371392628c.tar.gz
gentoo-2-c9cdc7bc4e208e3b93af0325c40022371392628c.tar.bz2
gentoo-2-c9cdc7bc4e208e3b93af0325c40022371392628c.zip
Version bumped. Thanks to Jackey Yang <043936y@acadiau.ca>; bug #82900.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'app-i18n/fcitx/fcitx-3.0.4.ebuild')
-rw-r--r--app-i18n/fcitx/fcitx-3.0.4.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/app-i18n/fcitx/fcitx-3.0.4.ebuild b/app-i18n/fcitx/fcitx-3.0.4.ebuild
new file mode 100644
index 000000000000..5e7502a80a82
--- /dev/null
+++ b/app-i18n/fcitx/fcitx-3.0.4.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/fcitx/fcitx-3.0.4.ebuild,v 1.1 2005/03/01 11:28:08 usata Exp $
+
+DESCRIPTION="Free Chinese Input Toy for X. Another Chinese XIM Input Method"
+HOMEPAGE="http://www.fcitx.org/"
+SRC_URI="http://www.fcitx.org/download/${P}.tar.bz2"
+
+# The HOMEPAGE and SRC_URI cannot be accessed from outside China :-(
+RESTRICT="nomirror"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="truetype"
+
+DEPEND="virtual/x11
+ truetype? ( virtual/xft )"
+
+src_compile() {
+ myconf=
+ if use truetype ; then
+ myconf=" --with-xft "
+ else
+ myconf=" --disable-xft "
+ fi
+ econf ${myconf} || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install()
+{
+ dobin src/fcitx
+ insinto /usr/share/fcitx/data
+ doins data/*.mb
+ doins data/*.dat
+ doins data/*.conf
+ insinto /usr/share/fcitx/xpm
+ doins xpm/*.xpm
+ insinto /usr/share/fcitx/doc
+ doins doc/*.txt
+ doins doc/*.htm
+}
+
+pkg_postinst()
+{
+ einfo "You should export the following variables to use fcitx"
+ einfo " export XMODIFIERS=\"@im=fcitx\""
+ einfo " export XIM=fcitx"
+ einfo " export XIM_PROGRAM=fcitx"
+ einfo ""
+ einfo "If you want to use WuBi or ErBi"
+ einfo " cp /usr/share/fcitx/data/wbx.mb ~/.fcitx"
+ einfo " cp /usr/share/fcitx/data/erbi.mb ~/.fcitx"
+ einfo " cp /usr/share/fcitx/data/tables.conf ~/.fcitx"
+ einfo ""
+ einfo "Note that fcitx only works in the zh_CN locale."
+}