summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2005-02-28 15:43:09 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2005-02-28 15:43:09 +0000
commit3606c12387e0803e8a7b8ff480bcdb3e20c06ba2 (patch)
treebb4d6110bdaba6f13796829750dca1bbc9b59b51 /app-i18n/anthy/anthy-6300.ebuild
parentAdded ~amd64. (diff)
downloadgentoo-2-3606c12387e0803e8a7b8ff480bcdb3e20c06ba2.tar.gz
gentoo-2-3606c12387e0803e8a7b8ff480bcdb3e20c06ba2.tar.bz2
gentoo-2-3606c12387e0803e8a7b8ff480bcdb3e20c06ba2.zip
Version bumped.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'app-i18n/anthy/anthy-6300.ebuild')
-rw-r--r--app-i18n/anthy/anthy-6300.ebuild76
1 files changed, 76 insertions, 0 deletions
diff --git a/app-i18n/anthy/anthy-6300.ebuild b/app-i18n/anthy/anthy-6300.ebuild
new file mode 100644
index 000000000000..a5334531f0ca
--- /dev/null
+++ b/app-i18n/anthy/anthy-6300.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy/anthy-6300.ebuild,v 1.1 2005/02/28 15:43:09 matsuu Exp $
+
+inherit elisp-common eutils
+
+IUSE="emacs ucs4"
+
+DESCRIPTION="Anthy -- free and secure Japanese input system"
+HOMEPAGE="http://anthy.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/anthy/13543/${P}.tar.gz"
+
+RESTRICT="nomirror"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc-macos ~sparc ~x86"
+SLOT="0"
+
+DEPEND="emacs? ( virtual/emacs )
+ !app-i18n/anthy-ss"
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S}
+ if has_version '>=sys-devel/gcc-3.4' ; then
+ epatch ${FILESDIR}/anthy-mkdic-gcc34.patch
+ fi
+}
+
+src_compile() {
+
+ local myconf
+ local cannadicdir=/var/lib/canna/dic/canna
+
+ use emacs || myconf="EMACS=no"
+ use ucs4 && myconf="${myconf} --enable-ucs4"
+
+ if has_version 'app-dicts/canna-zipcode'; then
+ einfo "Adding zipcode.t and jigyosyo.t to anthy.dic."
+ cp ${cannadicdir}/{zipcode,jigyosyo}.t mkanthydic
+ sed -i -e "/^EXTRA_DICS/s|$| zipcode.t jigyosyo.t|" mkanthydic/Makefile.in
+ fi
+
+ if has_version 'app-dicts/canna-2ch'; then
+ einfo "Adding nichan.ctd to anthy.dic."
+ cp ${cannadicdir}/nichan.ctd mkanthydic/2ch.t
+ sed -i -e "/^EXTRA_DICS/s|$| 2ch.t|" mkanthydic/Makefile.in
+ fi
+
+ econf ${myconf} || die
+ emake || die
+
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+
+ use emacs && elisp-site-file-install ${FILESDIR}/50anthy-gentoo.el
+
+ dodoc [A-Z][A-Z]* ChangeLog doc/[A-Z0-9][A-Z0-9]* doc/protocol.txt
+
+}
+
+pkg_postinst() {
+
+ use emacs && elisp-site-regen
+
+}
+
+pkg_postrm() {
+
+ has_version virtual/emacs && elisp-site-regen
+
+}