summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2004-07-18 13:03:24 +0000
committerAkinori Hattori <hattya@gentoo.org>2004-07-18 13:03:24 +0000
commit6bb136ed3a98e8b7d6ed7fd5b20af4774c86a769 (patch)
tree8f297155b623c5de79a798b435d109f0615246d6 /app-i18n/anthy-ss
parent~x86 keyworded due to bug #57472 (Manifest recommit) (diff)
downloadgentoo-2-6bb136ed3a98e8b7d6ed7fd5b20af4774c86a769.tar.gz
gentoo-2-6bb136ed3a98e8b7d6ed7fd5b20af4774c86a769.tar.bz2
gentoo-2-6bb136ed3a98e8b7d6ed7fd5b20af4774c86a769.zip
version bump
Diffstat (limited to 'app-i18n/anthy-ss')
-rw-r--r--app-i18n/anthy-ss/ChangeLog5
-rw-r--r--app-i18n/anthy-ss/Manifest10
-rw-r--r--app-i18n/anthy-ss/anthy-ss-5516.ebuild74
-rw-r--r--app-i18n/anthy-ss/files/digest-anthy-ss-55161
4 files changed, 85 insertions, 5 deletions
diff --git a/app-i18n/anthy-ss/ChangeLog b/app-i18n/anthy-ss/ChangeLog
index 5d03f6033952..8fdf08d5bf07 100644
--- a/app-i18n/anthy-ss/ChangeLog
+++ b/app-i18n/anthy-ss/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-i18n/anthy-ss
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy-ss/ChangeLog,v 1.34 2004/06/24 21:43:21 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy-ss/ChangeLog,v 1.35 2004/07/18 13:03:23 hattya Exp $
+
+ 18 Jul 2004; Akinori Hattori <hattya@gentoo.org> :
+ version bump.
*anthy-ss-5414 (17 Jun 2004)
diff --git a/app-i18n/anthy-ss/Manifest b/app-i18n/anthy-ss/Manifest
index 809fd683ceb5..192f8b61742b 100644
--- a/app-i18n/anthy-ss/Manifest
+++ b/app-i18n/anthy-ss/Manifest
@@ -1,11 +1,13 @@
-MD5 908f95bcee0ac6ee56a960457dfb2828 anthy-ss-5414.ebuild 1651
-MD5 a9c772321addea62a5542f0434f688ff anthy-ss-5330.ebuild 1651
+MD5 2f510b565a5626f7e087d95b85d1313f ChangeLog 4901
MD5 cee426fb350544c58b4c37e679ce88b2 anthy-ss-5326.ebuild 1651
+MD5 a9c772321addea62a5542f0434f688ff anthy-ss-5330.ebuild 1651
MD5 440a66b95feb83768aec410bfd833a4e anthy-ss-5406.ebuild 1651
-MD5 8e9203cccda033f4ac451f0e31391a79 ChangeLog 4831
+MD5 908f95bcee0ac6ee56a960457dfb2828 anthy-ss-5414.ebuild 1651
+MD5 1c6815b40a6dfbc67840afb6b3561c58 anthy-ss-5516.ebuild 1550
MD5 bae17b53f1633ca708e67b8762933954 metadata.xml 616
+MD5 d91fcb424ec63b588900d2d88a8bcee2 files/50anthy-gentoo.el 99
MD5 375c456edc2307faae526f62a995ae5d files/digest-anthy-ss-5326 63
MD5 5fa8f1dbb79f8c44aa6d3a8827cb10be files/digest-anthy-ss-5330 63
MD5 5cf47066ec69dd7bf5cb5608655b26ed files/digest-anthy-ss-5406 63
MD5 7b897d744e2bdb8daebdcbe4ff258cff files/digest-anthy-ss-5414 63
-MD5 d91fcb424ec63b588900d2d88a8bcee2 files/50anthy-gentoo.el 99
+MD5 ae0b002102ce35af49630eaab916579b files/digest-anthy-ss-5516 63
diff --git a/app-i18n/anthy-ss/anthy-ss-5516.ebuild b/app-i18n/anthy-ss/anthy-ss-5516.ebuild
new file mode 100644
index 000000000000..c3c9ac6746ae
--- /dev/null
+++ b/app-i18n/anthy-ss/anthy-ss-5516.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy-ss/anthy-ss-5516.ebuild,v 1.1 2004/07/18 13:03:23 hattya Exp $
+
+inherit elisp-common
+
+IUSE="emacs ucs4"
+
+MY_P="${P/-ss/}"
+
+DESCRIPTION="Anthy -- free and secure Japanese input system"
+HOMEPAGE="http://anthy.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/anthy/10401/${MY_P}.tar.gz"
+
+RESTRICT="nomirror"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+SLOT="0"
+S="${WORKDIR}/${MY_P}"
+
+DEPEND="emacs? ( virtual/emacs )
+ !app-i18n/anthy"
+
+# Anthy can not compile with sandbox since version 5209.
+# It always causes SEGV at making mkanthydic.
+SANDBOX_DISABLED="1"
+
+src_compile() {
+
+ local myconf
+ local cannadicdir=/var/lib/canna/dic/canna
+
+ use emacs || myconf="EMACS=no"
+ use ucs4 && myconf="${myconf} --enable-uc4"
+
+ if has_version 'app-dicts/canna-zipcode'; then
+ einfo "Adding zipcode.t and jigyosyo.t to anthy.dic."
+ cp ${cannadicdir}/{zipcode,jigyosyo}.t mkanthydic
+ sed -i -e "/^EXTRA_DICS/s|$| zipcode.t jigyosyo.t|" mkanthydic/Makefile.am
+ fi
+
+ if has_version 'app-dicts/canna-2ch'; then
+ einfo "Adding nichan.ctd to anthy.dic."
+ cp ${cannadicdir}/nichan.ctd mkanthydic/2ch.t
+ sed -i -e "/^EXTRA_DICS/s|$| 2ch.t|" mkanthydic/Makefile.am
+ fi
+
+ autoconf
+ econf ${myconf} || die
+ emake || die
+
+}
+
+src_install() {
+
+ einstall || die
+
+ use emacs && elisp-site-file-install ${FILESDIR}/50anthy-gentoo.el
+
+ dodoc [A-Z][A-Z]* ChangeLog doc/[A-Z0-9][A-Z0-9]* doc/protocol.txt
+
+}
+
+pkg_postinst() {
+
+ use emacs && elisp-site-regen
+
+}
+
+pkg_postrm() {
+
+ has_version virtual/emacs && elisp-site-regen
+
+}
diff --git a/app-i18n/anthy-ss/files/digest-anthy-ss-5516 b/app-i18n/anthy-ss/files/digest-anthy-ss-5516
new file mode 100644
index 000000000000..2f8548210508
--- /dev/null
+++ b/app-i18n/anthy-ss/files/digest-anthy-ss-5516
@@ -0,0 +1 @@
+MD5 5837c21ea43ca085a917e0482c4fc620 anthy-5516.tar.gz 1546350