summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2003-10-01 21:19:03 +0000
committerMamoru Komachi <usata@gentoo.org>2003-10-01 21:19:03 +0000
commit4cd6edd6fa8adf6f3f933938b2b2295c8c3e919e (patch)
tree46e701abea41bdeb03df5dfc284906f8155fa550 /app-i18n/anthy-ss
parentbump rev on ebuild for eclass changes, and move to stable (diff)
downloadgentoo-2-4cd6edd6fa8adf6f3f933938b2b2295c8c3e919e.tar.gz
gentoo-2-4cd6edd6fa8adf6f3f933938b2b2295c8c3e919e.tar.bz2
gentoo-2-4cd6edd6fa8adf6f3f933938b2b2295c8c3e919e.zip
Version bumped. Added ~alpha, ~sparc and ~ppc keywords
Diffstat (limited to 'app-i18n/anthy-ss')
-rw-r--r--app-i18n/anthy-ss/Manifest10
-rw-r--r--app-i18n/anthy-ss/anthy-ss-4601.ebuild71
-rw-r--r--app-i18n/anthy-ss/files/digest-anthy-ss-46011
3 files changed, 78 insertions, 4 deletions
diff --git a/app-i18n/anthy-ss/Manifest b/app-i18n/anthy-ss/Manifest
index 9b13132e5912..9788047fd3be 100644
--- a/app-i18n/anthy-ss/Manifest
+++ b/app-i18n/anthy-ss/Manifest
@@ -1,11 +1,13 @@
+MD5 b448f83cf0b7c04260de08ce95b30805 anthy-ss-4524.ebuild 1502
+MD5 ca30b7ef075f2fc650499a1a074aa91f metadata.xml 818
MD5 541eaff5b3a4a47eb74b0a3bfd0e3fdd ChangeLog 764
-MD5 8ae409761917b1160922ed657fdb2630 anthy-ss-4507.ebuild 1533
MD5 279a83f3bec141471313db69fd533278 anthy-ss-4515.ebuild 1533
MD5 96706081d9ce58b04439fd765efd4399 anthy-ss-4519.ebuild 1533
-MD5 b448f83cf0b7c04260de08ce95b30805 anthy-ss-4524.ebuild 1502
-MD5 ca30b7ef075f2fc650499a1a074aa91f metadata.xml 818
+MD5 1a1d4ee2f79e04403df1d6909103fc0b anthy-ss-4601.ebuild 1521
+MD5 8ae409761917b1160922ed657fdb2630 anthy-ss-4507.ebuild 1533
MD5 d91fcb424ec63b588900d2d88a8bcee2 files/50anthy-gentoo.el 99
+MD5 eb98e0463fbc96e00ae0d27e10f68e7e files/digest-anthy-ss-4524 63
MD5 7bbcd511928477630332c6bd34c6e528 files/digest-anthy-ss-4507 63
MD5 8d9909abec0c2c896ebb184e5f1b2af9 files/digest-anthy-ss-4515 63
MD5 7cc76494f7d2185070a6b156a13b3f39 files/digest-anthy-ss-4519 63
-MD5 eb98e0463fbc96e00ae0d27e10f68e7e files/digest-anthy-ss-4524 63
+MD5 f8f5923028de00ce97fc403b4eb54c74 files/digest-anthy-ss-4601 63
diff --git a/app-i18n/anthy-ss/anthy-ss-4601.ebuild b/app-i18n/anthy-ss/anthy-ss-4601.ebuild
new file mode 100644
index 000000000000..f05692e36cb4
--- /dev/null
+++ b/app-i18n/anthy-ss/anthy-ss-4601.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy-ss/anthy-ss-4601.ebuild,v 1.1 2003/10/01 21:19:00 usata Exp $
+
+inherit elisp-common
+
+IUSE="emacs"
+
+MY_P="${P/-ss/}"
+
+DESCRIPTION="Anthy -- free and secure Japanese input system"
+HOMEPAGE="http://anthy.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/anthy/6187/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~alpha ~sparc ~ppc"
+SLOT="0"
+S="${WORKDIR}/${MY_P}"
+
+DEPEND="virtual/glibc
+ emacs? ( virtual/emacs )
+ !app-i18n/anthy"
+
+src_compile() {
+
+ local myconf
+ local cannadicdir=/var/lib/canna/dic/canna
+
+ use emacs || myconf="${myconf} EMACS=no"
+
+ if has_version 'app-dicts/canna-zipcode'; then
+ einfo "Adding zipcode.t and jigyosyo.t to anthy.dic."
+ cp ${cannadicdir}/{zipcode,jigyosyo}.t mkanthydic
+ sed -i -e "/^EXTRA_DICS/s|$| zipcode.t jigyosyo.t|" \
+ mkanthydic/Makefile.{in,am}
+ fi
+
+ if has_version 'app-dicts/canna-2ch'; then
+ einfo "Adding nichan.ctd to anthy.dic."
+ cp ${cannadicdir}/nichan.ctd mkanthydic/2ch.t
+ sed -i -e "/^EXTRA_DICS/s|$| 2ch.t|" \
+ mkanthydic/Makefile.{in,am}
+ fi
+
+ econf ${myconf} || die
+ emake || die
+
+}
+
+src_install() {
+
+ einstall || die
+
+ use emacs && elisp-site-file-install ${FILESDIR}/50anthy-gentoo.el
+
+ dodoc AUTHORS ChangeLog DIARY INSTALL NEWS README \
+ doc/[A-Z0-9][A-Z0-9]* doc/protocol.txt
+
+}
+
+pkg_postinst() {
+
+ use emacs && elisp-site-regen
+
+}
+
+pkg_postrm() {
+
+ use emacs && elisp-site-regen
+
+}
diff --git a/app-i18n/anthy-ss/files/digest-anthy-ss-4601 b/app-i18n/anthy-ss/files/digest-anthy-ss-4601
new file mode 100644
index 000000000000..3c54d498f42f
--- /dev/null
+++ b/app-i18n/anthy-ss/files/digest-anthy-ss-4601
@@ -0,0 +1 @@
+MD5 2c85723d2e9031afffae4e24518c7596 anthy-4601.tar.gz 1419970