summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2005-09-25 00:47:34 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2005-09-25 00:47:34 +0000
commit98cafeb56f3e84c48176d517242c828d7386f9f5 (patch)
tree45bf1b95dc0675a1f6951eaafab707d0f732e304 /app-i18n/ami/ami-1.2.3-r1.ebuild
parentFixed url. (diff)
downloadgentoo-2-98cafeb56f3e84c48176d517242c828d7386f9f5.tar.gz
gentoo-2-98cafeb56f3e84c48176d517242c828d7386f9f5.tar.bz2
gentoo-2-98cafeb56f3e84c48176d517242c828d7386f9f5.zip
gtk2 removal, Bug 106560. cleanup ebuild.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'app-i18n/ami/ami-1.2.3-r1.ebuild')
-rw-r--r--app-i18n/ami/ami-1.2.3-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-i18n/ami/ami-1.2.3-r1.ebuild b/app-i18n/ami/ami-1.2.3-r1.ebuild
new file mode 100644
index 000000000000..1b45d90b40b2
--- /dev/null
+++ b/app-i18n/ami/ami-1.2.3-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ami/ami-1.2.3-r1.ebuild,v 1.1 2005/09/25 00:47:34 matsuu Exp $
+
+inherit eutils
+
+IUSE=""
+
+DESCRIPTION="Korean IMS Ami"
+SRC_URI="http://download.kldp.net/ami/${P}.tar.gz
+ http://ami.kldp.net/hanja.dic.gz"
+HOMEPAGE="http://ami.kldp.net/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ >=media-libs/gdk-pixbuf-0.7.0"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-imhangul_status.patch
+}
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ insinto /usr/share/ami
+ doins ${WORKDIR}/hanja.dic || die
+
+ insinto /usr/share/applnk/Utilities; doins ami.kdelnk
+ insinto /etc/CORBA/servers; doins ami.gnorba
+
+ #dosym ami /usr/bin/ami_applet
+ #insinto /usr/share/applets/Utility; doins ami.desktop
+
+ dodoc AUTHORS COPYING* ChangeLog INSTALL README README.en NEWS THANKS
+}