summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-01-04 23:38:20 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-01-04 23:38:20 +0000
commitda20ccbd879a9c26db9c8c31c3a7a476ab8cf363 (patch)
tree3387b8cf65960576e5ea240b7ebd09fc2f5cd9df /app-forensics
parentVersion bump. (diff)
downloadgentoo-2-da20ccbd879a9c26db9c8c31c3a7a476ab8cf363.tar.gz
gentoo-2-da20ccbd879a9c26db9c8c31c3a7a476ab8cf363.tar.bz2
gentoo-2-da20ccbd879a9c26db9c8c31c3a7a476ab8cf363.zip
Bump to 3.0.0, fixes #203773
(Portage version: 2.2_rc20/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/sleuthkit/ChangeLog9
-rw-r--r--app-forensics/sleuthkit/sleuthkit-3.0.0.ebuild37
2 files changed, 44 insertions, 2 deletions
diff --git a/app-forensics/sleuthkit/ChangeLog b/app-forensics/sleuthkit/ChangeLog
index ece9dfd021d1..af2b4b6db741 100644
--- a/app-forensics/sleuthkit/ChangeLog
+++ b/app-forensics/sleuthkit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-forensics/sleuthkit
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/sleuthkit/ChangeLog,v 1.33 2008/07/31 09:51:13 ulm Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/sleuthkit/ChangeLog,v 1.34 2009/01/04 23:38:20 patrick Exp $
+
+*sleuthkit-3.0.0 (04 Jan 2009)
+
+ 04 Jan 2009; Patrick Lauer <patrick@gentoo.org> +sleuthkit-3.0.0.ebuild:
+ Bump to 3.0.0, fixes #203773
31 Jul 2008; Ulrich Mueller <ulm@gentoo.org> metadata.xml:
Add USE flag description to metadata wrt GLEP 56.
diff --git a/app-forensics/sleuthkit/sleuthkit-3.0.0.ebuild b/app-forensics/sleuthkit/sleuthkit-3.0.0.ebuild
new file mode 100644
index 000000000000..1936e37b73c8
--- /dev/null
+++ b/app-forensics/sleuthkit/sleuthkit-3.0.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/sleuthkit/sleuthkit-3.0.0.ebuild,v 1.1 2009/01/04 23:38:20 patrick Exp $
+
+inherit eutils flag-o-matic autotools
+
+SLOT=0
+
+DESCRIPTION="A collection of file system and media management forensic analysis tools"
+HOMEPAGE="http://www.sleuthkit.org/sleuthkit/"
+SRC_URI="mirror://sourceforge/sleuthkit/${P}.tar.gz"
+
+LICENSE="GPL-2 IBM"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~s390 ~sparc ~x86"
+
+# disabling until imported into portage - patrick
+#DEPEND="ewf? ( app-forensics/libewf )
+# aff? ( app-forensics/afflib )"
+RDEPEND="dev-perl/DateManip"
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+ # AC_FUNC_REALLOC in configure.ac that hasn't been propagated
+ eautoreconf
+}
+
+src_compile() {
+ use hfs && append-flags "-DTSK_USE_HFS"
+ econf || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc docs/*.txt README.txt CHANGES.txt TODO.txt
+}