summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-01-05 00:04:28 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-01-05 00:04:28 +0000
commitd8f78b4d483790593a398949eeefbde237ff4772 (patch)
treedbbff423bfd520eeea0b5b419304f38e9989246b /app-forensics
parent=net-www/xxv-1.2.1383 , =x11-themes/xxv-skins-1.2.1383 masked for utf8handle ... (diff)
downloadgentoo-2-d8f78b4d483790593a398949eeefbde237ff4772.tar.gz
gentoo-2-d8f78b4d483790593a398949eeefbde237ff4772.tar.bz2
gentoo-2-d8f78b4d483790593a398949eeefbde237ff4772.zip
Bumping to 1.18, fixes #165300, thanks to RB <aoz.syn@gmail.com>
(Portage version: 2.2_rc20/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/tct/ChangeLog9
-rw-r--r--app-forensics/tct/tct-1.18.ebuild92
2 files changed, 99 insertions, 2 deletions
diff --git a/app-forensics/tct/ChangeLog b/app-forensics/tct/ChangeLog
index 1296316aa2e4..5f435b1539cf 100644
--- a/app-forensics/tct/ChangeLog
+++ b/app-forensics/tct/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-forensics/tct
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/tct/ChangeLog,v 1.10 2007/03/04 19:52:37 peper Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/tct/ChangeLog,v 1.11 2009/01/05 00:04:28 patrick Exp $
+
+*tct-1.18 (05 Jan 2009)
+
+ 05 Jan 2009; Patrick Lauer <patrick@gentoo.org> +tct-1.18.ebuild:
+ Bumping to 1.18, fixes #165300, thanks to RB <aoz.syn@gmail.com>
04 Mar 2007; Piotr Jaroszyński <peper@gentoo.org> tct-1.15-r1.ebuild:
Fix incomplete sys-apps/lsof -> sys-process/lsof move.
diff --git a/app-forensics/tct/tct-1.18.ebuild b/app-forensics/tct/tct-1.18.ebuild
new file mode 100644
index 000000000000..9d32e0efc79e
--- /dev/null
+++ b/app-forensics/tct/tct-1.18.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/tct/tct-1.18.ebuild,v 1.1 2009/01/05 00:04:28 patrick Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="The Coroner's Toolkit - a collection of tools to aide in gathering and analyzing forensic data on a UNIX system"
+HOMEPAGE="http://www.porcupine.org/forensics/tct.html"
+SRC_URI="http://www.porcupine.org/forensics/${P}.tar.gz"
+
+LICENSE="IBM as-is"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+
+DEPEND=">=dev-lang/perl-5.0004
+ >=sys-apps/sed-4"
+RDEPEND="${DEPEND}
+ dev-perl/DateManip"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ sed -i "s:^\(CC.*= \).*:\1$(tc-getCC):" Makefile || die "sed CC failed"
+ sed -i "s:\$(OPT) \$(DEBUG):${CFLAGS}:" */*/Makefile \
+ || die "sed CFLAGS failed"
+
+ epatch "${FILESDIR}/tct-1.15-gentoo.diff"
+}
+
+src_install() {
+ # bins/libs
+ into /usr/lib/tct
+ dobin bin/* || die "bin installation failed"
+
+ exeinto /usr/lib/tct
+ doexe reconfig || die "reconfig installation failed"
+
+ insinto /usr/lib/tct/lib
+ doins lib/*.pl || die "lib installation failed"
+
+ exeinto /usr/lib/tct/extras
+ doexe extras/bdf extras/ils2mac extras/realpath extras/entropy/entropy \
+ extras/findkey/findkey || die "extras installation failed"
+
+ # config
+ insinto /etc/tct
+ doins conf/* || die "conf installation failed"
+
+ # docs
+ newdoc extras/README README.extras || die "newdoc failed"
+ dodoc docs/* Beware CHANGES INSTALL OS-NOTES README.FIRST \
+ TODO* additional-resources bibliography help-recovering-file \
+ help-when-broken-into quick-start || die "doc installation failed"
+
+ # these manual pages are provided by other packages
+ rm man/man1/file.1
+ rm man/man1/md5.1
+ rm man/man1/ils.1
+ rm man/man1/icat.1
+ rm man/man1/mactime.1
+ rm man/man1/lastcomm.1
+ rm man/man5/magic.5
+ doman man/*/* || die "man installation failed"
+
+ # setup dirs/symlinks
+ keepdir /var/log/tct
+
+ dosym /etc/tct /usr/lib/tct/conf || die "dosym failed"
+
+ keepdir /var/lib/tct
+ dosym /var/lib/tct /usr/lib/tct/data || die "dosym failed"
+
+ dodir /usr/sbin
+ cd ${S}/bin
+ # all binaries except the following are meant for internal use
+ for bin in grave-robber lazarus mactime unrm; do
+ dosym /usr/lib/tct/bin/${bin} /usr/sbin/${bin} \
+ || die "dosym ${bin} failed"
+ done
+}
+
+pkg_postinst() {
+ echo
+ elog "The authors of The Coroner's Toolkit highly recommend"
+ elog "installing sys-process/lsof for use by the toolkit."
+ elog
+ elog "Please read the README and quickstart files installed"
+ elog "in /usr/share/doc/${PF} before using The Coroner's Toolkit."
+ echo
+}