summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-03-01 00:46:59 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-03-01 00:46:59 +0000
commit7455ce3c1783b730a500ddc4d71a5793edbbc852 (patch)
tree5136e874af786a3c013999eb9a60c2a70218612c /app-forensics
parentInitial commit (diff)
downloadgentoo-2-7455ce3c1783b730a500ddc4d71a5793edbbc852.tar.gz
gentoo-2-7455ce3c1783b730a500ddc4d71a5793edbbc852.tar.bz2
gentoo-2-7455ce3c1783b730a500ddc4d71a5793edbbc852.zip
Initial import. Ebuild by RB <aoz.syn@gmail.com>. Fixes #224121
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/libewf/ChangeLog10
-rw-r--r--app-forensics/libewf/libewf-20090209.ebuild45
-rw-r--r--app-forensics/libewf/metadata.xml11
3 files changed, 66 insertions, 0 deletions
diff --git a/app-forensics/libewf/ChangeLog b/app-forensics/libewf/ChangeLog
new file mode 100644
index 000000000000..97a25cf097f4
--- /dev/null
+++ b/app-forensics/libewf/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-forensics/libewf
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/libewf/ChangeLog,v 1.1 2009/03/01 00:46:59 patrick Exp $
+
+*libewf-20090209 (01 Mar 2009)
+
+ 01 Mar 2009; Patrick Lauer <patrick@gentoo.org> +metadata.xml,
+ +libewf-20090209.ebuild:
+ Initial import. Ebuild by RB <aoz.syn@gmail.com>. Fixes #224121
+
diff --git a/app-forensics/libewf/libewf-20090209.ebuild b/app-forensics/libewf/libewf-20090209.ebuild
new file mode 100644
index 000000000000..96287ee0901c
--- /dev/null
+++ b/app-forensics/libewf/libewf-20090209.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/libewf/libewf-20090209.ebuild,v 1.1 2009/03/01 00:46:59 patrick Exp $
+
+inherit eutils autotools
+
+MY_P=${P/libewf/libewf-beta}
+
+DESCRIPTION="Implementation of the EWF (SMART and EnCase) image format"
+HOMEPAGE="http://libewf.sourceforge.net"
+SRC_URI="mirror://sourceforge/libewf/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+# upstream bug #2597171, pyewf has implicit declarations
+#IUSE="debug python rawio unicode"
+IUSE="debug rawio unicode"
+
+DEPEND="
+ sys-libs/e2fsprogs-libs
+ sys-libs/zlib
+ dev-libs/openssl"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ $(use_enable unicode wide-character-type) \
+ $(use_enable rawio raw-access) \
+ $(use_enable debug verbose-output) \
+ $(use_enable debug debug-output)
+ emake
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc AUTHORS ChangeLog NEWS README documents/*.txt
+ doman manuals/*.1 manuals/*.3
+}
diff --git a/app-forensics/libewf/metadata.xml b/app-forensics/libewf/metadata.xml
new file mode 100644
index 000000000000..fa78f75e299a
--- /dev/null
+++ b/app-forensics/libewf/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>forensics</herd>
+<maintainer>
+ <email>forensics@gentoo.org</email>
+</maintainer>
+<use>
+ <flag name="rawio">Enables raw IO handling</flag>
+</use>
+</pkgmetadata>