summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-12-17 10:34:43 +0000
committerTim Harder <radhermit@gentoo.org>2013-12-17 10:34:43 +0000
commit9280e7c9688d575b34fb7b0377d41aa231e127ab (patch)
tree84c0fe2971b1243b449e6eb285f5842d55631874 /app-forensics/libewf
parentVersion bump. (diff)
downloadgentoo-2-9280e7c9688d575b34fb7b0377d41aa231e127ab.tar.gz
gentoo-2-9280e7c9688d575b34fb7b0377d41aa231e127ab.tar.bz2
gentoo-2-9280e7c9688d575b34fb7b0377d41aa231e127ab.zip
Version bump.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-forensics/libewf')
-rw-r--r--app-forensics/libewf/ChangeLog7
-rw-r--r--app-forensics/libewf/libewf-20131210.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/app-forensics/libewf/ChangeLog b/app-forensics/libewf/ChangeLog
index 0e869c079bc1..6138d3f1ff1b 100644
--- a/app-forensics/libewf/ChangeLog
+++ b/app-forensics/libewf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-forensics/libewf
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/libewf/ChangeLog,v 1.53 2013/07/29 00:20:30 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/libewf/ChangeLog,v 1.54 2013/12/17 10:34:43 radhermit Exp $
+
+*libewf-20131210 (17 Dec 2013)
+
+ 17 Dec 2013; Tim Harder <radhermit@gentoo.org> +libewf-20131210.ebuild:
+ Version bump.
29 Jul 2013; Jeroen Roovers <jer@gentoo.org> libewf-20130416-r1.ebuild:
Marked ~hppa (bug #478394).
diff --git a/app-forensics/libewf/libewf-20131210.ebuild b/app-forensics/libewf/libewf-20131210.ebuild
new file mode 100644
index 000000000000..49f449983049
--- /dev/null
+++ b/app-forensics/libewf/libewf-20131210.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/libewf/libewf-20131210.ebuild,v 1.1 2013/12/17 10:34:43 radhermit Exp $
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="Implementation of the EWF (SMART and EnCase) image format"
+HOMEPAGE="http://code.google.com/p/libewf/"
+SRC_URI="https://googledrive.com/host/0B3fBvzttpiiSMTdoaVExWWNsRjg/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/2"
+KEYWORDS="~amd64 ~hppa ~x86"
+# upstream bug #2597171, pyewf has implicit declarations
+#IUSE="debug python rawio unicode"
+IUSE="bfio debug ewf +fuse rawio +ssl static-libs +uuid unicode zlib"
+
+DEPEND="
+ sys-libs/zlib
+ bfio? ( =app-forensics/libbfio-0.0.20120425_alpha )
+ fuse? ( sys-fs/fuse )
+ uuid? ( sys-apps/util-linux )
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}"
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+DOCS=( AUTHORS ChangeLog NEWS README documents/header.txt documents/header2.txt )
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug debug-output)
+ $(use_enable debug verbose-output)
+ $(use_enable ewf v1-api)
+ $(use_enable rawio low-level-functions)
+ $(use_enable unicode wide-character-type)
+ $(use_with zlib)
+ # autodetects bzip2 but does not use
+ --without-bzip2
+ $(use_with bfio libbfio)
+ $(use_with ssl openssl)
+ $(use_with uuid libuuid)
+ $(use_with fuse libfuse)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ doman manuals/*.1 manuals/*.3
+}