summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-02-14 15:42:54 +0000
committerJustin Lecher <jlec@gentoo.org>2015-02-14 15:42:54 +0000
commit6a919a18402c4f76f176ce7f8faacab3a0a16a00 (patch)
treeafcee66dbd5571dcb7c6c8bf9743a338085704c7 /app-forensics/afl/afl-1.45b.ebuild
parentStable for ppc, wrt bug #536790 (diff)
downloadgentoo-2-6a919a18402c4f76f176ce7f8faacab3a0a16a00.tar.gz
gentoo-2-6a919a18402c4f76f176ce7f8faacab3a0a16a00.tar.bz2
gentoo-2-6a919a18402c4f76f176ce7f8faacab3a0a16a00.zip
Version Bump
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'app-forensics/afl/afl-1.45b.ebuild')
-rw-r--r--app-forensics/afl/afl-1.45b.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-forensics/afl/afl-1.45b.ebuild b/app-forensics/afl/afl-1.45b.ebuild
new file mode 100644
index 000000000000..58351b2b7d6b
--- /dev/null
+++ b/app-forensics/afl/afl-1.45b.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/afl/afl-1.45b.ebuild,v 1.1 2015/02/14 15:42:54 jlec Exp $
+
+EAPI=5
+
+inherit multilib toolchain-funcs
+
+DESCRIPTION="american fuzzy lop - compile-time instrumentation fuzzer"
+HOMEPAGE="http://lcamtuf.coredump.cx/afl/"
+SRC_URI="http://lcamtuf.coredump.cx/afl/releases//${P}.tgz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="sys-devel/gcc"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake CC="$(tc-getCC)" \
+ PREFIX="/usr" \
+ HELPER_PATH="/usr/$(get_libdir)/afl" \
+ DOC_PATH="/usr/share/doc/${PF}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ PREFIX="/usr" \
+ HELPER_PATH="/usr/$(get_libdir)/afl" \
+ DOC_PATH="/usr/share/doc/${PF}" \
+ install
+}