summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-16 03:50:48 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-16 03:50:48 +0000
commitfb37e25951afd32789f705ebc7fdc056aaf835db (patch)
tree2e54bfcd30d963d2ef7b82daac5a63f0a6235c28 /app-emulation
parentVersion bump. (diff)
downloadgentoo-2-fb37e25951afd32789f705ebc7fdc056aaf835db.tar.gz
gentoo-2-fb37e25951afd32789f705ebc7fdc056aaf835db.tar.bz2
gentoo-2-fb37e25951afd32789f705ebc7fdc056aaf835db.zip
Add patch from Debian to fix permission bug #69693 by Rene Petro.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/winesetuptk/ChangeLog8
-rw-r--r--app-emulation/winesetuptk/files/winesetuptk-0.7-perms.patch14
-rw-r--r--app-emulation/winesetuptk/winesetuptk-0.7.ebuild12
3 files changed, 30 insertions, 4 deletions
diff --git a/app-emulation/winesetuptk/ChangeLog b/app-emulation/winesetuptk/ChangeLog
index 25076d220c46..cb32bf7d8f4a 100644
--- a/app-emulation/winesetuptk/ChangeLog
+++ b/app-emulation/winesetuptk/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/winesetuptk
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/winesetuptk/ChangeLog,v 1.12 2005/01/01 14:20:13 eradicator Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/winesetuptk/ChangeLog,v 1.13 2005/08/16 03:50:48 vapier Exp $
+
+ 16 Aug 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/winesetuptk-0.7-perms.patch, winesetuptk-0.7.ebuild:
+ Add patch from Debian to fix permission bug #69693 by Rene Petro.
*winesetuptk-0.7 (08 Nov 2003)
diff --git a/app-emulation/winesetuptk/files/winesetuptk-0.7-perms.patch b/app-emulation/winesetuptk/files/winesetuptk-0.7-perms.patch
new file mode 100644
index 000000000000..b2e78fd1d887
--- /dev/null
+++ b/app-emulation/winesetuptk/files/winesetuptk-0.7-perms.patch
@@ -0,0 +1,14 @@
+Taken from Debian patchset to fix
+http://bugs.gentoo.org/69693
+
+--- winesetuptk-0.7/tcltk-winesetuptk-0.7/img1.2.4/Makefile.in
++++ winesetuptk-0.7/tcltk-winesetuptk-0.7/img1.2.4/Makefile.in
+@@ -195,7 +195,7 @@
+
+ INSTALL_PROGRAM = $(INSTALL) -m 744
+ INSTALL_DATA = $(INSTALL) -m 644
+-INSTALL_SHLIB = $(INSTALL) -m 555
++INSTALL_SHLIB = $(INSTALL) -m 644
+ RANLIB = @RANLIB@
+ SHLIB_SUFFIX = @SHLIB_SUFFIX@
+
diff --git a/app-emulation/winesetuptk/winesetuptk-0.7.ebuild b/app-emulation/winesetuptk/winesetuptk-0.7.ebuild
index 981d7fa98e49..66dad66a2987 100644
--- a/app-emulation/winesetuptk/winesetuptk-0.7.ebuild
+++ b/app-emulation/winesetuptk/winesetuptk-0.7.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/winesetuptk/winesetuptk-0.7.ebuild,v 1.7 2005/01/01 14:20:14 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/winesetuptk/winesetuptk-0.7.ebuild,v 1.8 2005/08/16 03:50:48 vapier Exp $
+
+inherit eutils
MY_P1=tcltk-${P}
MY_P=${P/-/}
@@ -12,11 +14,17 @@ SRC_URI="mirror://sourceforge/wine/winesetuptk-0.7.tar.gz"
LICENSE="as-is"
SLOT="0"
-KEYWORDS="~x86 ~amd64"
+KEYWORDS="amd64 x86"
IUSE=""
DEPEND="virtual/x11"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-perms.patch
+}
+
src_compile() {
cd ${S}/${MY_P1}
./build.sh