summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-08-31 05:01:16 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-08-31 05:01:16 +0000
commitf01603b93a87a241aa785ccd0fef84fefdb41c78 (patch)
treedcb05cdcc736717009b1adadd2b5ac17362e6641 /app-emulation
parentnasm moved to DEPEND for bug #221451 (diff)
downloadgentoo-2-f01603b93a87a241aa785ccd0fef84fefdb41c78.tar.gz
gentoo-2-f01603b93a87a241aa785ccd0fef84fefdb41c78.tar.bz2
gentoo-2-f01603b93a87a241aa785ccd0fef84fefdb41c78.zip
drop old version; fix DEPEND/RDEPEND split (bugs #221315, #221445, #221579)
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/pearpc/ChangeLog6
-rw-r--r--app-emulation/pearpc/pearpc-0.3.1.ebuild107
-rw-r--r--app-emulation/pearpc/pearpc-0.4.ebuild17
3 files changed, 13 insertions, 117 deletions
diff --git a/app-emulation/pearpc/ChangeLog b/app-emulation/pearpc/ChangeLog
index 78b21202eb7f..2cbc176e5e19 100644
--- a/app-emulation/pearpc/ChangeLog
+++ b/app-emulation/pearpc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/pearpc
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/pearpc/ChangeLog,v 1.20 2008/07/28 18:57:54 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/pearpc/ChangeLog,v 1.21 2008/08/31 05:01:16 mr_bones_ Exp $
+
+ 31 Aug 2008; Michael Sterrett <mr_bones_@gentoo.org> -pearpc-0.3.1.ebuild,
+ pearpc-0.4.ebuild:
+ drop old version; fix DEPEND/RDEPEND split (bugs #221315, #221445, #221579)
28 Jul 2008; Doug Goldstein <cardoe@gentoo.org> metadata.xml:
add GLEP 56 USE flag desc from use.local.desc
diff --git a/app-emulation/pearpc/pearpc-0.3.1.ebuild b/app-emulation/pearpc/pearpc-0.3.1.ebuild
deleted file mode 100644
index 9f0a9e196904..000000000000
--- a/app-emulation/pearpc/pearpc-0.3.1.ebuild
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/pearpc/pearpc-0.3.1.ebuild,v 1.11 2008/06/12 23:16:56 darkside Exp $
-
-inherit flag-o-matic
-
-IUSE="debug jit sdl"
-#IUSE="debug qt gtk jit sdl"
-
-DESCRIPTION="PowerPC Architecture Emulator"
-HOMEPAGE="http://pearpc.sourceforge.net/"
-SRC_URI="mirror://sourceforge/pearpc/${P}.tar.bz2
- http://pearpc.sf.net/createdisk.py"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~ppc ~x86"
-
-DEPEND="x86? ( dev-lang/nasm )
- x11-libs/libXt"
-
-RDEPEND="media-libs/libmng
- media-libs/jpeg
- media-libs/libpng
- sys-libs/zlib
- media-libs/freetype
- sdl? ( media-libs/libsdl )"
-# gtk? ( >=x11-libs/gtk-2.0 )
-# qt? ( >=x11-libs/qt-3.1.1 )"
-
-DEFAULT_TO_X11=0
-
-pkg_setup() {
-
- append-ldflags -Wl,-z,now
-
-# if (use qt && use sdl) || (use qt && use gtk) || (use gtk && sdl) || (use gtk && use qt && use sdl); then
-# ewarn
-# ewarn "More than one frontend USE flags enabled, defaulting to X11 support."
-# ewarn
-# DEFAULT_TO_X11=1
-# fi
-}
-
-src_compile() {
- local myconf
- myconf="--enable-release"
-
- use jit && myconf="${myconf} --enable-cpu=jitc_x86"
-
- if use debug; then
- myconf="${myconf} --enable-debug"
- else
- myconf="${myconf} --disable-debug"
- fi
-
- if [ $DEFAULT_TO_X11 = 1 ]; then
- myconf="${myconf} --enable-ui=x11"
- else
- if use sdl; then
- myconf="${myconf} --enable-ui=sdl"
-# elif use qt; then
-# myconf="${myconf} --enable-ui=qt"
-# elif use gtk; then
-# myconf="${myconf} --enable-ui=gtk"
- else
- myconf="${myconf} --enable-ui=x11"
- fi
- fi
-
- econf ${myconf} || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- dobin src/ppc
- dodoc ChangeLog AUTHORS README TODO
-
- dodir /usr/share/${P}
- insinto /usr/share/${P}
- doins scripts/ifppc_down scripts/ifppc_up scripts/ifppc_up.setuid scripts/ifppc_down.setuid
- doins video.x
- fperms u+s /usr/share/${P}/ifppc_up.setuid /usr/share/${P}/ifppc_down.setuid
-
- insinto /usr/share/doc/${P}
- sed -i -e "s:video.x:/usr/share/${P}/video.x:g" ppccfg.example
- doins ppccfg.example
-
- dodir /usr/share/${P}/scripts
- insinto /usr/share/${P}/scripts
- doins "${DISTDIR}"/createdisk.py
-}
-
-pkg_postinst() {
- echo
- elog "You will need to update your configuration files to point"
- elog "to the new location of video.x, which is now"
- elog "/usr/share/${P}/video.x"
- echo
- elog "To create disk images for PearPC, you can use the Python"
- elog "script located at: /usr/share/${P}/scripts/createdisk.py"
- elog "Usage: createdisk.py <image name> <image size>"
- echo
- elog "Also, be sure to check /usr/share/doc/${P}/ppccfg.example"
- elog "for new configuration options."
- echo
-}
diff --git a/app-emulation/pearpc/pearpc-0.4.ebuild b/app-emulation/pearpc/pearpc-0.4.ebuild
index bff58cedb24f..7af6fdd49e34 100644
--- a/app-emulation/pearpc/pearpc-0.4.ebuild
+++ b/app-emulation/pearpc/pearpc-0.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/pearpc/pearpc-0.4.ebuild,v 1.8 2008/06/12 22:57:15 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/pearpc/pearpc-0.4.ebuild,v 1.9 2008/08/31 05:01:16 mr_bones_ Exp $
inherit eutils flag-o-matic linux-info linux-mod
@@ -14,17 +14,16 @@ SLOT="0"
KEYWORDS="-amd64 ~x86"
IUSE="debug jit X sdl"
-DEPEND="virtual/libc
- sys-devel/flex
- sys-devel/bison
- x86? ( dev-lang/nasm )
- jit? ( dev-lang/nasm )
+RDEPEND="sys-apps/net-tools
+ sdl? ( >=media-libs/libsdl-1.2.0 )
X? ( x11-libs/libX11 )
- sdl? ( >=media-libs/libsdl-1.2.0 )"
-RDEPEND="${DEPEND}
- sys-apps/net-tools
net-firewall/iptables
net-misc/bridge-utils"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ sys-devel/bison
+ x86? ( dev-lang/nasm )
+ jit? ( dev-lang/nasm )"
src_unpack() {
unpack ${A}