summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2004-07-10 18:25:48 +0000
committerLuca Barbato <lu_zero@gentoo.org>2004-07-10 18:25:48 +0000
commitaea89dcf5c89ee1bc37f203d6fd948a4bfe11677 (patch)
tree98fe4f3008178f04ac7266522f96a9ccea17a3c9 /app-emulation
parentRevision bump to fix bad header file. Closes bug #55767. (Manifest recommit) (diff)
downloadgentoo-2-aea89dcf5c89ee1bc37f203d6fd948a4bfe11677.tar.gz
gentoo-2-aea89dcf5c89ee1bc37f203d6fd948a4bfe11677.tar.bz2
gentoo-2-aea89dcf5c89ee1bc37f203d6fd948a4bfe11677.zip
gtk -> wxwindows
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/bochs/ChangeLog5
-rw-r--r--app-emulation/bochs/bochs-2.1.1.ebuild9
2 files changed, 9 insertions, 5 deletions
diff --git a/app-emulation/bochs/ChangeLog b/app-emulation/bochs/ChangeLog
index 0e49f1f00b05..3bcaabbd4cfd 100644
--- a/app-emulation/bochs/ChangeLog
+++ b/app-emulation/bochs/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-emulation/bochs
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/ChangeLog,v 1.26 2004/06/24 22:30:15 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/ChangeLog,v 1.27 2004/07/10 18:25:48 lu_zero Exp $
+
+ 10 Jul 2004; Luca Barbato <lu_zero@gentoo.org> bochs-2.1.1.ebuild:
+ Change gtk useflag to wxwindows useflag
04 May 2004; Bryan Østergaard <kloeri@gentoo.org> bochs-1.4.1.ebuild,
bochs-2.0.ebuild, bochs-2.1.1.ebuild:
diff --git a/app-emulation/bochs/bochs-2.1.1.ebuild b/app-emulation/bochs/bochs-2.1.1.ebuild
index b06ccd8f1f13..f9050906772c 100644
--- a/app-emulation/bochs/bochs-2.1.1.ebuild
+++ b/app-emulation/bochs/bochs-2.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.1.1.ebuild,v 1.7 2004/06/27 23:01:44 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.1.1.ebuild,v 1.8 2004/07/10 18:25:48 lu_zero Exp $
inherit eutils
@@ -12,13 +12,13 @@ SRC_URI="mirror://sourceforge/bochs/${P}.tar.gz
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~x86 ~ppc alpha ~sparc ~amd64"
-IUSE="sdl gtk readline"
+IUSE="sdl wxwindows readline"
DEPEND="virtual/libc
virtual/x11
>=sys-apps/sed-4
sdl? ( media-libs/libsdl )
- gtk? ( x11-libs/wxGTK )
+ wxwindows? ( x11-libs/wxGTK )
readline? sys-libs/readline"
src_unpack() {
@@ -38,7 +38,8 @@ src_compile() {
[ "$ARCH" == "x86" ] \
&& myconf="--enable-idle-hack --enable-fast-function-calls"
myconf="${myconf} `use_with sdl`"
- myconf="${myconf} `use_with gtk wx`"
+ use wxwindows && myconf="${myconf} --with-gtk --with-wx"
+ use wxwindows || myconf="${myconf} --without-gtk --without-wx"
myconf="${myconf} `use_enable readline`"
./configure \