summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-03-03 02:24:17 +0000
committerMike Frysinger <vapier@gentoo.org>2003-03-03 02:24:17 +0000
commit9fb5a04b48146f89284ca51fed1a2c3fab0c6cf5 (patch)
tree64600a460c8308d2bf66503e867da8a5f8a5c896 /app-emulation
parentkeep information current (diff)
downloadgentoo-2-9fb5a04b48146f89284ca51fed1a2c3fab0c6cf5.tar.gz
gentoo-2-9fb5a04b48146f89284ca51fed1a2c3fab0c6cf5.tar.bz2
gentoo-2-9fb5a04b48146f89284ca51fed1a2c3fab0c6cf5.zip
initial ebuild #11781
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/goosnes/ChangeLog8
-rw-r--r--app-emulation/goosnes/files/digest-goosnes-0.5.21
-rw-r--r--app-emulation/goosnes/goosnes-0.5.2.ebuild31
3 files changed, 40 insertions, 0 deletions
diff --git a/app-emulation/goosnes/ChangeLog b/app-emulation/goosnes/ChangeLog
new file mode 100644
index 000000000000..60db17eef23c
--- /dev/null
+++ b/app-emulation/goosnes/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for app-emulation/goosnes
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/goosnes/ChangeLog,v 1.1 2003/03/03 02:24:17 vapier Exp $
+
+*goosnes-0.5.2 (02 Mar 2003)
+
+ 02 Mar 2003; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by brian wood <doowirb7@cox.net> #11781.
diff --git a/app-emulation/goosnes/files/digest-goosnes-0.5.2 b/app-emulation/goosnes/files/digest-goosnes-0.5.2
new file mode 100644
index 000000000000..d68220bc55e7
--- /dev/null
+++ b/app-emulation/goosnes/files/digest-goosnes-0.5.2
@@ -0,0 +1 @@
+MD5 032cb84df865f4b9e76973f8c0195804 goosnes_0.5.2-1.tar.gz 100685
diff --git a/app-emulation/goosnes/goosnes-0.5.2.ebuild b/app-emulation/goosnes/goosnes-0.5.2.ebuild
new file mode 100644
index 000000000000..975d9d1c1002
--- /dev/null
+++ b/app-emulation/goosnes/goosnes-0.5.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/goosnes/goosnes-0.5.2.ebuild,v 1.1 2003/03/03 02:24:17 vapier Exp $
+
+DESCRIPTION="A GTK+ frontend for Snes9X"
+SRC_URI="http://bard.sytes.net/debian/dists/unstable/main/source/${PN}_${PV}-1.tar.gz"
+HOMEPAGE="http://bard.sytes.net/goosnes/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+IUSE="gtk2"
+
+DEPEND="|| (
+ gtk2? ( =x11-libs/gtk+-2* )
+ =x11-libs/gtk+-1*
+ )
+ dev-util/pkgconfig
+ dev-libs/libxml2"
+RDEPEND="app-emulation/snes9x"
+
+src_compile() {
+ use gtk2 && myconf="--with-gtk-version=2.0"
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog README
+}