summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-01-13 01:12:06 +0000
committerMike Frysinger <vapier@gentoo.org>2005-01-13 01:12:06 +0000
commit76ba5fff58b3e5d0bc8e58be4abe4328fdb10ce5 (patch)
treee6d37048977c0bf73167b4bd45ee0088ad134d00 /app-emulation
parentFixed local variable declaration (diff)
downloadgentoo-2-76ba5fff58b3e5d0bc8e58be4abe4328fdb10ce5.tar.gz
gentoo-2-76ba5fff58b3e5d0bc8e58be4abe4328fdb10ce5.tar.bz2
gentoo-2-76ba5fff58b3e5d0bc8e58be4abe4328fdb10ce5.zip
Version bump #77655 by Dennis Schridde.
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine/ChangeLog7
-rw-r--r--app-emulation/wine/files/digest-wine-200501111
-rw-r--r--app-emulation/wine/wine-20050111.ebuild107
3 files changed, 114 insertions, 1 deletions
diff --git a/app-emulation/wine/ChangeLog b/app-emulation/wine/ChangeLog
index fb87441da697..0f8ec40e3045 100644
--- a/app-emulation/wine/ChangeLog
+++ b/app-emulation/wine/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/wine
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.85 2005/01/01 14:19:55 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.86 2005/01/13 01:12:06 vapier Exp $
+
+*wine-20050111 (12 Jan 2005)
+
+ 12 Jan 2005; Mike Frysinger <vapier@gentoo.org> +wine-20050111.ebuild:
+ Version bump #77655 by Dennis Schridde.
*wine-20041201 (02 Dec 2004)
diff --git a/app-emulation/wine/files/digest-wine-20050111 b/app-emulation/wine/files/digest-wine-20050111
new file mode 100644
index 000000000000..c061286bb658
--- /dev/null
+++ b/app-emulation/wine/files/digest-wine-20050111
@@ -0,0 +1 @@
+MD5 33f80e2c7a228912a3ab28fc163550b3 Wine-20050111.tar.gz 11477802
diff --git a/app-emulation/wine/wine-20050111.ebuild b/app-emulation/wine/wine-20050111.ebuild
new file mode 100644
index 000000000000..8afa2dc92bce
--- /dev/null
+++ b/app-emulation/wine/wine-20050111.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050111.ebuild,v 1.1 2005/01/13 01:12:06 vapier Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="free implementation of Windows(tm) on Unix - CVS snapshot"
+HOMEPAGE="http://www.winehq.com/"
+SRC_URI="mirror://sourceforge/${PN}/Wine-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="-* ~x86"
+IUSE="X alsa arts cups debug nas opengl gif glut jack jpeg oss ncurses doc lcms"
+RESTRICT="maketest" #72375
+
+RDEPEND=">=media-libs/freetype-2.0.0
+ ncurses? ( >=sys-libs/ncurses-5.2 )
+ jack? ( media-sound/jack-audio-connection-kit )
+ X? ( virtual/x11 )
+ arts? ( kde-base/arts )
+ alsa? ( media-libs/alsa-lib )
+ nas? ( media-libs/nas )
+ cups? ( net-print/cups )
+ opengl? ( virtual/opengl )
+ gif? ( media-libs/libungif )
+ jpeg? ( media-libs/jpeg )
+ glut? ( virtual/glut )
+ lcms? ( media-libs/lcms )"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4
+ sys-devel/bison
+ sys-devel/gcc
+ doc? ( app-text/docbook-sgml-utils app-text/jadetex )
+ sys-devel/flex"
+
+src_unpack() {
+ unpack Wine-${PV}.tar.gz
+ cd "${S}"
+
+ epatch "${FILESDIR}"/winearts-kdecvs-fix.patch
+ sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
+
+ test_flag -fstack-protector && epatch "${FILESDIR}"/20041019-no-stack.patch #66002
+}
+
+config_cache() {
+ local h ans="no"
+ use ${1} && ans="yes"
+ shift
+ for h in "$@" ; do
+ export ac_cv_${h}=${ans}
+ done
+}
+
+src_compile() {
+ export LDCONFIG=/bin/true
+ config_cache jack header_jack_jack_h
+ config_cache cups header_cups_cups_h
+ config_cache alsa header_alsa_asoundlib_h header_sys_asoundlib_h lib_asound_snd_pcm_open
+ use arts || export ARTSCCONFIG="/bin/false"
+ config_cache nas header_audio_audiolib_h header_audio_soundlib_h
+ config_cache gif header_gif_lib_h
+ config_cache glut lib_glut_glutMainLoop
+ config_cache jpeg header_jpeglib_h
+ config_cache oss header_sys_soundcard_h header_machine_soundcard_h header_soundcard_h
+ config_cache lcms header_lcms_h
+
+ strip-flags
+ use lcms && append-flags -I${ROOT}/usr/include/lcms
+
+ # $(use_enable amd64 win64)
+ # USE=debug is broken in this release
+ econf \
+ --sysconfdir=/etc/wine \
+ $(use_with ncurses curses) \
+ $(use_with opengl) \
+ $(use_with X x) \
+ $(use_enable debug trace) \
+ $(use_enable debug) \
+ || die "configure failed"
+
+ emake -j1 depend || die "depend"
+ emake all || die "all"
+ if use doc ; then
+ emake -j1 -C documentation doc || die "docs"
+ fi
+}
+
+src_install() {
+ make \
+ prefix="${D}"/usr \
+ bindir="${D}"/usr/bin \
+ datadir="${D}"/usr/share \
+ includedir="${D}"/usr/include/wine \
+ sysconfdir="${D}"/etc/wine \
+ mandir="${D}"/usr/share/man \
+ libdir="${D}"/usr/lib \
+ dlldir="${D}"/usr/lib/wine \
+ install || die
+ use doc && dodoc documentation/*.pdf
+
+ insinto /usr/share/wine
+ doins documentation/samples/config || die "doins config"
+
+ dodoc ANNOUNCE AUTHORS BUGS ChangeLog DEVELOPERS-HINTS README
+}