summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg Kroah-Hartman <gregkh@gentoo.org>2013-10-31 20:47:50 +0000
committerGreg Kroah-Hartman <gregkh@gentoo.org>2013-10-31 20:47:50 +0000
commit4375fe120e4c35197753296c48e892f160c937b0 (patch)
treedbbfe04edf57311cc32eb51c139504841274e5f1 /app-emulation
parentRevbump to pick up init script change. (diff)
downloadgentoo-2-4375fe120e4c35197753296c48e892f160c937b0.tar.gz
gentoo-2-4375fe120e4c35197753296c48e892f160c937b0.tar.bz2
gentoo-2-4375fe120e4c35197753296c48e892f160c937b0.zip
version bump to 0.6.5
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/docker/ChangeLog7
-rw-r--r--app-emulation/docker/docker-0.6.5.ebuild151
2 files changed, 157 insertions, 1 deletions
diff --git a/app-emulation/docker/ChangeLog b/app-emulation/docker/ChangeLog
index 61945e6c0b26..155c71d7d131 100644
--- a/app-emulation/docker/ChangeLog
+++ b/app-emulation/docker/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/docker
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/docker/ChangeLog,v 1.2 2013/10/05 17:41:13 gregkh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/docker/ChangeLog,v 1.3 2013/10/31 20:47:50 gregkh Exp $
+
+*docker-0.6.5 (31 Oct 2013)
+
+ 31 Oct 2013; Greg Kroah-Hartman <gregkh@gentoo.org> +docker-0.6.5.ebuild:
+ version bump to 0.6.5
*docker-0.6.3-r1 (05 Oct 2013)
diff --git a/app-emulation/docker/docker-0.6.5.ebuild b/app-emulation/docker/docker-0.6.5.ebuild
new file mode 100644
index 000000000000..5dbe6f2614e4
--- /dev/null
+++ b/app-emulation/docker/docker-0.6.5.ebuild
@@ -0,0 +1,151 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/docker/docker-0.6.5.ebuild,v 1.1 2013/10/31 20:47:50 gregkh Exp $
+
+EAPI=5
+
+DESCRIPTION="Docker complements LXC with a high-level API which operates at the process level."
+HOMEPAGE="http://www.docker.io/"
+SRC_URI=""
+
+EGIT_REPO_URI="git://github.com/dotcloud/docker.git"
+if [[ ${PV} == *9999 ]]; then
+ KEYWORDS=""
+else
+ EGIT_COMMIT="v${PV}"
+ KEYWORDS="~amd64"
+fi
+
+inherit bash-completion-r1 git-2 linux-info systemd user
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="doc vim-syntax"
+
+CDEPEND="
+ >=dev-db/sqlite-3.7.9:3
+"
+DEPEND="
+ ${CDEPEND}
+ >=dev-lang/go-1.1.2
+ dev-vcs/git
+ dev-vcs/mercurial
+ doc? (
+ dev-python/sphinx
+ dev-python/sphinxcontrib-httpdomain
+ )
+"
+RDEPEND="
+ ${CDEPEND}
+ !app-emulation/lxc-docker-bin
+ >=app-arch/tar-1.26
+ >=sys-apps/iproute2-3.5
+ >=net-firewall/iptables-1.4
+ >=app-emulation/lxc-0.8
+ >=dev-vcs/git-1.7
+ >=app-arch/xz-utils-4.9
+ || (
+ sys-fs/aufs3
+ sys-kernel/aufs-sources
+ )
+"
+
+RESTRICT="strip"
+
+CONFIG_CHECK="
+ ~AUFS_FS
+ ~BRIDGE
+ ~MEMCG_SWAP
+ ~NETFILTER_XT_MATCH_ADDRTYPE
+ ~NF_NAT
+ ~NF_NAT_NEEDED
+"
+
+# TODO AUFS will be replaced with device-mapper (requires sys-fs/lvm2[thin]) in 0.7
+ERROR_AUFS_FS="AUFS_FS is required to be set if and only if aufs-sources are used"
+
+ERROR_MEMCG_SWAP="MEMCG_SWAP is required if you wish to limit swap usage of containers"
+
+pkg_setup() {
+ check_extra_config
+}
+
+src_unpack() {
+ git-2_src_unpack
+}
+
+src_compile() {
+ export GOPATH="${WORKDIR}/gopath"
+ mkdir -p "$GOPATH" || die
+
+ # make sure docker itself is in our shiny new GOPATH
+ mkdir -p "${GOPATH}/src/github.com/dotcloud" || die
+ ln -sf "$(pwd -P)" "${GOPATH}/src/github.com/dotcloud/docker" || die
+
+ # we need our vendored deps, too
+ export GOPATH="$GOPATH:$(pwd -P)/vendor"
+
+ # time to build!
+ ./hack/make.sh dynbinary || die
+
+ if use doc; then
+ emake -C docs docs || die
+ fi
+}
+
+src_install() {
+ VERSION=$(cat VERSION)
+ newbin bundles/$VERSION/dynbinary/docker-$VERSION docker
+ exeinto /usr/libexec/docker
+ newexe bundles/$VERSION/dynbinary/dockerinit-$VERSION dockerinit
+
+ newinitd contrib/init/openrc/docker.initd docker
+ newconfd contrib/init/openrc/docker.confd docker
+
+ systemd_dounit contrib/init/systemd/docker.service
+
+ dodoc AUTHORS CONTRIBUTING.md CHANGELOG.md NOTICE README.md
+ if use doc; then
+ dohtml -r docs/_build/html/*
+ fi
+
+ dobashcomp contrib/completion/bash/*
+
+ insinto /usr/share/zsh/site-functions
+ doins contrib/completion/zsh/*
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles
+ doins -r contrib/vim-syntax/ftdetect
+ doins -r contrib/vim-syntax/syntax
+ fi
+
+ insinto /usr/share/${P}/contrib
+ doins contrib/README
+ cp -R "${S}/contrib"/* "${D}/usr/share/${P}/contrib/"
+}
+
+pkg_postinst() {
+ elog ""
+ elog "To use docker, the docker daemon must be running as root. To automatically"
+ elog "start the docker daemon at boot, add docker to the default runlevel:"
+ elog " rc-update add docker default"
+ elog "Similarly for systemd:"
+ elog " systemctl enable docker.service"
+ elog ""
+
+ # create docker group if the code checking for it in /etc/group exists
+ enewgroup docker
+
+ elog "To use docker as a non-root user, add yourself to the docker group."
+ elog ""
+
+ ewarn ""
+ ewarn "If you want your containers to have access to the public internet or even"
+ ewarn "the existing private network, IP Forwarding must be enabled:"
+ ewarn " sysctl -w net.ipv4.ip_forward=1"
+ ewarn "or more permanently:"
+ ewarn " echo net.ipv4.ip_forward = 1 > /etc/sysctl.d/${PN}.conf"
+ ewarn "Please be mindful of the security implications of enabling IP Forwarding."
+ ewarn ""
+}