summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-06-15 03:19:49 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-06-15 03:19:49 +0000
commit2d65b6a060ecf0dabe31c6bc049a8c71098d289d (patch)
tree5f19e385d1714fe2e9bd57ef3423cc7d85be6186 /app-emulation
parentInitial version. (Manifest recommit) (diff)
downloadgentoo-2-2d65b6a060ecf0dabe31c6bc049a8c71098d289d.tar.gz
gentoo-2-2d65b6a060ecf0dabe31c6bc049a8c71098d289d.tar.bz2
gentoo-2-2d65b6a060ecf0dabe31c6bc049a8c71098d289d.zip
tidy
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/uade/uade-0.81.ebuild21
1 files changed, 10 insertions, 11 deletions
diff --git a/app-emulation/uade/uade-0.81.ebuild b/app-emulation/uade/uade-0.81.ebuild
index 78b5606be4ae..8de89fc75326 100644
--- a/app-emulation/uade/uade-0.81.ebuild
+++ b/app-emulation/uade/uade-0.81.ebuild
@@ -1,14 +1,15 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/uade/uade-0.81.ebuild,v 1.5 2004/06/08 20:00:48 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uade/uade-0.81.ebuild,v 1.6 2004/06/15 03:19:49 mr_bones_ Exp $
DESCRIPTION="Unix Amiga Delitracker Emulator - plays old Amiga tunes through UAE emulation and cloned m68k-assembler Eagleplayer API"
HOMEPAGE="http://uade.ton.tut.fi/"
SRC_URI="http://uade.ton.tut.fi/uade/${P}.tar.bz2"
LICENSE="GPL-2"
-KEYWORDS="x86 ~ppc"
SLOT="0"
+KEYWORDS="x86 ~ppc"
+IUSE="xmms sdl"
RDEPEND="dev-lang/perl
xmms? ( >=media-sound/xmms-1.2.2 x11-libs/gtk+ )
@@ -16,15 +17,13 @@ RDEPEND="dev-lang/perl
DEPEND="${RDEPEND}
>=sys-apps/sed-4"
-IUSE="xmms sdl"
-
src_unpack() {
unpack ${A}
cd ${S}
sed -i \
- -e 's:\$prefix/doc:/usr/share/doc:' configure || \
- die 'sed configure failed'
+ -e 's:\$prefix/doc:/usr/share/doc:' configure \
+ || die 'sed configure failed'
}
src_compile() {
@@ -39,19 +38,19 @@ src_compile() {
}
src_install() {
- make DESTDIR=${D} install || die 'make install failed'
+ make DESTDIR="${D}" install || die 'make install failed'
# make install doesn't put anything in this directory
# I assume it's necessary to have it around so use keepdir to make is so.
keepdir /usr/share/uade/players/S
- dodoc BUGS ChangeLog.txt FIXED || die 'dodoc failed'
- find "${D}/usr/share/doc/${P}/" \
+ dodoc BUGS ChangeLog.txt FIXED
+ find "${D}/usr/share/doc/${PF}/" \
\( -name '*.readme' -o \
-name '*.txt' -o \
-name 'INSTALL*' -o \
-name 'README*' -o \
-name 'Change*' \) -exec gzip -9 \{\} \;
- dohtml ${D}/usr/share/doc/${P}/{*.html,*.png} || die 'dohtml failed'
- rm -f ${D}/usr/share/doc/${P}/{COPYING*,*.html,*.png}
+ dohtml "${D}/usr/share/doc/${PF}/"{*.html,*.png} || die 'dohtml failed'
+ rm -f "${D}/usr/share/doc/${PF}/"{COPYING*,*.html,*.png}
}