summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2006-05-07 20:28:32 +0000
committerLuca Barbato <lu_zero@gentoo.org>2006-05-07 20:28:32 +0000
commit2a2d4dcb56fbcae8d1bb64672fbaf67a933cd59f (patch)
treea4598ab1ab3b55ce7bae259dd16f2765d5671151 /app-emulation
parentStable on ppc64 (diff)
downloadgentoo-2-2a2d4dcb56fbcae8d1bb64672fbaf67a933cd59f.tar.gz
gentoo-2-2a2d4dcb56fbcae8d1bb64672fbaf67a933cd59f.tar.bz2
gentoo-2-2a2d4dcb56fbcae8d1bb64672fbaf67a933cd59f.zip
New version
(Portage version: 2.1_pre10-r2)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/kqemu/ChangeLog5
-rw-r--r--app-emulation/kqemu/files/digest-kqemu-1.3.0_pre73
-rw-r--r--app-emulation/kqemu/kqemu-1.3.0_pre7.ebuild73
3 files changed, 80 insertions, 1 deletions
diff --git a/app-emulation/kqemu/ChangeLog b/app-emulation/kqemu/ChangeLog
index d360b5f83593..db2d9bef5921 100644
--- a/app-emulation/kqemu/ChangeLog
+++ b/app-emulation/kqemu/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-emulation/kqemu
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/kqemu/ChangeLog,v 1.9 2006/04/27 12:32:12 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/kqemu/ChangeLog,v 1.10 2006/05/07 20:28:32 lu_zero Exp $
+
+ 07 May 2006; Luca Barbato <lu_zero@gentoo.org> ChangeLog:
+ New version
27 Apr 2006; Marien Zwart <marienz@gentoo.org> files/digest-kqemu-0.7.2,
files/digest-kqemu-1.3.0_pre5, Manifest:
diff --git a/app-emulation/kqemu/files/digest-kqemu-1.3.0_pre7 b/app-emulation/kqemu/files/digest-kqemu-1.3.0_pre7
new file mode 100644
index 000000000000..0b6f14160ef5
--- /dev/null
+++ b/app-emulation/kqemu/files/digest-kqemu-1.3.0_pre7
@@ -0,0 +1,3 @@
+MD5 3b77edbada790f924456aa4675edd0be kqemu-1.3.0pre7.tar.gz 189920
+RMD160 9f8e5dd7e1a901d939fc5e8b3be1a10e396f9ab3 kqemu-1.3.0pre7.tar.gz 189920
+SHA256 cf29505b3d07d5e31080aa677a4254f5770f273e9bd05ef2df956b87d248cead kqemu-1.3.0pre7.tar.gz 189920
diff --git a/app-emulation/kqemu/kqemu-1.3.0_pre7.ebuild b/app-emulation/kqemu/kqemu-1.3.0_pre7.ebuild
new file mode 100644
index 000000000000..c23e3091ed31
--- /dev/null
+++ b/app-emulation/kqemu/kqemu-1.3.0_pre7.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/kqemu/kqemu-1.3.0_pre7.ebuild,v 1.1 2006/05/07 20:28:32 lu_zero Exp $
+
+inherit eutils flag-o-matic linux-mod toolchain-funcs
+
+MY_PV=${PV/_/}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Multi-platform & multi-targets cpu emulator and dynamic translator kernel fast execution module"
+HOMEPAGE="http://fabrice.bellard.free.fr/qemu/"
+SRC_URI="http://fabrice.bellard.free.fr/qemu/${MY_P}.tar.gz"
+
+LICENSE="KQEMU"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="nostrip"
+IUSE=""
+
+S="${WORKDIR}/$MY_P"
+
+DEPEND=""
+
+pkg_setup() {
+ MODULE_NAMES="kqemu(misc:${S})"
+ linux-mod_pkg_setup
+
+ einfo "kqemu is binary module with a restricted license."
+ einfo "Please read carefully the KQEMU license"
+ einfo "and ${HOMEPAGE}qemu-accel.html"
+ einfo "if you would like to see it released under the GPL"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+src_compile() {
+ #Let the application set its cflags
+ unset CFLAGS
+
+ # Switch off hardened tech
+ filter-flags -fpie -fstack-protector
+
+ ./configure --kernel-path="${KV_DIR}" \
+ || die "could not configure"
+
+ make
+}
+
+src_install() {
+ linux-mod_src_install
+
+ # udev rule
+ dodir /etc/udev/rules.d/
+ echo 'KERNEL="kqemu*", NAME="%k", GROUP="qemu", MODE="0660"' > ${D}/etc/udev/rules.d/48-qemu.rules
+
+ # Module doc
+ dodoc ${S}/README
+ dohtml ${S}/kqemu-doc.html
+
+ # module params
+ dodir /etc/modules.d
+ echo "options kqemu major=0" > ${D}/etc/modules.d/kqemu
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+ enewgroup qemu
+ einfo "Make sure you have the kernel module loaded before running qemu"
+ einfo "and your user is in the qemu group"
+}