summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2004-01-13 02:50:58 +0000
committerLuca Barbato <lu_zero@gentoo.org>2004-01-13 02:50:58 +0000
commit082720d18864ea9b094c311cfbf104e6e08099b5 (patch)
tree375ef7b92fb1d39f9f8794b0ebbeccf93457f1a9 /app-emulation
parentversion bump (bug 38022) (diff)
downloadgentoo-2-082720d18864ea9b094c311cfbf104e6e08099b5.tar.gz
gentoo-2-082720d18864ea9b094c311cfbf104e6e08099b5.tar.bz2
gentoo-2-082720d18864ea9b094c311cfbf104e6e08099b5.zip
~arch
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/bochs/ChangeLog7
-rw-r--r--app-emulation/bochs/bochs-2.1.ebuild71
-rw-r--r--app-emulation/bochs/files/digest-bochs-2.12
3 files changed, 79 insertions, 1 deletions
diff --git a/app-emulation/bochs/ChangeLog b/app-emulation/bochs/ChangeLog
index 6e9af3afe430..81074b60a969 100644
--- a/app-emulation/bochs/ChangeLog
+++ b/app-emulation/bochs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/bochs
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/ChangeLog,v 1.19 2004/01/10 14:56:58 bazik Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/ChangeLog,v 1.20 2004/01/13 02:50:57 lu_zero Exp $
+
+*bochs-2.1 (13 Jan 2004)
+
+ 13 Jan 2004; Luca Barbato <lu_zero@gentoo.org> bochs-2.1.ebuild:
+ New version
10 Jan 2004; Sven Blumenstein <bazik@gentoo.org> bochs-2.0.2.ebuild:
Stable on sparc. Hey, I saw Win2K booting on my Sun Ultra5!
diff --git a/app-emulation/bochs/bochs-2.1.ebuild b/app-emulation/bochs/bochs-2.1.ebuild
new file mode 100644
index 000000000000..3c955b69b9a5
--- /dev/null
+++ b/app-emulation/bochs/bochs-2.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.1.ebuild,v 1.1 2004/01/13 02:50:58 lu_zero Exp $
+
+inherit eutils
+
+DESCRIPTION="a LGPL-ed pc emulator"
+HOMEPAGE="http://bochs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/bochs/${P}.tar.gz
+ http://bochs.sourceforge.net/guestos/dlxlinux4.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc"
+IUSE="sdl gtk readline"
+
+DEPEND=">=sys-libs/glibc-2.1.3
+ >=x11-base/xfree-4.0.1
+ >=sys-apps/sed-4
+ sdl? media-libs/libsdl
+ gtk? x11-libs/wxGTK
+ readline? sys-libs/readline"
+
+src_unpack() {
+# unpack ${A}
+ unpack ${P}.tar.gz
+ cd ${S}
+# -e 's:MAN_PAGE_1_LIST=bochs bximage bochs-dlx:MAN_PAGE_1_LIST=bochs bximage:'
+ sed -i \
+ -e "s:\$(WGET) \$(DLXLINUX_TAR_URL):cp ${DISTDIR}/dlxlinux4.tar.gz .:" \
+ -e 's:BOCHSDIR=:BOCHSDIR=/usr/lib/bochs#:' \
+ -e 's: $(BOCHSDIR): $(DESTDIR)$(BOCHSDIR):g' Makefile.in || \
+ die "sed Makefile.in failed"
+# epatch ${FILESDIR}/${P}-gcc3.patch || die
+}
+
+src_compile() {
+ [ "$ARCH" == "x86" ] \
+ && myconf="--enable-idle-hack --enable-fast-function-calls"
+ myconf="${myconf} `use_with sdl`"
+ myconf="${myconf} `use_with gtk wx`"
+ myconf="${myconf} `use_enable readline`"
+
+ ./configure \
+ --enable-fpu --enable-cdrom --enable-control-panel \
+ --enable-usb --enable-pci --enable-mmx --enable-sse\
+ --enable-cpu-level=6 \
+ --enable-repeat-speedups --enable-guest2host-tlb \
+ --enable-plugins --enable-debugger \
+ --enable-ne2000 --enable-sb16=linux --enable-slowdown --prefix=/usr \
+ --infodir=/usr/share/info --mandir=/usr/share/man --host=${CHOST} \
+ --with-x11 $myconf || \
+ die "configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install unpack_dlx || die "make install failed"
+ #workaround
+ make prefix=${D}/usr install_dlx
+
+ dodoc CHANGES README TESTFORM.txt || die "dodoc failed"
+}
+
+pkg_postinst() {
+ einfo "Updating the font index"
+ mkfontdir /usr/X11R6/lib/X11/fonts/misc
+ einfo "If you are running X please update the fontlist with:"
+ einfo "# xset fp rehash"
+}
diff --git a/app-emulation/bochs/files/digest-bochs-2.1 b/app-emulation/bochs/files/digest-bochs-2.1
new file mode 100644
index 000000000000..60a7c594a75a
--- /dev/null
+++ b/app-emulation/bochs/files/digest-bochs-2.1
@@ -0,0 +1,2 @@
+MD5 30bdb17e11fb416f9d3c6243e02f6e73 bochs-2.1.tar.gz 3650627
+MD5 21c153f5aa391395c35f0c2f660da972 dlxlinux4.tar.gz 1504868