summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Marineau <marineam@gentoo.org>2007-10-15 18:33:41 +0000
committerMichael Marineau <marineam@gentoo.org>2007-10-15 18:33:41 +0000
commit95770c620405b5a695bbaca6288165a01b781b1b (patch)
tree4f7fa20e55ab77fc4c24600da01fa377a959c730 /app-emulation/xen
parentAdding java-virtuals metadata.xml, missed this on inital create. (diff)
downloadgentoo-2-95770c620405b5a695bbaca6288165a01b781b1b.tar.gz
gentoo-2-95770c620405b5a695bbaca6288165a01b781b1b.tar.bz2
gentoo-2-95770c620405b5a695bbaca6288165a01b781b1b.zip
Bump xen to version 3.1.1
(Portage version: 2.1.3.9)
Diffstat (limited to 'app-emulation/xen')
-rw-r--r--app-emulation/xen/ChangeLog7
-rw-r--r--app-emulation/xen/files/digest-xen-3.1.13
-rw-r--r--app-emulation/xen/xen-3.1.1.ebuild95
3 files changed, 104 insertions, 1 deletions
diff --git a/app-emulation/xen/ChangeLog b/app-emulation/xen/ChangeLog
index afd8cfe69418..1c6b59937471 100644
--- a/app-emulation/xen/ChangeLog
+++ b/app-emulation/xen/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/xen
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/ChangeLog,v 1.48 2007/08/27 17:19:12 marineam Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/ChangeLog,v 1.49 2007/10/15 18:33:40 marineam Exp $
+
+*xen-3.1.1 (15 Oct 2007)
+
+ 15 Oct 2007; Michael Marineau <marineam@gentoo.org> +xen-3.1.1.ebuild:
+ Version bump.
27 Aug 2007; Michael Marineau <marineam@gentoo.org> xen-3.0.4_p1.ebuild,
xen-3.1.0.ebuild:
diff --git a/app-emulation/xen/files/digest-xen-3.1.1 b/app-emulation/xen/files/digest-xen-3.1.1
new file mode 100644
index 000000000000..e739866b2661
--- /dev/null
+++ b/app-emulation/xen/files/digest-xen-3.1.1
@@ -0,0 +1,3 @@
+MD5 d5bafac9c819206d6a85c11352cc90fd xen-3.1.1.tgz 6868014
+RMD160 23f522a76815a64ba18eaf9eec19f38ea01e8c32 xen-3.1.1.tgz 6868014
+SHA256 c6c986177e75e41e7412920d453b5b759568a90266b09e2fea6043f8890f75e2 xen-3.1.1.tgz 6868014
diff --git a/app-emulation/xen/xen-3.1.1.ebuild b/app-emulation/xen/xen-3.1.1.ebuild
new file mode 100644
index 000000000000..ee4ae38a5603
--- /dev/null
+++ b/app-emulation/xen/xen-3.1.1.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/xen-3.1.1.ebuild,v 1.1 2007/10/15 18:33:40 marineam Exp $
+
+inherit mount-boot flag-o-matic
+
+DESCRIPTION="The Xen virtual machine monitor"
+HOMEPAGE="http://www.xensource.com/xen/xen/"
+#SRC_URI="http://bits.xensource.com/oss-xen/release/${PV}/src.tgz/xen-${PV}-src.tgz"
+#S="${WORKDIR}/xen-${PV}-src"
+
+# Temporary while we wait on the upstream tarball
+SRC_URI="http://dev.gentoo.org/~marineam/files/xen/xen-${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug custom-cflags pae"
+
+RDEPEND="|| ( sys-boot/grub
+ sys-boot/grub-static )
+ >=sys-kernel/xen-sources-2.6.18"
+PDEPEND="~app-emulation/xen-tools-${PV}"
+
+RESTRICT="test"
+
+# Approved by QA team in bug #144032
+QA_WX_LOAD="boot/xen-syms-${PV}"
+
+pkg_setup() {
+ if [[ -z ${XEN_TARGET_ARCH} ]]; then
+ if use x86 && use amd64; then
+ die "Confusion! Both x86 and amd64 are set in your use flags!"
+ elif use x86; then
+ export XEN_TARGET_ARCH="x86_32"
+ elif use amd64; then
+ export XEN_TARGET_ARCH="x86_64"
+ else
+ die "Unsupported architecture!"
+ fi
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ # if the user *really* wants to use their own custom-cflags, let them
+ if use custom-cflags; then
+ einfo "User wants their own CFLAGS - removing defaults"
+ # try and remove all the default custom-cflags
+ find "${S}" -name Makefile -o -name Rules.mk -o -name Config.mk -exec sed \
+ -e 's/CFLAGS\(.*\)=\(.*\)-O3\(.*\)/CFLAGS\1=\2\3/' \
+ -e 's/CFLAGS\(.*\)=\(.*\)-march=i686\(.*\)/CFLAGS\1=\2\3/' \
+ -e 's/CFLAGS\(.*\)=\(.*\)-fomit-frame-pointer\(.*\)/CFLAGS\1=\2\3/' \
+ -e 's/CFLAGS\(.*\)=\(.*\)-g3*\s\(.*\)/CFLAGS\1=\2 \3/' \
+ -e 's/CFLAGS\(.*\)=\(.*\)-O2\(.*\)/CFLAGS\1=\2\3/' \
+ -i {} \;
+ fi
+}
+
+src_compile() {
+ local myopt
+ use debug && myopt="${myopt} debug=y"
+ use pae && myopt="${myopt} pae=y"
+
+ if use custom-cflags; then
+ filter-flags -fPIE -fstack-protector
+ else
+ unset CFLAGS
+ fi
+
+ # Send raw LDFLAGS so that --as-needed works
+ emake LDFLAGS="$(raw-ldflags)" -C xen ${myopt} || die "compile failed"
+}
+
+src_install() {
+ local myopt
+ use debug && myopt="${myopt} debug=y"
+ use pae && myopt="${myopt} pae=y"
+
+ emake LDFLAGS="$(raw-ldflags)" DESTDIR="${D}" -C xen ${myopt} install || die "install failed"
+}
+
+pkg_postinst() {
+ elog "Official Xen Guide and the unoffical wiki page:"
+ elog " http://www.gentoo.org/doc/en/xen-guide.xml"
+ elog " http://gentoo-wiki.com/HOWTO_Xen_and_Gentoo"
+
+ echo
+ elog "Note: xen tools have been moved to app-emulation/xen-tools"
+
+ if use pae; then
+ echo
+ ewarn "This is a PAE build of Xen. It will *only* boot PAE kernels!"
+ fi
+}