summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Bainbridge <chrb@gentoo.org>2006-06-09 17:59:12 +0000
committerChris Bainbridge <chrb@gentoo.org>2006-06-09 17:59:12 +0000
commitd10ac3d715956162c68cf9d36602ff3ec8423d43 (patch)
treeb6951be947352e24623c8c2907db2b6e96603ef4 /app-emulation/xen-tools
parentStable on ppc64; bug #135068 (diff)
downloadgentoo-2-d10ac3d715956162c68cf9d36602ff3ec8423d43.tar.gz
gentoo-2-d10ac3d715956162c68cf9d36602ff3ec8423d43.tar.bz2
gentoo-2-d10ac3d715956162c68cf9d36602ff3ec8423d43.zip
Clean up .pyc files, thanks to Andrew Ross, bug #136159
(Portage version: 2.1_rc4-r4)
Diffstat (limited to 'app-emulation/xen-tools')
-rw-r--r--app-emulation/xen-tools/ChangeLog8
-rw-r--r--app-emulation/xen-tools/files/digest-xen-tools-3.0.2-r13
-rw-r--r--app-emulation/xen-tools/xen-tools-3.0.2-r1.ebuild135
3 files changed, 145 insertions, 1 deletions
diff --git a/app-emulation/xen-tools/ChangeLog b/app-emulation/xen-tools/ChangeLog
index 4bdb29370805..46da61cad293 100644
--- a/app-emulation/xen-tools/ChangeLog
+++ b/app-emulation/xen-tools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/xen-tools
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/ChangeLog,v 1.11 2006/06/02 09:23:34 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/ChangeLog,v 1.12 2006/06/09 17:59:12 chrb Exp $
+
+*xen-tools-3.0.2-r1 (09 Jun 2006)
+
+ 09 Jun 2006; Chris Bainbridge <chrb@gentoo.org> -xen-tools-3.0.2.ebuild,
+ +xen-tools-3.0.2-r1.ebuild:
+ Clean up .pyc files, thanks to Andrew Ross, bug #136159
02 Jun 2006; Roy Marples <uberlord@gentoo.org>
+files/xen-tools-3.0.2--as-needed.patch, -xen-tools-3.0.1.ebuild,
diff --git a/app-emulation/xen-tools/files/digest-xen-tools-3.0.2-r1 b/app-emulation/xen-tools/files/digest-xen-tools-3.0.2-r1
new file mode 100644
index 000000000000..724d092d5489
--- /dev/null
+++ b/app-emulation/xen-tools/files/digest-xen-tools-3.0.2-r1
@@ -0,0 +1,3 @@
+MD5 544eab940a0734a55459d648e5c3b224 xen-3.0.2-src.tgz 4933621
+RMD160 34e4431a981891319f8a5ea0c3f604e7d8d7d7af xen-3.0.2-src.tgz 4933621
+SHA256 f18ffab16a457fa721d11933c75f8288f6958c88c2669857c7c11d5107ba2951 xen-3.0.2-src.tgz 4933621
diff --git a/app-emulation/xen-tools/xen-tools-3.0.2-r1.ebuild b/app-emulation/xen-tools/xen-tools-3.0.2-r1.ebuild
new file mode 100644
index 000000000000..ff29e12dd398
--- /dev/null
+++ b/app-emulation/xen-tools/xen-tools-3.0.2-r1.ebuild
@@ -0,0 +1,135 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/xen-tools-3.0.2-r1.ebuild,v 1.1 2006/06/09 17:59:12 chrb Exp $
+
+inherit mount-boot flag-o-matic distutils eutils
+
+DESCRIPTION="Xend daemon and tools"
+HOMEPAGE="http://xen.sourceforge.net"
+if [[ ${PV} == *_p* ]]; then
+ XEN_UNSTABLE="xen-unstable-${PV#*_p}"
+ SRC_URI="mirror://gentoo/${XEN_UNSTABLE}.tar.bz2"
+ S="${WORKDIR}/${XEN_UNSTABLE}"
+else
+ SRC_URI="http://www.cl.cam.ac.uk/Research/SRG/netos/xen/downloads/xen-${PV}-src.tgz"
+ S="${WORKDIR}/xen-${PV}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc debug screen custom-cflags hardened"
+
+DEPEND="sys-devel/gcc
+ dev-lang/python"
+
+RDEPEND=">=app-emulation/xen-3.0.2
+ dev-lang/python
+ sys-apps/iproute2
+ net-misc/bridge-utils
+ sys-libs/zlib
+ doc? (
+ dev-tex/latex2html
+ media-gfx/transfig
+ )
+ screen? (
+ app-misc/screen
+ app-admin/logrotate
+ )
+ || ( sys-fs/udev sys-apps/hotplug )"
+
+PYTHON_MODNAME="xen grub"
+
+src_unpack() {
+ unpack ${A}
+ # if the user *really* wants to use their own custom-cflags, let them
+ if use custom-cflags; then
+ einfo "User wants their own CFLAGS - removing defaults"
+ # try and remove all the default custom-cflags
+ find "${S}" -name Makefile -o -name Rules.mk -o -name Config.mk -exec sed \
+ -e 's/CFLAGS\(.*\)=\(.*\)-O3\(.*\)/CFLAGS\1=\2\3/' \
+ -e 's/CFLAGS\(.*\)=\(.*\)-march=i686\(.*\)/CFLAGS\1=\2\3/' \
+ -e 's/CFLAGS\(.*\)=\(.*\)-fomit-frame-pointer\(.*\)/CFLAGS\1=\2\3/' \
+ -e 's/CFLAGS\(.*\)=\(.*\)-g3*\s\(.*\)/CFLAGS\1=\2 \3/' \
+ -e 's/CFLAGS\(.*\)=\(.*\)-O2\(.*\)/CFLAGS\1=\2\3/' \
+ -i {} \;
+ fi
+ # for some reason the xen gcc checks don't work on gentoo-hardened
+ if use hardened; then
+ HARDFLAGS="-nopie -fno-stack-protector -fno-stack-protector-all"
+ sed -e "s/CFLAGS :=/CFLAGS := ${HARDFLAGS}/" \
+ -i "${S}"/tools/firmware/hvmloader/Makefile \
+ "${S}"/tools/firmware/vmxassist/Makefile
+ cd "${S}"
+ epatch "${FILESDIR}"/hardened-bx-clobber.patch
+ fi
+
+ # Allow --as-needed LDFLAGS
+ epatch "${FILESDIR}/${P}"--as-needed.patch
+}
+
+src_compile() {
+ local myopt
+ use debug && myopt="${myopt} debug=y"
+
+ use custom-cflags || unset CFLAGS
+
+ emake -C tools ${myopt} || die "compile failed"
+
+ if use doc; then
+ sh ./docs/check_pkgs || die "package check failed"
+ emake -C docs || die "compiling docs failed"
+ fi
+
+ emake -C docs man-pages || die "make man-pages failed"
+}
+
+src_install() {
+ local myopt="XEN_PYTHON_NATIVE_INSTALL=1"
+
+ make DESTDIR=${D} ${myopt} install-tools \
+ || die "install failed"
+
+ if use doc; then
+ make DESTDIR="${D}" -C docs install || die "install docs failed"
+ # Rename doc/xen to the Gentoo-style doc/xen-x.y
+ mv "${D}"/usr/share/doc/{${PN},${PF}}
+ fi
+
+ doman docs/man?/*
+
+ newinitd "${FILESDIR}"/xend-init xend
+ newconfd "${FILESDIR}"/xend-conf xend
+ newconfd "${FILESDIR}"/xendomains-conf xendomains
+ newinitd "${FILESDIR}"/xendomains-init xendomains
+
+ if use screen; then
+ sed -i -e 's/SCREEN="no"/SCREEN="yes"/' "${D}"/etc/init.d/xendomains
+ fi
+
+ # xend expects these to exist
+ keepdir /var/run/xenstored /var/lib/xenstored /var/xen/dump
+
+ # for upstream change tracking
+ if [[ -n ${XEN_UNSTABLE} ]]; then
+ dodoc "${S}"/XEN-VERSION
+ fi
+}
+
+pkg_postinst() {
+ einfo "Please visit the Xen and Gentoo wiki:"
+ einfo "http://gentoo-wiki.com/HOWTO_Xen_and_Gentoo"
+
+ if ! built_with_use dev-lang/python ncurses; then
+ echo
+ ewarn "NB: Your dev-lang/python is built without USE=ncurses."
+ ewarn "Please rebuild python with USE=ncurses to make use of xenmon.py."
+ fi
+
+ if [[ -n ${XEN_UNSTABLE} ]]; then
+ echo
+ einfo "This is a snapshot of the xen-unstable tree."
+ einfo "Please report bugs in xen itself (and not the packaging) to"
+ einfo "bugzilla.xensource.com"
+ fi
+}