summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTilman Klar <phoenix@gentoo.org>2003-03-23 18:58:01 +0000
committerTilman Klar <phoenix@gentoo.org>2003-03-23 18:58:01 +0000
commit75d7ee6bb7d93d0bd0fa8272aa84e87c7a72005f (patch)
treed72783373fb8cae37b25e5871e20660bfd267714 /app-emulation/winex-cvs
parentversion bump, closes #17365 (diff)
downloadgentoo-2-75d7ee6bb7d93d0bd0fa8272aa84e87c7a72005f.tar.gz
gentoo-2-75d7ee6bb7d93d0bd0fa8272aa84e87c7a72005f.tar.bz2
gentoo-2-75d7ee6bb7d93d0bd0fa8272aa84e87c7a72005f.zip
Worked around a problem with programs/{wcmd,winhelp}.
Diffstat (limited to 'app-emulation/winex-cvs')
-rw-r--r--app-emulation/winex-cvs/ChangeLog7
-rw-r--r--app-emulation/winex-cvs/files/winex-cvs-3.0_pre1.patch15
-rw-r--r--app-emulation/winex-cvs/winex-cvs-3.0_pre1.ebuild9
3 files changed, 28 insertions, 3 deletions
diff --git a/app-emulation/winex-cvs/ChangeLog b/app-emulation/winex-cvs/ChangeLog
index ad02505f831b..b8e7100b2459 100644
--- a/app-emulation/winex-cvs/ChangeLog
+++ b/app-emulation/winex-cvs/ChangeLog
@@ -1,9 +1,14 @@
# ChangeLog for app-emulation/winex-cvs
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex-cvs/ChangeLog,v 1.10 2003/03/16 15:03:14 phoenix Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex-cvs/ChangeLog,v 1.11 2003/03/23 18:58:01 phoenix Exp $
*winex-cvs-3.0_pre1 (16 Mar 2003)
+ 23 Mar 2003; phoen][x <phoenix@gentoo.org> winex-cvs-3.0_pre1.ebuild,
+ files/winex-cvs-3.0_pre1.patch :
+ Incorporated patch to prevent building of programs/{wcmd,winhelp}. These
+ two targets made winex break during compilation.
+
16 Mar 2003; phoen][x <phoenix@gentoo.org> winex-cvs-3.0_pre1.ebuild :
Version bump. Minor modification to the ebuild to make it work: Portage does
not allow the ebuild to be called exactly like the CVS-branch
diff --git a/app-emulation/winex-cvs/files/winex-cvs-3.0_pre1.patch b/app-emulation/winex-cvs/files/winex-cvs-3.0_pre1.patch
new file mode 100644
index 000000000000..1a5170e5159a
--- /dev/null
+++ b/app-emulation/winex-cvs/files/winex-cvs-3.0_pre1.patch
@@ -0,0 +1,15 @@
+--- programs/Makefile.in.orig 2003-03-23 19:41:16.000000000 +0100
++++ programs/Makefile.in 2003-03-23 19:41:24.000000000 +0100
+@@ -17,12 +17,10 @@
+ regtest \
+ uninstaller \
+ view \
+- wcmd \
+ wineconsole \
+ winedbg \
+ winemine \
+ winetest \
+- winhelp \
+ winver
+
+ all: $(SUBDIRS)
diff --git a/app-emulation/winex-cvs/winex-cvs-3.0_pre1.ebuild b/app-emulation/winex-cvs/winex-cvs-3.0_pre1.ebuild
index 6b6ba2f1407b..5971463a858f 100644
--- a/app-emulation/winex-cvs/winex-cvs-3.0_pre1.ebuild
+++ b/app-emulation/winex-cvs/winex-cvs-3.0_pre1.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex-cvs/winex-cvs-3.0_pre1.ebuild,v 1.1 2003/03/16 15:03:14 phoenix Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex-cvs/winex-cvs-3.0_pre1.ebuild,v 1.2 2003/03/23 18:58:01 phoenix Exp $
IUSE="cups opengl"
+inherit eutils
+
# Dont modify the ECVS_BRANCH setting yourself.
# Instead, make a backup of this ebuild and rename it to
# winex-[your branch].ebuild.
@@ -53,6 +55,9 @@ src_compile() {
use opengl && myconf="--enable-opengl" || myconf="--disable-opengl"
[ -z $DEBUG ] && myconf="$myconf --disable-trace --disable-debug" || myconf="$myconf --enable-trace --enable-debug"
+ # patching winex to not compile wcmd
+ epatch ${FILESDIR}/winex-cvs-3.0_pre1.patch
+
# the folks at #winehq were really angry about custom optimization
unset CFLAGS
unset CXXFLAGS
@@ -76,7 +81,7 @@ src_compile() {
cd ${S}
make depend all || die "make depend all failed"
- cd programs && emake || die "emake died"
+ cd programs && gmake || die "emake died"
}
src_install () {