summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2013-06-23 13:13:19 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2013-06-23 13:13:19 +0000
commit0e0df92efd6cc29a5ef98e2df60cf4493ba31da3 (patch)
tree090704853b5868becd15846639dd8d4c021b824f /app-emulation/vmware-modules
parentAdd USE=+deprecated for gtk2 dependency, add live ebuild for gtk3 development. (diff)
downloadgentoo-2-0e0df92efd6cc29a5ef98e2df60cf4493ba31da3.tar.gz
gentoo-2-0e0df92efd6cc29a5ef98e2df60cf4493ba31da3.tar.bz2
gentoo-2-0e0df92efd6cc29a5ef98e2df60cf4493ba31da3.zip
Remove old; add patch to build 264 with kernel 3.8, bug 458228
(Portage version: 2.2.0_alpha183/cvs/Linux x86_64, signed Manifest commit with key EBE6A336BE19039C!)
Diffstat (limited to 'app-emulation/vmware-modules')
-rw-r--r--app-emulation/vmware-modules/ChangeLog7
-rw-r--r--app-emulation/vmware-modules/files/264-3.8.0.patch33
-rw-r--r--app-emulation/vmware-modules/vmware-modules-264.4.ebuild81
-rw-r--r--app-emulation/vmware-modules/vmware-modules-264.5.ebuild3
4 files changed, 41 insertions, 83 deletions
diff --git a/app-emulation/vmware-modules/ChangeLog b/app-emulation/vmware-modules/ChangeLog
index 059f8305e2a1..7c5236b7e241 100644
--- a/app-emulation/vmware-modules/ChangeLog
+++ b/app-emulation/vmware-modules/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/vmware-modules
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-modules/ChangeLog,v 1.105 2013/06/21 20:44:01 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-modules/ChangeLog,v 1.106 2013/06/23 13:13:19 dilfridge Exp $
+
+ 23 Jun 2013; Andreas K. Huettel <dilfridge@gentoo.org>
+ +files/264-3.8.0.patch, -vmware-modules-264.4.ebuild,
+ vmware-modules-264.5.ebuild:
+ Remove old; add patch to build 264 with kernel 3.8, bug 458228
21 Jun 2013; Andreas K. Huettel <dilfridge@gentoo.org>
vmware-modules-238.6.ebuild, vmware-modules-264.5.ebuild,
diff --git a/app-emulation/vmware-modules/files/264-3.8.0.patch b/app-emulation/vmware-modules/files/264-3.8.0.patch
new file mode 100644
index 000000000000..e1a97d8c9b93
--- /dev/null
+++ b/app-emulation/vmware-modules/files/264-3.8.0.patch
@@ -0,0 +1,33 @@
+[patch] Vmware 9 on Linux Kernel 3.8rc4 and later
+source: http://communities.vmware.com/thread/432897 and bug 458228
+
+diff -rupN a/work/vmci-only/linux/driver.c b/work/vmci-only/linux/driver.c
+--- a/work/vmci-only/linux/driver.c 2012-10-31 23:28:45.000000000 -0400
++++ b/work/vmci-only/linux/driver.c 2013-03-18 15:23:52.488752357 -0400
+@@ -124,7 +124,7 @@ static struct pci_driver vmci_driver = {
+ .name = "vmci",
+ .id_table = vmci_ids,
+ .probe = vmci_probe_device,
+- .remove = __devexit_p(vmci_remove_device),
++ .remove = vmci_remove_device,
+ };
+
+ #if LINUX_VERSION_CODE < KERNEL_VERSION(2, 6, 19)
+@@ -1741,7 +1741,7 @@ vmci_enable_msix(struct pci_dev *pdev) /
+ *-----------------------------------------------------------------------------
+ */
+
+-static int __devinit
++static int
+ vmci_probe_device(struct pci_dev *pdev, // IN: vmci PCI device
+ const struct pci_device_id *id) // IN: matching device ID
+ {
+@@ -1969,7 +1969,7 @@ vmci_probe_device(struct pci_dev *pdev,
+ *-----------------------------------------------------------------------------
+ */
+
+-static void __devexit
++static void
+ vmci_remove_device(struct pci_dev* pdev)
+ {
+ struct vmci_device *dev = pci_get_drvdata(pdev);
diff --git a/app-emulation/vmware-modules/vmware-modules-264.4.ebuild b/app-emulation/vmware-modules/vmware-modules-264.4.ebuild
deleted file mode 100644
index 64f5d39a5970..000000000000
--- a/app-emulation/vmware-modules/vmware-modules-264.4.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-modules/vmware-modules-264.4.ebuild,v 1.2 2012/12/12 11:46:57 ssuominen Exp $
-
-EAPI="4"
-
-inherit eutils flag-o-matic linux-info linux-mod user versionator udev
-
-PV_MAJOR=$(get_major_version)
-PV_MINOR=$(get_version_component_range 2)
-
-DESCRIPTION="VMware kernel modules"
-HOMEPAGE="http://www.vmware.com/"
-
-SRC_URI=""
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="pax_kernel"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- || ( =app-emulation/vmware-player-4.0.${PV_MINOR}*
- =app-emulation/vmware-workstation-8.0.${PV_MINOR}* )"
-
-S=${WORKDIR}
-
-pkg_setup() {
- CONFIG_CHECK="~HIGH_RES_TIMERS"
- if kernel_is ge 2 6 37 && kernel_is lt 2 6 39; then
- CONFIG_CHECK="${CONFIG_CHECK} BKL"
- fi
-
- linux-info_pkg_setup
-
- linux-mod_pkg_setup
-
- VMWARE_GROUP=${VMWARE_GROUP:-vmware}
-
- VMWARE_MODULE_LIST="vmblock vmci vmmon vmnet vsock"
- VMWARE_MOD_DIR="${PN}-${PVR}"
-
- BUILD_TARGETS="auto-build KERNEL_DIR=${KERNEL_DIR} KBUILD_OUTPUT=${KV_OUT_DIR}"
-
- enewgroup "${VMWARE_GROUP}"
- filter-flags -mfpmath=sse
-
- for mod in ${VMWARE_MODULE_LIST}; do
- MODULE_NAMES="${MODULE_NAMES} ${mod}(misc:${S}/${mod}-only)"
- done
-}
-
-src_unpack() {
- cd "${S}"
- for mod in ${VMWARE_MODULE_LIST}; do
- tar -xf /opt/vmware/lib/vmware/modules/source/${mod}.tar
- done
-}
-
-src_prepare() {
- epatch "${FILESDIR}/${PV_MAJOR}-makefile-kernel-dir.patch"
- epatch "${FILESDIR}/${PV_MAJOR}-makefile-include.patch"
- epatch "${FILESDIR}/${PV_MAJOR}-jobserver.patch"
- epatch "${FILESDIR}/${PV_MAJOR}-netdevice.patch"
- epatch "${FILESDIR}/${PV_MAJOR}-3.2.0.patch"
- use pax_kernel && epatch "${FILESDIR}/hardened.patch"
- epatch "${FILESDIR}/${PV_MAJOR}-apic.patch"
- epatch "${FILESDIR}/${PV_MAJOR}-d-make-root.patch"
-}
-
-src_install() {
- linux-mod_src_install
- local udevrules="${T}/60-vmware.rules"
- cat > "${udevrules}" <<-EOF
- KERNEL=="vmci", GROUP="vmware", MODE=660
- KERNEL=="vmmon", GROUP="vmware", MODE=660
- KERNEL=="vsock", GROUP="vmware", MODE=660
- EOF
- udev_dorules "${udevrules}"
-}
diff --git a/app-emulation/vmware-modules/vmware-modules-264.5.ebuild b/app-emulation/vmware-modules/vmware-modules-264.5.ebuild
index 9cbb00f24476..74c92eebdd2d 100644
--- a/app-emulation/vmware-modules/vmware-modules-264.5.ebuild
+++ b/app-emulation/vmware-modules/vmware-modules-264.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-modules/vmware-modules-264.5.ebuild,v 1.2 2013/06/21 20:44:01 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-modules/vmware-modules-264.5.ebuild,v 1.3 2013/06/23 13:13:19 dilfridge Exp $
EAPI="4"
@@ -66,6 +66,7 @@ src_prepare() {
use pax_kernel && epatch "${FILESDIR}/hardened.patch"
epatch "${FILESDIR}/${PV_MAJOR}-apic.patch"
kernel_is ge 3 7 0 && epatch "${FILESDIR}/${PV_MAJOR}-putname.patch"
+ kernel_is ge 3 8 0 && epatch "${FILESDIR}/${PV_MAJOR}-3.8.0.patch"
# Allow user patches so they can support RC kernels and whatever else
epatch_user