summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Holm <dholm@gentoo.org>2004-02-11 21:04:54 +0000
committerDavid Holm <dholm@gentoo.org>2004-02-11 21:04:54 +0000
commit2ae9597130106c70425aca9ec59c0565c1a367b8 (patch)
tree11b175a9b4947f8e09b6d5a09d9a030bb797236e /app-emulation/uae
parentAdding cpu-1.4.3, new digests and metadata.xml (Manifest recommit) (diff)
downloadgentoo-2-2ae9597130106c70425aca9ec59c0565c1a367b8.tar.gz
gentoo-2-2ae9597130106c70425aca9ec59c0565c1a367b8.tar.bz2
gentoo-2-2ae9597130106c70425aca9ec59c0565c1a367b8.zip
Commited some compilation fixes
Diffstat (limited to 'app-emulation/uae')
-rw-r--r--app-emulation/uae/ChangeLog6
-rw-r--r--app-emulation/uae/uae-0.8.23_pre20040129.ebuild14
2 files changed, 16 insertions, 4 deletions
diff --git a/app-emulation/uae/ChangeLog b/app-emulation/uae/ChangeLog
index 8b4198145640..75728b1ab145 100644
--- a/app-emulation/uae/ChangeLog
+++ b/app-emulation/uae/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/uae
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/ChangeLog,v 1.11 2004/02/09 09:54:04 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/ChangeLog,v 1.12 2004/02/11 21:04:54 dholm Exp $
+
+ 11 Feb 2004; David Holm <dholm@gentoo.org> uae-0.8.23_pre20040129.ebuild:
+ Added SDL configure flags as suggested by Jonathan Heaney and compilation fix
+ suggested by Lars Schünzel.
*uae-0.8.23_pre20040129 (09 Feb 2004)
diff --git a/app-emulation/uae/uae-0.8.23_pre20040129.ebuild b/app-emulation/uae/uae-0.8.23_pre20040129.ebuild
index 792695d87cad..31cb77615881 100644
--- a/app-emulation/uae/uae-0.8.23_pre20040129.ebuild
+++ b/app-emulation/uae/uae-0.8.23_pre20040129.ebuild
@@ -1,10 +1,12 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/uae-0.8.23_pre20040129.ebuild,v 1.2 2004/02/09 10:55:02 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/uae-0.8.23_pre20040129.ebuild,v 1.3 2004/02/11 21:04:54 dholm Exp $
+
+inherit flag-o-matic
MY_PV="0.8.23-20040129"
S="${WORKDIR}/${PN}-${MY_PV}"
-DESCRIPTION="An amiga emulator"
+DESCRIPTION="The Umiquious Amiga Emulator"
HOMEPAGE="http://www.rcdrummond.net/uae/"
SRC_URI="http://www.rcdrummond.net/uae/uae-${MY_PV}/uae-${MY_PV}.tar.bz2"
@@ -21,7 +23,13 @@ src_compile() {
ewarn "Compiling the CPU-core requires a substantial amount of RAM."
ewarn "Make sure that you have at least 512MB of RAM+SWAP available."
- econf || die "./configure failed"
+ replace-flags "-O3" "-O2"
+ use sdl && myconf="--with-sdl-sound --with-sdl-gfx"
+
+ econf ${myconf} \
+ --enable-threads \
+ --enable-scsi-device \
+ || die "./configure failed"
emake -j1 || die "emake failed"
}