summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <msterret@gentoo.org>2003-08-27 08:14:47 +0000
committerMichael Sterrett <msterret@gentoo.org>2003-08-27 08:14:47 +0000
commit9cf99581250366ab760f5ed4db83719ed531f84f (patch)
tree558789b3519a0711e07a1031b48c3a5656f21319 /app-emulation/uade
parentinitial commit; bug 25886 (diff)
downloadgentoo-2-9cf99581250366ab760f5ed4db83719ed531f84f.tar.gz
gentoo-2-9cf99581250366ab760f5ed4db83719ed531f84f.tar.bz2
gentoo-2-9cf99581250366ab760f5ed4db83719ed531f84f.zip
initial commit; bug 25886
Diffstat (limited to 'app-emulation/uade')
-rw-r--r--app-emulation/uade/ChangeLog9
-rw-r--r--app-emulation/uade/Manifest3
-rw-r--r--app-emulation/uade/files/digest-uade-0.731
-rw-r--r--app-emulation/uade/uade-0.73.ebuild50
4 files changed, 62 insertions, 1 deletions
diff --git a/app-emulation/uade/ChangeLog b/app-emulation/uade/ChangeLog
new file mode 100644
index 000000000000..0483cc31978b
--- /dev/null
+++ b/app-emulation/uade/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for app-emulation/uade
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uade/ChangeLog,v 1.1 2003/08/27 08:14:43 msterret Exp $
+
+*uade-0.73 (27 Aug 2003)
+
+ 27 Aug 2003; Michael Sterrett <msterret@gentoo.org> uade-0.73.ebuild:
+ initial commit; bug 25886 (at least, part of that bug)
+
diff --git a/app-emulation/uade/Manifest b/app-emulation/uade/Manifest
index e2da9c62653e..fc6986baa7d7 100644
--- a/app-emulation/uade/Manifest
+++ b/app-emulation/uade/Manifest
@@ -1,2 +1,3 @@
-MD5 835006241adfedffc868d038eeedef3f uade-0.73.ebuild 949
+MD5 9f3fa48f74be5507b91c92af251f95e9 uade-0.73.ebuild 1354
+MD5 1d27dc85e27dbd8d7c26c4157fb622ad ChangeLog 376
MD5 b56030cf3a179479fa1bf7c8f6d491de files/digest-uade-0.73 63
diff --git a/app-emulation/uade/files/digest-uade-0.73 b/app-emulation/uade/files/digest-uade-0.73
new file mode 100644
index 000000000000..569b13cf566f
--- /dev/null
+++ b/app-emulation/uade/files/digest-uade-0.73
@@ -0,0 +1 @@
+MD5 7546b7b7c4bbd3af956d0dcb30db524f uade-0.73.tar.bz2 1054323
diff --git a/app-emulation/uade/uade-0.73.ebuild b/app-emulation/uade/uade-0.73.ebuild
new file mode 100644
index 000000000000..64d69ace9a9f
--- /dev/null
+++ b/app-emulation/uade/uade-0.73.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uade/uade-0.73.ebuild,v 1.1 2003/08/27 08:14:43 msterret Exp $
+
+DESCRIPTION='Unix Amiga Delitracker Emulator - plays old Amiga tunes through UAE
+ emulation and cloned m68k-assembler Eagleplayer API'
+HOMEPAGE='http://ee.tut.fi/~heikki/uade.html'
+SRC_URI="http://ee.tut.fi/~heikki/uade/${P}.tar.bz2"
+
+LICENSE='GPL-2'
+KEYWORDS='x86'
+SLOT='0'
+
+IUSE='xmms sdl'
+RDEPEND="dev-lang/perl
+ xmms? ( >=media-sound/xmms-1.2.2 x11-libs/gtk+ )
+ sdl? ( media-libs/libsdl )"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ sed -i \
+ -e 's:\$prefix/doc:/usr/share/doc:' configure || \
+ die 'sed configure failed'
+}
+
+src_compile() {
+ local myconf="--package-prefix=${D}"
+ use sdl && myconf="$myconf --with-sdl"
+ use xmms || myconf="$myconf --no-plugin"
+
+ econf ${myconf} || die
+ # warning...broken Makefiles ahead.
+ emake -j1 || die 'emake failed'
+}
+
+src_install() {
+ make DESTDIR=${D} install || die 'make install failed'
+ dodoc BUGS ChangeLog.txt FIXED
+ rm -f ${D}/usr/share/doc/${P}/COPYING
+ find ${D}/usr/share/doc/${P}/ \
+ \( -name '*.readme' -o \
+ -name '*.txt' -o \
+ -name 'INSTALL*' -o \
+ -name 'README*' -o \
+ -name 'Change*' \) -exec gzip -9 \{\} \;
+}