summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2007-07-10 22:38:07 +0000
committerMichael Januszewski <spock@gentoo.org>2007-07-10 22:38:07 +0000
commit4ae960608cf146531248f3bfba1dec1bcda97939 (patch)
treec6671002692c6932ccbaf27ab64ddaa52d664329 /app-emulation/uade
parent Don't move awk, mkfifo, uname, true, false or tty to /bin (diff)
downloadgentoo-2-4ae960608cf146531248f3bfba1dec1bcda97939.tar.gz
gentoo-2-4ae960608cf146531248f3bfba1dec1bcda97939.tar.bz2
gentoo-2-4ae960608cf146531248f3bfba1dec1bcda97939.zip
Version bump.
(Portage version: 2.1.3_rc7)
Diffstat (limited to 'app-emulation/uade')
-rw-r--r--app-emulation/uade/ChangeLog7
-rw-r--r--app-emulation/uade/files/digest-uade-2.073
-rw-r--r--app-emulation/uade/uade-2.07.ebuild36
3 files changed, 45 insertions, 1 deletions
diff --git a/app-emulation/uade/ChangeLog b/app-emulation/uade/ChangeLog
index 976082b93535..9c6091831822 100644
--- a/app-emulation/uade/ChangeLog
+++ b/app-emulation/uade/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/uade
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/uade/ChangeLog,v 1.45 2007/05/05 15:00:21 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uade/ChangeLog,v 1.46 2007/07/10 22:38:07 spock Exp $
+
+*uade-2.07 (10 Jul 2007)
+
+ 10 Jul 2007; Michał Januszewski <spock@gentoo.org> +uade-2.07.ebuild:
+ Version bump.
05 May 2007; Tobias Scherbaum <dertobi123@gentoo.org> uade-2.03.ebuild:
ppc stable
diff --git a/app-emulation/uade/files/digest-uade-2.07 b/app-emulation/uade/files/digest-uade-2.07
new file mode 100644
index 000000000000..78922f2e8477
--- /dev/null
+++ b/app-emulation/uade/files/digest-uade-2.07
@@ -0,0 +1,3 @@
+MD5 2dd16715a6a2e15f5f1dc6ba2d2bc078 uade-2.07.tar.bz2 2628138
+RMD160 59ff78a016f02a1c9f68ecc3c03be691a3826503 uade-2.07.tar.bz2 2628138
+SHA256 bb0661e673659ea174df317a230d126467dbb3c1860edbab3e84f7e21408d459 uade-2.07.tar.bz2 2628138
diff --git a/app-emulation/uade/uade-2.07.ebuild b/app-emulation/uade/uade-2.07.ebuild
new file mode 100644
index 000000000000..b625da25e9ba
--- /dev/null
+++ b/app-emulation/uade/uade-2.07.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uade/uade-2.07.ebuild,v 1.1 2007/07/10 22:38:07 spock Exp $
+
+inherit eutils
+
+DESCRIPTION="Unix Amiga Delitracker Emulator - plays old Amiga tunes through UAE emulation and cloned m68k-assembler Eagleplayer API"
+HOMEPAGE="http://zakalwe.fi/uade"
+SRC_URI="http://zakalwe.fi/uade/uade2/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="audacious"
+
+RDEPEND="media-libs/libao
+ audacious? ( >=media-sound/audacious-0.2 )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ ./configure \
+ --prefix=/usr \
+ --package-prefix="${D}" \
+ $(use_with audacious) \
+ --without-xmms \
+ || die "configure failed"
+ emake || die 'emake failed'
+}
+
+src_install() {
+ make install || die 'make install failed'
+ dodoc AUTHORS ChangeLog doc/BUGS doc/PLANS
+ doman doc/uade123.1
+}