summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2014-08-19 06:59:27 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2014-08-19 06:59:27 +0000
commit883f9ecda8e114519dabc283901e729bce38b8bd (patch)
tree4d47e5c726cde5cdf3f283e97d4f56c291bf23ef /app-emulation/ski
parentCleanup vulnerable Jinja versions for bug 497690 (diff)
downloadgentoo-2-883f9ecda8e114519dabc283901e729bce38b8bd.tar.gz
gentoo-2-883f9ecda8e114519dabc283901e729bce38b8bd.tar.bz2
gentoo-2-883f9ecda8e114519dabc283901e729bce38b8bd.zip
Fix build failure against modern binutils.
(Portage version: 2.2.11_p14/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'app-emulation/ski')
-rw-r--r--app-emulation/ski/ChangeLog8
-rw-r--r--app-emulation/ski/files/ski-1.3.2-binutils.patch31
-rw-r--r--app-emulation/ski/ski-1.3.2.ebuild5
3 files changed, 40 insertions, 4 deletions
diff --git a/app-emulation/ski/ChangeLog b/app-emulation/ski/ChangeLog
index 142656815cfe..cff7e767c9cf 100644
--- a/app-emulation/ski/ChangeLog
+++ b/app-emulation/ski/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/ski
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/ski/ChangeLog,v 1.6 2013/12/31 17:09:19 tomwij Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ski/ChangeLog,v 1.7 2014/08/19 06:59:27 slyfox Exp $
+
+ 19 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org>
+ +files/ski-1.3.2-binutils.patch, ski-1.3.2.ebuild:
+ Fix build failure against modern binutils.
31 Dec 2013; Tom Wijsman <TomWij@gentoo.org>
-files/ski-1.3.2-gtk-linkage.patch:
diff --git a/app-emulation/ski/files/ski-1.3.2-binutils.patch b/app-emulation/ski/files/ski-1.3.2-binutils.patch
new file mode 100644
index 000000000000..71094f3bf4b6
--- /dev/null
+++ b/app-emulation/ski/files/ski-1.3.2-binutils.patch
@@ -0,0 +1,31 @@
+From 30d3253c6b413ba22ca0ca30dcd4c4c24daec2e1 Mon Sep 17 00:00:00 2001
+From: Sergei Trofimovich <slyfox@gentoo.org>
+Date: Tue, 19 Aug 2014 09:42:43 +0300
+Subject: [PATCH] Fix build failure against binutils-2.16.1 and upper.
+
+Follow binutils' upstream change from 2004:
+
+ https://sourceware.org/git/?p=binutils.git;a=commitdiff;h=7e2dd9e4c3e0b69dcb7d471b891879b5fd28687e
+ > section.c (struct sec): Rename "_cooked_size" to "size".
+
+Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
+---
+ src/linux/dwarf-linux.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/linux/dwarf-linux.c b/src/linux/dwarf-linux.c
+index 1941a1f..73be0e6 100644
+--- a/src/linux/dwarf-linux.c
++++ b/src/linux/dwarf-linux.c
+@@ -155,7 +155,7 @@ find_in_section (bfd * bfd, asection * sect, PTR obj)
+ first.function = function;
+ first.line = line;
+ first.num_lines = 1;
+- first.limit = sect->_cooked_size;
++ first.limit = sect->size;
+ last_line = line;
+ }
+ if (line > last_line
+--
+2.0.4
+
diff --git a/app-emulation/ski/ski-1.3.2.ebuild b/app-emulation/ski/ski-1.3.2.ebuild
index 0ca93d6893a6..4446b11a8e70 100644
--- a/app-emulation/ski/ski-1.3.2.ebuild
+++ b/app-emulation/ski/ski-1.3.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/ski/ski-1.3.2.ebuild,v 1.5 2013/09/30 06:57:41 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ski/ski-1.3.2.ebuild,v 1.6 2014/08/19 06:59:27 slyfox Exp $
EAPI="4"
@@ -36,6 +36,7 @@ PATCHES=(
"${FILESDIR}"/${P}-no-local-ltdl.patch
"${FILESDIR}"/${P}-AC_C_BIGENDIAN.patch
"${FILESDIR}"/${P}-configure-withval.patch
+ "${FILESDIR}"/${P}-binutils.patch
)
src_prepare() {