summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2005-08-27 20:59:39 +0000
committerRyan Phillips <rphillips@gentoo.org>2005-08-27 20:59:39 +0000
commite2d91998930d1cb0990fa6eccd9a01cfa1337d98 (patch)
treed7e1b403d0be408e0abc4046797478442b9e8eb2 /app-emulation/simh/simh-3.3.0.ebuild
parentVersion bump. (diff)
downloadgentoo-2-e2d91998930d1cb0990fa6eccd9a01cfa1337d98.tar.gz
gentoo-2-e2d91998930d1cb0990fa6eccd9a01cfa1337d98.tar.bz2
gentoo-2-e2d91998930d1cb0990fa6eccd9a01cfa1337d98.zip
new package
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'app-emulation/simh/simh-3.3.0.ebuild')
-rw-r--r--app-emulation/simh/simh-3.3.0.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-emulation/simh/simh-3.3.0.ebuild b/app-emulation/simh/simh-3.3.0.ebuild
new file mode 100644
index 000000000000..2cb2328b7e4b
--- /dev/null
+++ b/app-emulation/simh/simh-3.3.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/simh/simh-3.3.0.ebuild,v 1.1 2005/08/27 20:59:39 rphillips Exp $
+
+inherit eutils
+
+DESCRIPTION="a simulator for historical computers such as Vax, PDP-11 etc.)"
+HOMEPAGE="http://simh.trailing-edge.com/"
+SRC_URI="http://simh.trailing-edge.com/sources/simhv33-0.zip"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="net-libs/libpcap"
+
+S=${WORKDIR}
+
+MAKEOPTS="USE_NETWORK=1 ${MAKEOPTS}"
+
+
+src_unpack() {
+ mkdir ${WORKDIR}/BIN
+ unpack ${A}
+
+ # convert makefile from dos format to unix format
+ sed -i 's/.$//' makefile
+
+ epatch ${FILESDIR}/makefile.patch
+}
+
+src_compile() {
+ emake || die "make failed"
+}
+
+src_install() {
+ cd "${S}/BIN"
+ for BINFILE in *; do
+ newbin ${BINFILE} "simh-${BINFILE}"
+ done
+
+ cd ${S}
+ dodir /usr/share/simh
+ insinto /usr/share/simh
+ doins VAX/*.bin
+ dodoc *.txt */*.txt
+}