summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2005-08-19 21:37:02 +0000
committerAron Griffis <agriffis@gentoo.org>2005-08-19 21:37:02 +0000
commit79f61f81458c11f477207dd52754f557be126f91 (patch)
treeb642a84c450ad4e5ca980c11e59e8f14f4c88568 /app-emulation/qemu-softmmu
parentAdded patch to fix compilation with gcc-4; bug #103013 (diff)
downloadgentoo-2-79f61f81458c11f477207dd52754f557be126f91.tar.gz
gentoo-2-79f61f81458c11f477207dd52754f557be126f91.tar.bz2
gentoo-2-79f61f81458c11f477207dd52754f557be126f91.zip
Minor ebuild fixups, particularly move MODULE_NAMES setting into pkg_setup.
The kqemu-sysfs patch is not compatible with 2.6.13-rc1+ because the new interfaces are GPL-only, so refrain from applying the patch on those versions; http://lkml.org/lkml/2005/7/4/5 (Portage version: 2.0.51.20-r5)
Diffstat (limited to 'app-emulation/qemu-softmmu')
-rw-r--r--app-emulation/qemu-softmmu/ChangeLog9
-rw-r--r--app-emulation/qemu-softmmu/qemu-softmmu-0.7.1-r1.ebuild51
2 files changed, 34 insertions, 26 deletions
diff --git a/app-emulation/qemu-softmmu/ChangeLog b/app-emulation/qemu-softmmu/ChangeLog
index 54863b935726..0419a88a7f2b 100644
--- a/app-emulation/qemu-softmmu/ChangeLog
+++ b/app-emulation/qemu-softmmu/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/qemu-softmmu
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-softmmu/ChangeLog,v 1.5 2005/08/06 15:41:04 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-softmmu/ChangeLog,v 1.6 2005/08/19 21:37:02 agriffis Exp $
+
+ 19 Aug 2005; Aron Griffis <agriffis@gentoo.org>
+ qemu-softmmu-0.7.1-r1.ebuild:
+ Minor ebuild fixups, particularly move MODULE_NAMES setting into pkg_setup.
+ The kqemu-sysfs patch is not compatible with 2.6.13-rc1+ because the new
+ interfaces are GPL-only, so refrain from applying the patch on those
+ versions; http://lkml.org/lkml/2005/7/4/5
*qemu-softmmu-0.7.1-r1 (06 Aug 2005)
diff --git a/app-emulation/qemu-softmmu/qemu-softmmu-0.7.1-r1.ebuild b/app-emulation/qemu-softmmu/qemu-softmmu-0.7.1-r1.ebuild
index 928cd9a94b2a..fd63a4d64868 100644
--- a/app-emulation/qemu-softmmu/qemu-softmmu-0.7.1-r1.ebuild
+++ b/app-emulation/qemu-softmmu/qemu-softmmu-0.7.1-r1.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-softmmu/qemu-softmmu-0.7.1-r1.ebuild,v 1.2 2005/08/06 16:54:55 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-softmmu/qemu-softmmu-0.7.1-r1.ebuild,v 1.3 2005/08/19 21:37:02 agriffis Exp $
inherit eutils flag-o-matic linux-mod toolchain-funcs
DESCRIPTION="Multi-platform & multi-targets cpu emulator and dynamic translator"
HOMEPAGE="http://fabrice.bellard.free.fr/qemu/"
-SRC_URI="http://fabrice.bellard.free.fr/qemu/${P/-softmmu}.tar.gz
- kqemu? ( http://fabrice.bellard.free.fr/qemu/kqemu-${PV}-1.tar.gz )"
+SRC_URI="${HOMEPAGE}${P/-softmmu}.tar.gz
+ kqemu? ( ${HOMEPAGE}kqemu-${PV}-1.tar.gz )"
#qvm86? ( http://dev.gentoo.org/~lu_zero/distfiles/qvm86-20050409.tar.bz2 )"
#kqemu? ( http://fabrice.bellard.free.fr/qemu/kqemu-${PV%.*}-1.tar.gz )
@@ -25,12 +25,6 @@ RDEPEND="sdl? ( media-libs/libsdl )"
S="${WORKDIR}/${P/-softmmu}"
-MODULE_NAMES=""
-use kqemu && MODULE_NAMES=$MODULE_NAMES" kqemu(misc:${S}/kqemu)"
-#use qvm86 && MODULE_NAMES=$MODULE_NAMES" qvm86(misc:${S}/qvm86)"
-
-
-
set_target_list() {
TARGET_LIST="i386-softmmu ppc-softmmu sparc-softmmu x86_64-softmmu"
export TARGET_LIST
@@ -40,24 +34,35 @@ pkg_setup() {
if [ "$(gcc-major-version)" == "4" ]; then
ewarn "Qemu could not build with GCC 4"
fi
-# ( use kqemu || use qvm86 ) && linux-mod_pkg_setup
+
+ MODULE_NAMES="$(useq kqemu && echo "kqemu(misc:${S}/kqemu)")"
+ # $(useq qvm86 && echo "qvm86(misc:${S}/qvm86)")"
+ #( use kqemu || use qvm86 ) && linux-mod_pkg_setup
use kqemu && linux-mod_pkg_setup
+
+ if use kqemu ; then
+ einfo "QEMU Accelerator enabled (USE=kqemu)"
+ einfo "kqemu is binary module with a restricted license."
+ einfo "Please read carefully the KQEMU license"
+ einfo "and ${HOMEPAGE}qemu-accel.html"
+ einfo "if you would like to see it released under the GPL"
+ fi
}
#RUNTIME_PATH="/emul/gnemul/"
src_unpack() {
unpack ${A}
- if use kqemu ; then
- einfo "QEMU Accelerator enabled"
- einfo "kqemu actually is a closed source software"
- einfo "Please read carefully the KQEMU license"
- einfo "and http://fabrice.bellard.free.fr/qemu/qemu-accel.html"
- einfo "if you want it released under GPL"
- mv ${S}/../kqemu ${S}
- cd ${S}/kqemu
- epatch ${FILESDIR}/kqemu-${PV}-sysfs.patch
- sed -i -e "s:#ifndef PAGE_KERNEL_EXEC:#if 1:" ${S}/kqemu/kqemu-linux.c
+ if use kqemu; then
+ mv ${WORKDIR}/kqemu ${S}
+ cd ${S}/kqemu
+ sed -i -e 's:#ifndef PAGE_KERNEL_EXEC:#if 1:' ${S}/kqemu/kqemu-linux.c
+ # The class_simple interfaces were removed in 2.6.13-rc1, leaving only
+ # GPL symbols behind, which this module can't use. Until there's a fix
+ # from Fabrice, kqemu+udev no worky.
+ if kernel_is le 2 6 12; then
+ epatch ${FILESDIR}/kqemu-${PV}-sysfs.patch
+ fi
fi
# if use qvm86; then
# mv ${WORKDIR}/qvm86 ${S}
@@ -134,12 +139,8 @@ pkg_postinst() {
einfo "You will need the Universal TUN/TAP driver compiled into"
einfo "kernel or as a module to use the virtual network device."
if use kqemu ; then
- einfo "kqemu actually is a closed source software"
- einfo "Please read carefully the KQEMU license"
- einfo "and http://fabrice.bellard.free.fr/qemu/qemu-accel.html"
- einfo "if you want it released under GPL"
linux-mod_pkg_postinst
- einfo "make sure you have the kernel module loaded before running qemu"
+ einfo "Make sure you have the kernel module loaded before running qemu"
einfo "and your user is in the qemu group"
fi
}