summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim Kuznetsov <vadimk@gentoo.org>2009-06-07 20:51:57 +0000
committerVadim Kuznetsov <vadimk@gentoo.org>2009-06-07 20:51:57 +0000
commit328c8dc20d70493a230a94641dfffb4f6609381b (patch)
tree5c96baebd03e25fb0458f1ee31f36329fefaed63 /app-emulation/open-vm-tools
parentbump to rc3 (diff)
downloadgentoo-2-328c8dc20d70493a230a94641dfffb4f6609381b.tar.gz
gentoo-2-328c8dc20d70493a230a94641dfffb4f6609381b.tar.bz2
gentoo-2-328c8dc20d70493a230a94641dfffb4f6609381b.zip
Version bump.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/open-vm-tools')
-rw-r--r--app-emulation/open-vm-tools/ChangeLog8
-rw-r--r--app-emulation/open-vm-tools/files/open-vm-tools.initd76
-rw-r--r--app-emulation/open-vm-tools/open-vm-tools-0.0.20090522.167859.ebuild129
3 files changed, 212 insertions, 1 deletions
diff --git a/app-emulation/open-vm-tools/ChangeLog b/app-emulation/open-vm-tools/ChangeLog
index 76bf508955c1..5af3cbc69402 100644
--- a/app-emulation/open-vm-tools/ChangeLog
+++ b/app-emulation/open-vm-tools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/open-vm-tools
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/ChangeLog,v 1.16 2009/06/04 13:20:34 vadimk Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/ChangeLog,v 1.17 2009/06/07 20:51:57 vadimk Exp $
+
+*open-vm-tools-0.0.20090522.167859 (07 Jun 2009)
+
+ 07 Jun 2009; Vadim Kuznetsov vadimk@gentoo.org
+ +open-vm-tools-0.0.20090522.167859.ebuild, +files/open-vm-tools.initd:
+ Version bump.
*open-vm-tools-0.0.20090318.154848 (04 Jun 2009)
diff --git a/app-emulation/open-vm-tools/files/open-vm-tools.initd b/app-emulation/open-vm-tools/files/open-vm-tools.initd
new file mode 100644
index 000000000000..3988c297daf2
--- /dev/null
+++ b/app-emulation/open-vm-tools/files/open-vm-tools.initd
@@ -0,0 +1,76 @@
+#!/sbin/runscript
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/files/open-vm-tools.initd,v 1.1 2009/06/07 20:51:57 vadimk Exp $
+
+DND_TMPDIR="/tmp/VMwareDnD"
+USER_GROUP="root:vmware"
+DND_TMPDIR_PERMS="1777"
+GUESTD_BIN="/usr/bin/vmtoolsd"
+PIDFILE="/var/run/vmtoolsd.pid"
+MOUNTPOINT="/proc/fs/vmblock/mountPoint"
+
+depend() {
+ before checkfs fsck net X
+}
+
+start() {
+ if [ "${VM_DRAG_AND_DROP}" == "yes" ];
+ then
+
+ if ! grep -q -w vmblock /proc/modules;
+ then
+ ebegin "Loading vmblock module"
+ modprobe vmblock
+ eend $?
+ sleep 0.25
+ fi
+
+ if [[ ! -d "${DND_TMPDIR}" ]];
+ then
+ # einfo "Creating the VM drag and drop directory"
+ mkdir "${DND_TMPDIR}"
+ chown "${USER_GROUP}" "${DND_TMPDIR}"
+ chmod "${DND_TMPDIR_PERMS}" "${DND_TMPDIR}"
+ fi
+
+ # DnD_TMPDIR must exist before vmblock can be mounted
+ ebegin "Mounting vmblock device"
+ mount -t vmblock none ${MOUNTPOINT}
+ eend $?
+ fi
+
+ ebegin "Starting vmtoolsd"
+ start-stop-daemon --chuid "${USER_GROUP}" --start --quiet --exec ${GUESTD_BIN} -- --background "${PIDFILE}"
+ eend $?
+}
+
+stop() {
+ local ret
+
+ if [ "${VM_DRAG_AND_DROP}" == "yes" ];
+ then
+ ebegin "Cleaning the contents of ${DND_TMPDIR}"
+ # First check, whether ${DND_TMPDIR} isn valid... we shouldn't risk deleting the content of ""/*
+ if [[ ! -z "${DND_TMPDIR}" ]] && [[ "${DND_TMPDIR}" != "/" ]];
+ then
+ rm -rf ${DND_TMPDIR}/*
+ ret=0
+ else
+ eerror "Not cleaning up ${DND_TMPDIR}, please check definition of variable"
+ ret=1
+ fi
+ eend $ret
+
+ ebegin "Unmounting vmblock device"
+ if grep -q -w "${MOUNTPOINT}" /proc/mounts;
+ then
+ umount ${MOUNTPOINT} 1>&2 > /dev/null
+ fi
+ eend 0
+ fi
+
+ ebegin "Stopping vmtoolsd"
+ start-stop-daemon --stop --quiet --pidfile "${PIDFILE}"
+ eend $?
+}
diff --git a/app-emulation/open-vm-tools/open-vm-tools-0.0.20090522.167859.ebuild b/app-emulation/open-vm-tools/open-vm-tools-0.0.20090522.167859.ebuild
new file mode 100644
index 000000000000..fcc3331afb0d
--- /dev/null
+++ b/app-emulation/open-vm-tools/open-vm-tools-0.0.20090522.167859.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/open-vm-tools-0.0.20090522.167859.ebuild,v 1.1 2009/06/07 20:51:57 vadimk Exp $
+
+EAPI="2"
+
+inherit eutils linux-mod pam versionator
+
+MY_DATE="$(get_version_component_range 3)"
+MY_BUILD="$(get_version_component_range 4)"
+MY_PV="${MY_DATE:0:4}.${MY_DATE:4:2}.${MY_DATE:6:2}-${MY_BUILD}"
+MY_P="${PN}-${MY_PV}"
+
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Opensourced tools for VMware guests"
+HOMEPAGE="http://open-vm-tools.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="X xinerama icu unity"
+DEPEND="
+ virtual/linux-sources
+ sys-apps/ethtool
+ X? (
+ x11-libs/libX11
+ x11-libs/gtk+
+ dev-cpp/gtkmm
+ )
+ unity? (
+ x11-libs/libXScrnSaver
+ dev-libs/uriparser
+ )
+ xinerama? (
+ x11-libs/libXinerama
+ )
+ !app-emulation/vmware-workstation-tools
+ !app-emulation/vmware-server-tools
+ !app-emulation/vmware-esx-tools
+ sys-process/procps
+ dev-libs/libdnet
+ icu? ( dev-libs/icu )
+ "
+
+RDEPEND="${DEPEND/virtual\/linux\-sources/}
+ virtual/pam
+ X? (
+ x11-base/xorg-server
+ x11-drivers/xf86-video-vmware
+ x11-drivers/xf86-input-vmmouse
+ )
+ unity? (
+ x11-libs/libXScrnSaver
+ dev-libs/uriparser
+ )
+ "
+
+VMWARE_MOD_DIR="modules/linux"
+VMWARE_MODULE_LIST="pvscsi vmblock vmci vmhgfs vmsync vmmemctl vmxnet vmxnet3 vsock"
+
+pkg_setup() {
+ use unity && ! use xinerama && \
+ die 'The Unity USE flag requires USE="xinerama" as well'
+
+ linux-mod_pkg_setup
+ MODULE_NAMES=""
+ BUILD_TARGETS="auto-build HEADER_DIR=${KERNEL_DIR}/include BUILD_DIR=${KV_OUT_DIR} OVT_SOURCE_DIR=${S}"
+
+ for mod in ${VMWARE_MODULE_LIST};
+ do
+ if [ "${mod}" == "vmxnet" -o "${mod}" == "vmxnet3" ];
+ then
+ MODTARGET="net"
+ else
+ MODTARGET="openvmtools"
+ fi
+ MODULE_NAMES="${MODULE_NAMES} ${mod}(${MODTARGET}:${S}/${VMWARE_MOD_DIR}/${mod})"
+ done
+
+ enewgroup vmware
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/default-scripts.patch"
+ epatch "${FILESDIR}/wiper-warning-fix.patch"
+ sed -e 's:VMTOOLSD_PLUGIN_ROOT=\\"\$(pkglibdir)\\":VMTOOLSD_PLUGIN_ROOT=\\"\$(pkglibdir)/plugins\\":g' -i services/vmtoolsd/Makefile.in
+}
+
+src_configure() {
+ econf \
+ --without-kernel-modules \
+ $(use_with icu) \
+ $(use_with X x11) \
+ $(use_with X gtkmm) \
+ $(use_enable unity) \
+ $(use_enable xinerama multimon)
+}
+
+src_compile() {
+ linux-mod_src_compile
+
+ emake || die
+}
+
+src_install() {
+ linux-mod_src_install
+
+ emake DESTDIR="${D}" install || die "Failed to install"
+
+ rm "${D}"/etc/pam.d/vmtoolsd
+ pamd_mimic_system vmtoolsd auth account
+
+ newinitd "${FILESDIR}/open-vm-tools.initd" vmware-tools
+ newconfd "${FILESDIR}/open-vm.confd" vmware-tools
+
+ if use X;
+ then
+ insinto /etc/xdg/autostart
+ doins "${FILESDIR}/open-vm-tools.desktop"
+
+ elog "To be able to use the drag'n'drop feature of VMware for file"
+ elog "exchange, you need to do this:"
+ elog " Add 'vmware-tools' to your default runlevel"
+ elog " Add the users which should have access to this function"
+ elog " to the group 'vmware'"
+ fi
+}