summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2006-10-28 19:54:25 +0000
committerJoseph Jezak <josejx@gentoo.org>2006-10-28 19:54:25 +0000
commit9efdad8a010a8fdb707198d154005ac4451842f6 (patch)
tree5a5d88c20ff734db2ffc137812486562b4a22ece /app-emulation/mol
parentRevision bump, add a couple of USE flags. (diff)
downloadgentoo-2-9efdad8a010a8fdb707198d154005ac4451842f6.tar.gz
gentoo-2-9efdad8a010a8fdb707198d154005ac4451842f6.tar.bz2
gentoo-2-9efdad8a010a8fdb707198d154005ac4451842f6.zip
New version - 2.6.19 support. Updated website and src info.
(Portage version: 2.1.2_pre3-r8)
Diffstat (limited to 'app-emulation/mol')
-rw-r--r--app-emulation/mol/ChangeLog9
-rw-r--r--app-emulation/mol/files/digest-mol-0.9.71.13
-rw-r--r--app-emulation/mol/files/mol-pciproxy-dump.patch18
-rw-r--r--app-emulation/mol/metadata.xml2
-rw-r--r--app-emulation/mol/mol-0.9.71.1.ebuild138
-rw-r--r--app-emulation/mol/mol-0.9.71.ebuild8
6 files changed, 163 insertions, 15 deletions
diff --git a/app-emulation/mol/ChangeLog b/app-emulation/mol/ChangeLog
index 4a7dff610eec..2ceefedef5ba 100644
--- a/app-emulation/mol/ChangeLog
+++ b/app-emulation/mol/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/mol
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/ChangeLog,v 1.64 2006/10/03 04:08:36 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/ChangeLog,v 1.65 2006/10/28 19:54:25 josejx Exp $
+
+*mol-0.9.71.1 (28 Oct 2006)
+
+ 28 Oct 2006; Joseph Jezak <josejx@gentoo.org>
+ -files/mol-0.9.71-pciproxy-dump.patch, files/mol-pciproxy-dump.patch,
+ -mol-0.9.71_pre8-r1.ebuild, +mol-0.9.71.1.ebuild:
+ New version - 2.6.19 support. Updated website and src info.
*mol-0.9.71 (03 Oct 2006)
diff --git a/app-emulation/mol/files/digest-mol-0.9.71.1 b/app-emulation/mol/files/digest-mol-0.9.71.1
new file mode 100644
index 000000000000..f863f94eb585
--- /dev/null
+++ b/app-emulation/mol/files/digest-mol-0.9.71.1
@@ -0,0 +1,3 @@
+MD5 3eaa51927191b03b06828609a1122307 mol-0.9.71.1.tar.bz2 1850812
+RMD160 f671bc4f52ebd6256ce615924ce5117cb1b5ff45 mol-0.9.71.1.tar.bz2 1850812
+SHA256 3be6fbd218e4f922973cefc49963bcf4b7d8f5e775019b0e8c6a36acff02a7be mol-0.9.71.1.tar.bz2 1850812
diff --git a/app-emulation/mol/files/mol-pciproxy-dump.patch b/app-emulation/mol/files/mol-pciproxy-dump.patch
index f321a6b9abe5..aee33ec0ff9c 100644
--- a/app-emulation/mol/files/mol-pciproxy-dump.patch
+++ b/app-emulation/mol/files/mol-pciproxy-dump.patch
@@ -55,8 +55,8 @@
/* indeed we now call a hook here ;-) */
if (dev->hooks.write_config != NULL)
-- (*(dev->hooks.write_config))(dev->usr, offs, &val);
-+ (*(dev->hooks.write_config))(dev->usr, offs, last, &val);
+- (*(dev->hooks.write_config))(dev->usr, offs, (char *) &val);
++ (*(dev->hooks.write_config))(dev->usr, offs, last, (char *) &val);
/* Base registers & rom */
if( rr >= (PCI_BASE_ADDRESS_0 >> 2) && rr <= (PCI_BASE_ADDRESS_5 >> 2) ) {
@@ -204,7 +204,7 @@
@@ -300,6 +334,12 @@
}
- lvaddr = pdev->bars[ind].lvbase + (addr - pdev->bars[ind].mmum.mbase);
+ lvaddr = (char *)pdev->bars[ind].lvbase + (addr - pdev->bars[ind].mmum.mbase);
+ r_int = data;
+ r_short = data;
+ r_pass = data;
@@ -260,21 +260,21 @@
+ if (gettimeofday(&t, NULL))
+ fprintf(stderr, "gettimeofday error\n");
+
-+ len = snprintf(buf, sizeof(buf), "%.8ld.%.6ld 0x%.8x %s %s 0x%.4x %d %*dx%.*x\n",
-+ t.tv_sec, t.tv_usec, mregs->nip, type, (in?"r":"w"), offset, datalen, 9-2*datalen, 0, 2*datalen, data);
++ len = snprintf((char *)buf, sizeof(buf), "%.8ld.%.6ld 0x%.8x %s %s 0x%.4x %d %*dx%.*x\n",
++ t.tv_sec, t.tv_usec, (unsigned int) mregs->nip, type, (in?"r":"w"), offset, datalen, 9-2*datalen, 0, 2*datalen, data);
+
+ if (len > 0)
+ write(pdump_fd, buf, len);
+}
+
+void
-+pdump_initialise() {
++pdump_initialise(void) {
+ if (pdump_fd != -1) return;
+ pdump_fd = open("/tmp/test.dump", O_CREAT | O_WRONLY | O_TRUNC, 0644);
+}
+
+void
-+pdump_deinit() {
++pdump_deinit(void) {
+ close(pdump_fd);
+}
--- src/drivers/plain-dump.h 1970-01-01 01:00:00.000000000 +0100
@@ -284,8 +284,8 @@
+#define __plain_dump_h
+
+void pdump_write_pkt(short offset, int in, int datalen, int data, const char * type);
-+void pdump_initialise();
-+void pdump_deinit();
++void pdump_initialise(void);
++void pdump_deinit(void);
+
+#endif
--- src/kmod/Linux/alloc.h 2005-07-21 14:26:24.979343068 +0200
diff --git a/app-emulation/mol/metadata.xml b/app-emulation/mol/metadata.xml
index 1c05d56b08d1..93fed147cfa6 100644
--- a/app-emulation/mol/metadata.xml
+++ b/app-emulation/mol/metadata.xml
@@ -3,7 +3,7 @@
<pkgmetadata>
<herd>ppc</herd>
<longdescription>
- mac-on-linux -- Running Mac OS (X) from within Linux
+ Mac-On-Linux - Allows the virtualization of MacOS or MacOS X from within Linux
</longdescription>
<maintainer><email>josejx@gentoo.org</email><name>Joseph Jezak</name></maintainer>
</pkgmetadata>
diff --git a/app-emulation/mol/mol-0.9.71.1.ebuild b/app-emulation/mol/mol-0.9.71.1.ebuild
new file mode 100644
index 000000000000..fb132c39e975
--- /dev/null
+++ b/app-emulation/mol/mol-0.9.71.1.ebuild
@@ -0,0 +1,138 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/mol-0.9.71.1.ebuild,v 1.1 2006/10/28 19:54:25 josejx Exp $
+
+inherit flag-o-matic eutils linux-mod
+
+DESCRIPTION="MOL (Mac-on-Linux) lets PPC users run MacOS (X) under Linux (rsync snapshot)"
+HOMEPAGE="http://mac-on-linux.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mac-on-linux/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~ppc"
+IUSE="vnc alsa oss fbcon X oldworld sheep debug dga usb pci"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+RDEPEND="net-misc/dhcp
+ net-firewall/iptables
+ alsa? ( virtual/alsa )
+ vnc? ( net-misc/vnc )
+ X? ( || ( ( x11-libs/libXext
+ dga? ( x11-libs/libXxf86dga )
+ )
+ virtual/x11
+ )
+ )"
+DEPEND="${RDEPEND}
+ X? ( || ( ( x11-libs/libXt
+ x11-proto/xextproto
+ dga? ( x11-proto/xf86dgaproto )
+ )
+ virtual/x11
+ )
+ )"
+
+MODULE_NAMES="mol(mol:${S}/src/kmod/Linux)
+ sheep(net:${S}/src/netdriver)"
+
+pkg_setup() {
+ echo
+ einfo "If you want to use MOL fullscreen on a virtual console"
+ einfo "be sure to have the USE-flag \"fbcon\" set!"
+ echo
+
+ linux-mod_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ # PCI Debugging Patch
+ if use debug; then
+ epatch ${FILESDIR}/${PN}-pciproxy-dump.patch
+ fi
+}
+
+src_compile() {
+ filter-flags -fsigned-char
+ append-flags -D_FILE_OFFSET_BITS=64
+ append-flags -D_LARGE_FILES
+
+ export KERNEL_SOURCE="/usr/src/${FK}"
+ export LDFLAGS=""
+
+ # initialize all needed build-files
+ ./autogen.sh
+ ./configure --prefix="/usr" || die "Configure failed."
+
+ # workaround for proper module-building
+ emake defconfig || die "Make failed."
+
+ sed -i "s:CONFIG_XDGA=y:# CONFIG_XDGA is not set:" .config-ppc
+ sed -i "s:CONFIG_TAP=y:# CONFIG_TAP is not set:" .config-ppc
+ sed -i "s:CONFIG_TUN=y:# CONFIG_TUN is not set:" .config-ppc
+ use alsa || sed -i "s:CONFIG_ALSA=y:# CONFIG_ALSA is not set:" .config-ppc
+ use debug && sed -i "s:# CONFIG_DEBUGGER is not set:CONFIG_DEBUGGER=y:" .config-ppc
+ use oss || sed -i "s:CONFIG_OSS=y:# CONFIG_OSS is not set:" .config-ppc
+ use oldworld || sed -i "s:CONFIG_OLDWORLD=y:# CONFIG_OLDWORLD is not set:" .config-ppc
+ use sheep || sed -i "s:CONFIG_SHEEP=y:# CONFIG_SHEEP is not set:" .config-ppc
+ use X || sed -i "s:CONFIG_X11=y:# CONFIG_X11 is not set:" .config-ppc
+ use fbcon || sed -i "s:CONFIG_FBDEV=y:# CONFIG_FBDEV is not set:" .config-ppc
+ use vnc || sed -i "s:CONFIG_VNC=y:# CONFIG_VNC is not set:" .config-ppc
+ use dga || sed -i "s:CONFIG_XDGA=y:# CONFIG_XDGA is not set:" .config-ppc
+ use usb || sed -i "s:CONFIG_USBDEV=y:# CONFIG_USBDEV is not set:" .config-ppc
+ use pci || sed -i "s:CONFIG_PCIPROXY=y:# CONFIG_PCIPROXY is not set:" .config-ppc
+
+ einfo "The configuration has been altered according to your USE-flags."
+ # reinitialize our changed configuration
+ emake oldconfig
+
+ cd ${S}
+ emake BUILD_MODS=n || die "Build failed."
+
+ # Build the modules too!
+ BUILD_PARAMS="KERNEL_SOURCE=${KV_DIR} LV=${KV_MAJOR}${KV_MINOR} MP=${KV_OBJ}
+ KUNAME=${KV}"
+ BUILD_TARGETS=all
+ linux-mod_src_compile
+}
+
+src_install() {
+ #linux-mod_src_install
+ cd ${S}
+ emake DESTDIR=${D} install || die "Failed to install"
+ dodoc CREDITS Doc/Boot-ROM Doc/NewWorld-ROM Doc/Sound Doc/Video
+ dodoc Doc/Networking Doc/Dev/Debugger Doc/Dev/Addresses
+ dodoc Doc/man/molvconfig.1 Doc/man/startmol.1 Doc/man/molrc.5
+ insinto /var/lib/mol
+ doins ${S}/mollib/nvram/nvram.x
+}
+
+pkg_postinst() {
+ echo
+ einfo "Mac-on-Linux is now installed. To run, use the command startmol."
+ einfo "You might want to configure video modes first with molvconfig."
+ einfo "Other configuration is in /etc/molrc. For more info see:"
+ einfo " http://www.maconlinux.org"
+ einfo "Also try man molrc, man molvconfig, man startmol"
+ echo
+ ewarn "For networking and sound you might install the drivers in the"
+ ewarn "folder \"MOL-Install\" on your Mac OS X-Desktop."
+ echo
+ ewarn "If errors with networking occur, make sure you have the following"
+ ewarn "kernel functions enabled:"
+ einfo "For connecting to Linux:"
+ einfo " Universal TUN/TAP device driver support (CONFIG_TUN)"
+ einfo "For the dhcp server:"
+ einfo " Packet Socket (CONFIG_PACKET)"
+ einfo "For NAT:"
+ einfo " Network packet filtering (CONFIG_NETFILTER)"
+ einfo " Connection tracking (CONFIG_IP_NF_CONNTRACK)"
+ einfo " IP tables support (CONFIG_IP_NF_IPTABLES)"
+ einfo " Packet filtering (CONFIG_IP_NF_FILTER)"
+ einfo " Full NAT (CONFIG_IP_NF_NAT)"
+ einfo " MASQUERADE target support (CONFIG_IP_NF_TARGET_MASQUERADE)"
+ echo
+}
diff --git a/app-emulation/mol/mol-0.9.71.ebuild b/app-emulation/mol/mol-0.9.71.ebuild
index 66318270ea61..d2a47808dbed 100644
--- a/app-emulation/mol/mol-0.9.71.ebuild
+++ b/app-emulation/mol/mol-0.9.71.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/mol-0.9.71.ebuild,v 1.1 2006/10/03 04:08:36 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/mol-0.9.71.ebuild,v 1.2 2006/10/28 19:54:25 josejx Exp $
inherit flag-o-matic eutils linux-mod
DESCRIPTION="MOL (Mac-on-Linux) lets PPC users run MacOS (X) under Linux (rsync snapshot)"
-HOMEPAGE="http://www.maconlinux.org/"
-SRC_URI="mirror://gentoo/${P}.tar.bz2"
+HOMEPAGE="http://mac-on-linux.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mac-on-linux/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
@@ -51,7 +51,7 @@ src_unpack() {
cd ${S}
# PCI Debugging Patch
if use debug; then
- epatch ${FILESDIR}/${P}-pciproxy-dump.patch
+ epatch ${FILESDIR}/${PN}-pciproxy-dump.patch
fi
}