summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2007-01-16 00:17:43 +0000
committerJoseph Jezak <josejx@gentoo.org>2007-01-16 00:17:43 +0000
commit2f2c6bacb6399418bc1020818308db69e25cea79 (patch)
treef11a3408b0c4306c27536c0019a7591fd358d484 /app-emulation/mol
parent- import readahead() symbol and import from Joakim Tjernlund - uClibc-svn-r17... (diff)
downloadgentoo-2-2f2c6bacb6399418bc1020818308db69e25cea79.tar.gz
gentoo-2-2f2c6bacb6399418bc1020818308db69e25cea79.tar.bz2
gentoo-2-2f2c6bacb6399418bc1020818308db69e25cea79.zip
Added latest version.
(Portage version: 2.1.2_rc4-r7)
Diffstat (limited to 'app-emulation/mol')
-rw-r--r--app-emulation/mol/ChangeLog7
-rw-r--r--app-emulation/mol/files/digest-mol-0.9.71.16
-rw-r--r--app-emulation/mol/files/digest-mol-0.9.72_pre23
-rw-r--r--app-emulation/mol/mol-0.9.72_pre2.ebuild135
4 files changed, 147 insertions, 4 deletions
diff --git a/app-emulation/mol/ChangeLog b/app-emulation/mol/ChangeLog
index 450fda711f3e..7891d34c9857 100644
--- a/app-emulation/mol/ChangeLog
+++ b/app-emulation/mol/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/mol
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/ChangeLog,v 1.68 2007/01/08 22:03:08 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/ChangeLog,v 1.69 2007/01/16 00:17:42 josejx Exp $
+
+*mol-0.9.72_pre2 (16 Jan 2007)
+
+ 16 Jan 2007; Joseph Jezak <josejx@gentoo.org> +mol-0.9.72_pre2.ebuild:
+ Added latest version.
08 Jan 2007; Joseph Jezak <josejx@gentoo.org>
-files/mol-pciproxy-dump.patch, -mol-0.9.71.ebuild, mol-0.9.71.1.ebuild,
diff --git a/app-emulation/mol/files/digest-mol-0.9.71.1 b/app-emulation/mol/files/digest-mol-0.9.71.1
index f863f94eb585..225e10d2029d 100644
--- a/app-emulation/mol/files/digest-mol-0.9.71.1
+++ b/app-emulation/mol/files/digest-mol-0.9.71.1
@@ -1,3 +1,3 @@
-MD5 3eaa51927191b03b06828609a1122307 mol-0.9.71.1.tar.bz2 1850812
-RMD160 f671bc4f52ebd6256ce615924ce5117cb1b5ff45 mol-0.9.71.1.tar.bz2 1850812
-SHA256 3be6fbd218e4f922973cefc49963bcf4b7d8f5e775019b0e8c6a36acff02a7be mol-0.9.71.1.tar.bz2 1850812
+MD5 0e9a404a421121ca55751d5c4500e37b mol-0.9.71.1.tar.bz2 1850616
+RMD160 9887f407ec799e00d73ebb5785b7740331148b59 mol-0.9.71.1.tar.bz2 1850616
+SHA256 00a7a3f4129414f30a911075f666d7aac785f6b6a161407e8a82f640de99f0e0 mol-0.9.71.1.tar.bz2 1850616
diff --git a/app-emulation/mol/files/digest-mol-0.9.72_pre2 b/app-emulation/mol/files/digest-mol-0.9.72_pre2
new file mode 100644
index 000000000000..122bcc257d44
--- /dev/null
+++ b/app-emulation/mol/files/digest-mol-0.9.72_pre2
@@ -0,0 +1,3 @@
+MD5 1fd1c46ed49016e713161cb697a18ddd mol-0.9.72_pre2.tar.bz2 1860244
+RMD160 7d3cbca6e585ef8f0e061be799938657182623e1 mol-0.9.72_pre2.tar.bz2 1860244
+SHA256 3eb5c396c704d8e4e2c8c010cc4e86c3f9e5f47059482c458f35ed94f8bc2272 mol-0.9.72_pre2.tar.bz2 1860244
diff --git a/app-emulation/mol/mol-0.9.72_pre2.ebuild b/app-emulation/mol/mol-0.9.72_pre2.ebuild
new file mode 100644
index 000000000000..8d25b7f675ae
--- /dev/null
+++ b/app-emulation/mol/mol-0.9.72_pre2.ebuild
@@ -0,0 +1,135 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/mol-0.9.72_pre2.ebuild,v 1.1 2007/01/16 00:17:42 josejx Exp $
+
+inherit flag-o-matic eutils linux-mod
+
+DESCRIPTION="MOL (Mac-on-Linux) lets PPC users run MacOS (X) under Linux (rsync snapshot)"
+HOMEPAGE="http://www.maconlinux.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~ppc"
+IUSE="vnc alsa oss fbcon X oldworld sheep debug dga usb pci"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+RDEPEND="net-misc/dhcp
+ net-firewall/iptables
+ alsa? ( virtual/alsa )
+ vnc? ( net-misc/vnc )
+ X? ( || ( ( x11-libs/libXext
+ dga? ( x11-libs/libXxf86dga )
+ )
+ virtual/x11
+ )
+ )"
+DEPEND="${RDEPEND}
+ X? ( || ( ( x11-libs/libXt
+ x11-proto/xextproto
+ dga? ( x11-proto/xf86dgaproto )
+ )
+ virtual/x11
+ )
+ )"
+
+MODULE_NAMES="mol(mol:${S}/src/kmod/Linux)
+ sheep(net:${S}/src/netdriver)"
+
+pkg_setup() {
+ echo
+ if ! use fbcon; then
+ einfo "If you want to use MOL fullscreen on a virtual console"
+ einfo "be sure to have the USE-flag \"fbcon\" set!"
+ fi
+ echo
+
+ linux-mod_pkg_setup
+}
+
+src_compile() {
+ filter-flags -fsigned-char
+ append-flags -D_FILE_OFFSET_BITS=64
+ append-flags -D_LARGE_FILES
+
+ export KERNEL_SOURCE="/usr/src/${FK}"
+ export LDFLAGS=""
+
+ # initialize all needed build-files
+ ./autogen.sh
+ ./configure --prefix="/usr" || die "Configure failed."
+
+ # workaround for proper module-building
+ emake defconfig || die "Make failed."
+
+ sed -i "s:CONFIG_XDGA=y:# CONFIG_XDGA is not set:" .config-ppc
+ sed -i "s:CONFIG_TAP=y:# CONFIG_TAP is not set:" .config-ppc
+ sed -i "s:CONFIG_TUN=y:# CONFIG_TUN is not set:" .config-ppc
+ use alsa || sed -i "s:CONFIG_ALSA=y:# CONFIG_ALSA is not set:" .config-ppc
+ use debug && sed -i "s:# CONFIG_DEBUGGER is not set:CONFIG_DEBUGGER=y:" .config-ppc
+ use oss || sed -i "s:CONFIG_OSS=y:# CONFIG_OSS is not set:" .config-ppc
+ use oldworld || sed -i "s:CONFIG_OLDWORLD=y:# CONFIG_OLDWORLD is not set:" .config-ppc
+ use sheep || sed -i "s:CONFIG_SHEEP=y:# CONFIG_SHEEP is not set:" .config-ppc
+ use X || sed -i "s:CONFIG_X11=y:# CONFIG_X11 is not set:" .config-ppc
+ use fbcon || sed -i "s:CONFIG_FBDEV=y:# CONFIG_FBDEV is not set:" .config-ppc
+ use vnc || sed -i "s:CONFIG_VNC=y:# CONFIG_VNC is not set:" .config-ppc
+ use dga || sed -i "s:CONFIG_XDGA=y:# CONFIG_XDGA is not set:" .config-ppc
+ use usb || sed -i "s:CONFIG_USBDEV=y:# CONFIG_USBDEV is not set:" .config-ppc
+ use pci || sed -i "s:CONFIG_PCIPROXY=y:# CONFIG_PCIPROXY is not set:" .config-ppc
+
+ einfo "The configuration has been altered according to your USE-flags."
+ # reinitialize our changed configuration
+ emake oldconfig
+
+ cd ${S}
+ emake BUILD_MODS=n || die "Build failed."
+
+ # Build the modules too!
+ BUILD_PARAMS="KERNEL_SOURCE=${KV_DIR} LV=${KV_MAJOR}${KV_MINOR} MP=${KV_OBJ}
+ KUNAME=${KV}"
+ BUILD_TARGETS=all
+ linux-mod_src_compile
+}
+
+src_install() {
+ #linux-mod_src_install
+ cd ${S}
+ emake DESTDIR=${D} install || die "Failed to install"
+ dodoc CREDITS Doc/Boot-ROM Doc/NewWorld-ROM Doc/Sound Doc/Video
+ dodoc Doc/Networking Doc/Dev/Debugger Doc/Dev/Addresses
+ dodoc Doc/man/molvconfig.1 Doc/man/startmol.1 Doc/man/molrc.5
+
+ dodir /var/lib/mol/lock
+ touch ${D}/var/lib/mol/lock/.keep
+ dodir /var/lib/mol/log
+ touch ${D}/var/lib/mol/log/.keep
+}
+
+pkg_postinst() {
+ echo
+ einfo "Mac-on-Linux is now installed. To run, use the command startmol."
+ if use fbcon; then
+ einfo "You might want to configure video modes first with molvconfig."
+ fi
+ einfo "Other configuration is in /etc/molrc. For more info see:"
+ einfo " http://www.maconlinux.org"
+ einfo "Also try man molrc, man molvconfig, man startmol"
+ echo
+ ewarn "For networking and sound you might install the drivers in the"
+ ewarn "folder \"MOL-Install\" on your Mac OS X-Desktop."
+ echo
+ ewarn "If errors with networking occur, make sure you have the following"
+ ewarn "kernel functions enabled:"
+ einfo "For connecting to Linux:"
+ einfo " Universal TUN/TAP device driver support (CONFIG_TUN)"
+ einfo "For the dhcp server:"
+ einfo " Packet Socket (CONFIG_PACKET)"
+ einfo "For NAT:"
+ einfo " Network packet filtering (CONFIG_NETFILTER)"
+ einfo " Connection tracking (CONFIG_IP_NF_CONNTRACK)"
+ einfo " IP tables support (CONFIG_IP_NF_IPTABLES)"
+ einfo " Packet filtering (CONFIG_IP_NF_FILTER)"
+ einfo " Full NAT (CONFIG_IP_NF_NAT)"
+ einfo " MASQUERADE target support (CONFIG_IP_NF_TARGET_MASQUERADE)"
+ echo
+}