summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2013-03-18 17:31:41 +0000
committerDoug Goldstein <cardoe@gentoo.org>2013-03-18 17:31:41 +0000
commitfa1c24ac0f2041f561d1bd8447c49ea6ea364cd0 (patch)
treeb785744176f0c546ea451dfbaca7be38e6ea162e /app-emulation/libvirt-glib
parentStabilize for all. (diff)
downloadgentoo-2-fa1c24ac0f2041f561d1bd8447c49ea6ea364cd0.tar.gz
gentoo-2-fa1c24ac0f2041f561d1bd8447c49ea6ea364cd0.tar.bz2
gentoo-2-fa1c24ac0f2041f561d1bd8447c49ea6ea364cd0.zip
Version bump
(Portage version: 2.1.11.52/cvs/Linux x86_64, signed Manifest commit with key D7DFA8D318FA9AEF!)
Diffstat (limited to 'app-emulation/libvirt-glib')
-rw-r--r--app-emulation/libvirt-glib/ChangeLog7
-rw-r--r--app-emulation/libvirt-glib/libvirt-glib-0.1.6.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/app-emulation/libvirt-glib/ChangeLog b/app-emulation/libvirt-glib/ChangeLog
index c5a860ab93fd..f83293d40a0a 100644
--- a/app-emulation/libvirt-glib/ChangeLog
+++ b/app-emulation/libvirt-glib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/libvirt-glib
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt-glib/ChangeLog,v 1.19 2013/03/05 22:57:34 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt-glib/ChangeLog,v 1.20 2013/03/18 17:31:41 cardoe Exp $
+
+*libvirt-glib-0.1.6 (18 Mar 2013)
+
+ 18 Mar 2013; Doug Goldstein <cardoe@gentoo.org> +libvirt-glib-0.1.6.ebuild:
+ Version bump
05 Mar 2013; Gilles Dartiguelongue <eva@gentoo.org>
-libvirt-glib-0.1.3.ebuild, -libvirt-glib-0.1.4.ebuild:
diff --git a/app-emulation/libvirt-glib/libvirt-glib-0.1.6.ebuild b/app-emulation/libvirt-glib/libvirt-glib-0.1.6.ebuild
new file mode 100644
index 000000000000..8ec12bd662fb
--- /dev/null
+++ b/app-emulation/libvirt-glib/libvirt-glib-0.1.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt-glib/libvirt-glib-0.1.6.ebuild,v 1.1 2013/03/18 17:31:41 cardoe Exp $
+
+EAPI=5
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+VALA_MIN_API_VERSION="0.14"
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit gnome2 python-single-r1 vala
+
+DESCRIPTION="GLib and GObject mappings for libvirt"
+HOMEPAGE="http://libvirt.org/git/?p=libvirt-glib.git"
+SRC_URI="ftp://libvirt.org/libvirt/glib/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+introspection python +vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="dev-libs/libxml2:2
+ >=app-emulation/libvirt-0.9.10:=
+ >=dev-libs/glib-2.10:2
+ introspection? ( >=dev-libs/gobject-introspection-0.10.8:= )
+ python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )"
+
+pkg_setup() {
+ G2CONF+="--disable-test-coverage
+ --disable-static
+ $(use_enable introspection)
+ $(use_enable vala)
+ $(use_with python)"
+ use python && python-single-r1_pkg_setup
+}