summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2015-05-27 20:04:41 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2015-05-27 20:04:41 +0000
commit60eb5bcc5943222f3cb1dfab3d63a10c982c39fb (patch)
tree9eb57b94a890a62322ee0e015b86b9fa44989885 /app-emulation/libguestfs-appliance
parentarm stable wrt bug #535598 (diff)
downloadgentoo-2-60eb5bcc5943222f3cb1dfab3d63a10c982c39fb.tar.gz
gentoo-2-60eb5bcc5943222f3cb1dfab3d63a10c982c39fb.tar.bz2
gentoo-2-60eb5bcc5943222f3cb1dfab3d63a10c982c39fb.zip
Keep README.fixed in /usr/share/guestfs/appliance, see RedHat bug https://bugzilla.redhat.com/show_bug.cgi?id=1183780. Thanks to lk4d4 for report.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key F8DBDADE)
Diffstat (limited to 'app-emulation/libguestfs-appliance')
-rw-r--r--app-emulation/libguestfs-appliance/ChangeLog12
-rw-r--r--app-emulation/libguestfs-appliance/libguestfs-appliance-1.28.1-r1.ebuild45
2 files changed, 55 insertions, 2 deletions
diff --git a/app-emulation/libguestfs-appliance/ChangeLog b/app-emulation/libguestfs-appliance/ChangeLog
index c3db0541f9aa..c1430f650a86 100644
--- a/app-emulation/libguestfs-appliance/ChangeLog
+++ b/app-emulation/libguestfs-appliance/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-emulation/libguestfs-appliance
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libguestfs-appliance/ChangeLog,v 1.5 2014/12/05 18:56:43 maksbotan Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libguestfs-appliance/ChangeLog,v 1.6 2015/05/27 20:04:41 maksbotan Exp $
+
+*libguestfs-appliance-1.28.1-r1 (27 May 2015)
+
+ 27 May 2015; Maxim Koltsov <maksbotan@gentoo.org>
+ +libguestfs-appliance-1.28.1-r1.ebuild:
+ Keep README.fixed in /usr/share/guestfs/appliance, see RedHat bug
+ https://bugzilla.redhat.com/show_bug.cgi?id=1183780. Thanks to lk4d4 for
+ report.
05 Dec 2014; Maxim Koltsov <maksbotan@gentoo.org>
-libguestfs-appliance-1.20.0.ebuild, -libguestfs-appliance-1.24.8.ebuild,
diff --git a/app-emulation/libguestfs-appliance/libguestfs-appliance-1.28.1-r1.ebuild b/app-emulation/libguestfs-appliance/libguestfs-appliance-1.28.1-r1.ebuild
new file mode 100644
index 000000000000..ebc86371c663
--- /dev/null
+++ b/app-emulation/libguestfs-appliance/libguestfs-appliance-1.28.1-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libguestfs-appliance/libguestfs-appliance-1.28.1-r1.ebuild,v 1.1 2015/05/27 20:04:41 maksbotan Exp $
+
+EAPI=5
+
+CHECKREQS_DISK_USR=500M
+CHECKREQS_DISK_BUILD=500M
+
+inherit check-reqs
+
+DESCRIPTION="VM appliance disk image used in libguestfs package"
+HOMEPAGE="http://libguestfs.org/"
+SRC_URI="http://libguestfs.org/download/binaries/appliance/appliance-${PV}.tar.xz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-arch/xz-utils"
+# Mixing libguestfs versions causes weird problems. #501588
+RDEPEND="!<app-emulation/libguestfs-${PV}"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ # We'll unpack the tarball directly into ${D} to speed up install.
+ # Otherwise we need to duplicate hundreds of data.
+ :
+}
+
+src_install() {
+ dodir /usr/share/guestfs
+ cd "${ED}"/usr/share/guestfs
+ unpack ${A}
+ cd appliance || die
+ dodoc README*
+ # Don't rm README.* here, at least README.fixed is needed for libguestfs, see
+ # https://bugzilla.redhat.com/show_bug.cgi?id=1183780
+ chmod 755 . || die
+ chmod 644 * || die
+
+ newenvd "${FILESDIR}"/env.file 99"${PN}"
+}