summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2010-05-26 17:43:03 +0000
committerDoug Goldstein <cardoe@gentoo.org>2010-05-26 17:43:03 +0000
commit724c805becade46d647c2d9895f66e373100e778 (patch)
tree3151e5ea44c4eb0e938dca13a77eb367071c109e /app-emulation/kvm-kmod
parentOld. (diff)
downloadgentoo-2-724c805becade46d647c2d9895f66e373100e778.tar.gz
gentoo-2-724c805becade46d647c2d9895f66e373100e778.tar.bz2
gentoo-2-724c805becade46d647c2d9895f66e373100e778.zip
latest upstream version bump
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/kvm-kmod')
-rw-r--r--app-emulation/kvm-kmod/ChangeLog7
-rw-r--r--app-emulation/kvm-kmod/kvm-kmod-2.6.34.ebuild66
2 files changed, 72 insertions, 1 deletions
diff --git a/app-emulation/kvm-kmod/ChangeLog b/app-emulation/kvm-kmod/ChangeLog
index a85dd8d9c5d6..025f831efc99 100644
--- a/app-emulation/kvm-kmod/ChangeLog
+++ b/app-emulation/kvm-kmod/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/kvm-kmod
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/kvm-kmod/ChangeLog,v 1.10 2010/04/29 01:59:15 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/kvm-kmod/ChangeLog,v 1.11 2010/05/26 17:43:03 cardoe Exp $
+
+*kvm-kmod-2.6.34 (26 May 2010)
+
+ 26 May 2010; Doug Goldstein <cardoe@gentoo.org> +kvm-kmod-2.6.34.ebuild:
+ latest upstream version bump
*kvm-kmod-2.6.33.3 (29 Apr 2010)
*kvm-kmod-2.6.32.12 (29 Apr 2010)
diff --git a/app-emulation/kvm-kmod/kvm-kmod-2.6.34.ebuild b/app-emulation/kvm-kmod/kvm-kmod-2.6.34.ebuild
new file mode 100644
index 000000000000..c93360c7d4fd
--- /dev/null
+++ b/app-emulation/kvm-kmod/kvm-kmod-2.6.34.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/kvm-kmod/kvm-kmod-2.6.34.ebuild,v 1.1 2010/05/26 17:43:03 cardoe Exp $
+
+EAPI="2"
+
+inherit eutils linux-mod
+
+SRC_URI="mirror://sourceforge/kvm/${P}.tar.bz2"
+
+DESCRIPTION="Kernel-based Virtual Machine kernel modules"
+HOMEPAGE="http://www.linux-kvm.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ linux-info_pkg_setup
+ if ! linux_chkconfig_present KVM; then
+ eerror "KVM now needs CONFIG_KVM built into your kernel, even"
+ eerror "if you're using the external modules from this package."
+ eerror "Please enable KVM support in your kernel, found at:"
+ eerror
+ eerror " Virtualization"
+ eerror " Kernel-based Virtual Machine (KVM) support"
+ eerror
+ die "KVM support not detected!"
+ fi
+ BUILD_TARGETS="all"
+ MODULE_NAMES="kvm(kernel/arch/x86/kvm/:${S}:${S}/x86)"
+ MODULE_NAMES="${MODULE_NAMES} kvm-intel(kernel/arch/x86/kvm/:${S}:${S}/x86)"
+ MODULE_NAMES="${MODULE_NAMES} kvm-amd(kernel/arch/x86/kvm/:${S}:${S}/x86)"
+ linux-mod_pkg_setup
+}
+
+src_configure() {
+ local conf_opts
+
+ conf_opts="--kerneldir=$KV_DIR"
+
+ if has_multilib_profile && [[ "${DEFAULT_ABI}" == "x86" ]] ; then
+ conf_opts="$conf_opts --arch=x86"
+ fi
+
+ ./configure ${conf_opts} || die "configure failed"
+}
+
+src_compile() {
+ linux-mod_src_compile
+}
+
+src_install() {
+ linux-mod_src_install
+}
+
+pkg_preinst() {
+ find /lib/modules/${KV_FULL} -name 'kvm*.ko' -type f -delete
+
+ linux-mod_pkg_preinst
+}