summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMalcolm Lashley <malc@gentoo.org>2005-02-24 01:59:37 +0000
committerMalcolm Lashley <malc@gentoo.org>2005-02-24 01:59:37 +0000
commit32d812ac607067e0497c3cf5cbdd6dfed55ca18b (patch)
tree0c5bd69c7f55d3894ac3ec3121885ba92666a4fa /app-emulation/hercules
parentAdded additional else statement for non-DVD builds (bad Wolfie...) and closes... (diff)
downloadgentoo-2-32d812ac607067e0497c3cf5cbdd6dfed55ca18b.tar.gz
gentoo-2-32d812ac607067e0497c3cf5cbdd6dfed55ca18b.tar.bz2
gentoo-2-32d812ac607067e0497c3cf5cbdd6dfed55ca18b.zip
Version bump - add ~amd64 - Bugs #71067 #74192
(Portage version: 2.0.51.16)
Diffstat (limited to 'app-emulation/hercules')
-rw-r--r--app-emulation/hercules/ChangeLog5
-rw-r--r--app-emulation/hercules/Manifest4
-rw-r--r--app-emulation/hercules/files/digest-hercules-3.021
-rw-r--r--app-emulation/hercules/hercules-3.02.ebuild64
4 files changed, 72 insertions, 2 deletions
diff --git a/app-emulation/hercules/ChangeLog b/app-emulation/hercules/ChangeLog
index 8031f2ba72e6..698b7d6315a6 100644
--- a/app-emulation/hercules/ChangeLog
+++ b/app-emulation/hercules/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-emulation/hercules
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/hercules/ChangeLog,v 1.13 2005/01/01 14:13:22 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/hercules/ChangeLog,v 1.14 2005/02/24 01:59:36 malc Exp $
+
+ 24 Feb 2005; Malcolm Lashley <malc@gentoo.org> :
+ Version bump - add ~amd64 - Bugs #71067 #74192
10 Apr 2004; Michael Sterrett <mr_bones_@gentoo.org>
hercules-2.17.1-r1.ebuild, hercules-3.00.ebuild, hercules-3.01.ebuild:
diff --git a/app-emulation/hercules/Manifest b/app-emulation/hercules/Manifest
index c4679732b35e..0c492ec12de4 100644
--- a/app-emulation/hercules/Manifest
+++ b/app-emulation/hercules/Manifest
@@ -1,8 +1,10 @@
MD5 99ea66f1c6302de5c2dbb229243fd234 ChangeLog 1432
MD5 23af55e92212bdafac1a86104c3d63ce hercules-2.17.1-r1.ebuild 1752
MD5 012376e2fce2ca6a429af80965551205 hercules-3.00.ebuild 1888
-MD5 968c7b72b7bbecb7091f27ff50f152c3 hercules-3.01.ebuild 1956
MD5 1795fda604c41d53f524294b6d6daf35 metadata.xml 645
+MD5 650ca4e6268a564f4a2cc43f04cc8416 hercules-3.02.ebuild 1959
+MD5 968c7b72b7bbecb7091f27ff50f152c3 hercules-3.01.ebuild 1956
MD5 e09f0c008fb3b02510eb63971a66ecf3 files/digest-hercules-2.17.1-r1 68
MD5 64b6313ec62cc77a8a5b021ab426a67d files/digest-hercules-3.00 66
MD5 420850c3a641b2b1c34c6a9794e2278c files/digest-hercules-3.01 66
+MD5 1071b00be391084f80adf7982a54e2f8 files/digest-hercules-3.02 66
diff --git a/app-emulation/hercules/files/digest-hercules-3.02 b/app-emulation/hercules/files/digest-hercules-3.02
new file mode 100644
index 000000000000..e353d35d47ec
--- /dev/null
+++ b/app-emulation/hercules/files/digest-hercules-3.02
@@ -0,0 +1 @@
+MD5 d765ad315a1eba281bd816e63d854dc5 hercules-3.02.tar.gz 1832443
diff --git a/app-emulation/hercules/hercules-3.02.ebuild b/app-emulation/hercules/hercules-3.02.ebuild
new file mode 100644
index 000000000000..8a83bbe8aa17
--- /dev/null
+++ b/app-emulation/hercules/hercules-3.02.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/hercules/hercules-3.02.ebuild,v 1.1 2005/02/24 01:59:37 malc Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Hercules System/370, ESA/390 and zArchitecture Mainframe Emulator"
+HOMEPAGE="http://www.conmicro.cx/hercules/"
+SRC_URI="http://www.conmicro.cx/hercules/${P}.tar.gz"
+
+LICENSE="QPL-1.0"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc ~amd64"
+IUSE=""
+
+DEPEND="virtual/libc
+ app-arch/bzip2"
+
+
+src_compile() {
+ replace-flags -march=pentium3 -mcpu=pentium3
+ local mycflags
+ mycflags="${CFLAGS}"
+ unset CFLAGS ; unset CXXFLAGS
+
+ econf \
+ --enable-optimization="${mycflags}" \
+ --enable-cckd-bzip2 \
+ --enable-het-bzip2 \
+ --enable-setuid-hercifc \
+ --enable-custom="Gentoo Linux ${PF}.ebuild" \
+ --enable-multi-cpu=7 \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install
+ dohtml -r html/
+ insinto /usr/share/hercules
+ doins hercules.cnf
+ dodoc README.COMMADPT README.CVS README.ECPSVM README.HDL \
+ README.NETWORKING README.OSX README.TAPE \
+ RELEASE.NOTES CHANGES
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Hercules System/370, ESA/390 and zArchitecture Mainframe"
+ einfo "Emulator has been installed. Some useful utility files have"
+ einfo "been placed in /usr/share/hercules. For detailed configuration"
+ einfo "and operating instructions, see http://www.conmicro.cx/hercules"
+ einfo
+ einfo "In order to use Hercules you will need a guest operating"
+ einfo "system. There are several flavors of 'Linux for S/390' and"
+ einfo "'Linux for zSeries' available, or if you want that 'Big Iron'"
+ einfo "feel, you can download several real mainframe operating systems"
+ einfo "such as OS/360, DOS/VS, MVS, or VM370 from http://www.cbttape.org"
+ einfo
+ einfo "Hercules is also capable of running OS/390, z/OS, and z/VM with an"
+ einfo "appropriate license."
+ einfo
+}