summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2009-01-04 12:07:15 +0000
committerRaúl Porcel <armin76@gentoo.org>2009-01-04 12:07:15 +0000
commit367ab43eb29f6414ae22d48cb75fc8fa86c17bd8 (patch)
treec266d0620fa62e4ce061ef2cde73a42cdc11606a /app-emulation/gxemul/gxemul-0.4.7.ebuild
parentclean up (diff)
downloadgentoo-2-367ab43eb29f6414ae22d48cb75fc8fa86c17bd8.tar.gz
gentoo-2-367ab43eb29f6414ae22d48cb75fc8fa86c17bd8.tar.bz2
gentoo-2-367ab43eb29f6414ae22d48cb75fc8fa86c17bd8.zip
Version bump
(Portage version: 2.1.6.4/cvs/Linux 2.6.27-gentoo-r7 i686)
Diffstat (limited to 'app-emulation/gxemul/gxemul-0.4.7.ebuild')
-rw-r--r--app-emulation/gxemul/gxemul-0.4.7.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-emulation/gxemul/gxemul-0.4.7.ebuild b/app-emulation/gxemul/gxemul-0.4.7.ebuild
new file mode 100644
index 000000000000..08d2771542dc
--- /dev/null
+++ b/app-emulation/gxemul/gxemul-0.4.7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/gxemul/gxemul-0.4.7.ebuild,v 1.1 2009/01/04 12:07:15 armin76 Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A Machine Emulator, Mainly emulates MIPS, but supports other CPU types."
+HOMEPAGE="http://gavare.se/gxemul/"
+SRC_URI="http://gavare.se/gxemul/src/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="X"
+
+RDEPEND="X? ( x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXdmcp )"
+
+DEPEND="${RDEPEND}
+ X? ( x11-proto/xproto )"
+
+src_compile() {
+ tc-export CC
+ local myconf=""
+
+ use X || myconf="${myconf} --disable-x"
+
+ einfo "Configuring with: ${myconf}"
+ ./configure ${myconf} || die "configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin gxemul || die "gxemul not found in ${S}"
+ doman man/gxemul.1
+ dodoc HISTORY LICENSE README RELEASE TODO
+ dohtml doc/*
+}